Guest session fails to log out

Bug #1627310 reported by Sean Davis
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Fix Released
Undecided
Unassigned
xfce4-session (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Vanilla Xubuntu install. When logging out from the guest session, everything is closed and the desktop wallpaper is the only thing that remains. The user is never returned to the login screen.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: xfce4-session 4.12.1-3ubuntu2
ProcVersionSignature: Ubuntu 4.8.0-11.12-generic 4.8.0-rc6
Uname: Linux 4.8.0-11-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Sep 24 09:18:31 2016
InstallationDate: Installed on 2016-09-24 (0 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160921)
SourcePackage: xfce4-session
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
DistroRelease: Ubuntu 16.10
InstallationDate: Installed on 2016-09-24 (0 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160921)
Package: lightdm 1.19.4-0ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.8.0-11.12-generic 4.8.0-rc6
Tags: yakkety
Uname: Linux 4.8.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Revision history for this message
Sean Davis (bluesabre) wrote :
tags: added: apport-collected
description: updated
Revision history for this message
Sean Davis (bluesabre) wrote : Dependencies.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote : JournalErrors.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote : LightdmDisplayLog.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote : LightdmGreeterLog.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote : LightdmLog.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote : LightdmUsersConfig.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote : ProcEnviron.txt

apport information

Revision history for this message
Sean Davis (bluesabre) wrote :

Comments #2 - 8 are from using apport-collect with lightdm

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in xfce4-session (Ubuntu):
status: New → Confirmed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Tested with Ubuntu MATE, and the guest session works fine there, so the issue is probably not caused by lightdm. Possibly the Xubuntu specific parts of lightdm-gtk-greeter should be looked at.

Revision history for this message
Kev Bowring (flocculant) wrote :
Download full text (3.4 KiB)

test@test-Standard-PC-i440FX-PIIX-1996:~$ dmesg | grep DENIED
[ 50.801345] audit: type=1400 audit(1474991831.922:27): apparmor="DENIED" operation="mknod" profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/1722/fd/2" pid=1722 comm="lightdm-session" requested_mask="c" denied_mask="c" fsuid=996 ouid=996
[ 50.803080] audit: type=1400 audit(1474991831.922:28): apparmor="DENIED" operation="mknod" profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/1724/fd/2" pid=1724 comm="lightdm-session" requested_mask="c" denied_mask="c" fsuid=996 ouid=996
[ 50.932125] audit: type=1400 audit(1474991832.054:29): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=1846 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 50.941490] audit: type=1400 audit(1474991832.062:30): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=1862 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 50.946784] audit: type=1400 audit(1474991832.066:31): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=1866 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 50.949328] audit: type=1400 audit(1474991832.070:32): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=1870 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 50.951780] audit: type=1400 audit(1474991832.074:33): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=1874 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 50.954141] audit: type=1400 audit(1474991832.074:34): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=1878 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 62.395078] audit: type=1400 audit(1474991843.538:35): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=2127 comm="initctl" family="unix" sock_type="stream" protocol=0 requested_mask="send receive accept" denied_mask="send accept" addr="@/com/ubuntu/upstart-session/996/1720" peer_addr=none peer="unconfined"
[ 62.397757] audit: type=1400 audit(1474991843.542:36): apparmor="DENIED" operation="connect" profile="/usr/lib/lightdm/lightdm-guest-session" pid=2129 co...

Read more...

Kev Bowring (flocculant)
Changed in lightdm (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Fix Released
Kev Bowring (flocculant)
Changed in xfce4-session (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints