all window title bars missing, xfwm4 does not start after boot

Bug #1277738 reported by Miro Janosik on 2014-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-session (Ubuntu)
Undecided
Unassigned

Bug Description

Used ubuntu + xfce for many months, few weeks ago I found out that after reboot my windows are missing title bars and alt+tab behavior was not working.
I have found that it can be solved with running xfwm4 each time. I have solved it permanently by adding xfwm4 to run at startup.

OS: Ubuntu 12.04.4 LTS with xfce on top.
xfwm4 package version: 4.8.3-1ubuntu1.1

Bug is described also here by other user(s): http://askubuntu.com/questions/47445/massive-xubuntu-desktop-malfunction

It looks like xfce4-session is restoring a saved session without xfwm4. Please delete the content of ~/.cache/sessions/ and disable your custom startup item for xfwm4. Does xfwm4 now start automatically after login?

affects: xfwm4 (Ubuntu) → xfce4-session (Ubuntu)
Changed in xfce4-session (Ubuntu):
status: New → Incomplete
Miro Janosik (miro-janosik-geo) wrote :

I have tested your suggested steps:
* delete the content of ~/.cache/sessions/
* remove my additional startup item for xfwm4
* reboot of PC

It works, problem is solved.

Thanks for verifying that the suggested steps resolved the problem. I think that we can mark this report as duplicate of bug 978333.

Changed in xfce4-session (Ubuntu):
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers