xscreensaver-command is slow at locking

Bug #1229486 reported by ToZ on 2013-09-24
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
xfce4-session (Ubuntu)
Low
Unassigned
xscreensaver (Ubuntu)
Low
Unassigned

Bug Description

$ lsb_release -rd
Description: Ubuntu Saucy Salamander (development branch)
Release: 13.10

$ apt-cache policy xfce4-session
xfce4-session:
  Installed: 4.10.1-1ubuntu1
  Candidate: 4.10.1-1ubuntu1
  Version table:
 *** 4.10.1-1ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy xscreensaver
xscreensaver:
  Installed: 5.15-3ubuntu1
  Candidate: 5.15-3ubuntu1
  Version table:
 *** 5.15-3ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

Actual: When resuming from suspend, the desktop is visible for a while before the screensaver clicks on.
Expected: The system will resume and only display the screensaver login screen.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xfce4-session 4.10.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
Date: Mon Sep 23 21:14:50 2013
InstallationDate: Installed on 2013-09-24 (0 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Beta amd64 (20130923)
MarkForUpload: True
SourcePackage: xfce4-session
UpgradeStatus: No upgrade log present (probably fresh install)

ToZ (toz) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1229486

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-session (Ubuntu):
status: New → Confirmed
ToZ (toz) wrote :

pm-utils is not installed by default on 13.10. Once installed, the screen locks properly on suspend and resumes to the xscreensaver login screen without displaying any of the desktop.

Pasi Lallinaho (knome) on 2013-09-27
summary: - Lock screen before sleep doesn't work
+ Resuming from suspend flashes the desktop, then shows unlocking dialog

This bug does also affect regular Unity without Xfce even being installed!

The Xfce session runs "xscreensaver-command -lock" to lock the screen. This command waits exactly 1 second before blanking/locking the screen to make sure, that the screen saver will not get deactivated on key release. Bypassing this delay with an optional argument could improve the situation.

Tormod Volden (tormodvolden) wrote :

Thaddäus, that is well spotted and a good idea. The existing sleep(1) call is kind of a hack. Maybe it can be enhanced with another hack: Skip the sleep if isatty() returns failure. I will ask upstream.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

Upstream is favorable to the isatty() hack. I have sent him a patch, and I will also apply it in Debian's 5.22-1 (to be released real soon). I have also applied this to the pre-release in my PPA if anyone wants to test it.

Thaddäus, can you please advice in bug 1054299 on which program is calling xscreensaver-command without waiting for it to complete before proceeding to suspend?

Tormod Volden (tormodvolden) wrote :

The attachment "patch from Debian" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Jarno Suni (jarnos) wrote :

There are two older bug reports about this issue, namely Bug #423930 and Bug #1054299 . I think this one should be marked as a duplicate of either one. This one was originally reported agains xfce4-session, but in later comments fixing has been tried to do in xscreensaver's code. Please see https://bugs.launchpad.net/ubuntu/+source/xfce4-session/+bug/1054299/comments/8

Tormod Volden (tormodvolden) wrote :

Jarno, the important bug is not in xscreensaver but in whatever calls xscreensaver-command. However there is also an issue in xscreensaver that makes the other bug much more prominent. I therefore have kept this bug report for tracking the xscreensaver part, which is fixed in xscreensaver 5.22-1.

Changed in xfce4-session (Ubuntu):
status: Confirmed → Invalid
summary: - Resuming from suspend flashes the desktop, then shows unlocking dialog
+ xscreensaver-command is slow at locking
Changed in xfce4-session:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Jarno Suni (jarnos) wrote :

Xscreensaver's fading setting changes how fast "xscreensaver-command -lock" exits and hides desktop (although fading does not work in ubuntu 13.10, in my experience).

Changed in xfce4-session (Ubuntu):
importance: Undecided → High
Changed in xscreensaver (Ubuntu):
importance: Undecided → High
importance: High → Low
Changed in xfce4-session (Ubuntu):
importance: High → Low
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Low
no longer affects: xfce4-session
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package xscreensaver - 5.26-1ubuntu1

---------------
xscreensaver (5.26-1ubuntu1) utopic; urgency=low

  * Dropped Ubuntu changes:
    - Ubuntu delta to the screensavers sets.
    - Keep Debian Vcs-* links instead of the ~ubuntu-desktop team bzr
      repository: the Desktop team does not have interest any more.
    - The Ubuntu changes to the descriptions.
  * Merge from Debian unstable. (LP: #1283459) Remaining changes:
    - debian/control:
      + Breaks/Replaces: the old changes are not needed anymore, but the
        new changes the screensavers sets needs it.
    - debian/rules:
      + Use /usr/share/backgrounds as image directory.
      + Add translation domain to .desktop files.
    - debian/source_xscreensaver.py:
      + Add apport hook.
    - debian/xscreensaver.dirs:
      + Install /usr/share/backgrounds. By default, settings search in
        /usr/share/backgrounds and without it, it displays an error.
    - debian/patch/90_ubuntu-branding.patch: Use Ubuntu branding.
    - debian/patches/60_sequential_glslideshow.patch:
      + Allow going through images sequentially rather than just at random in
        the GLSlideshow hack.

xscreensaver (5.26-1) unstable; urgency=low

  * New upstream release 5.26, changes since 5.23:
    - Updated feed-loading for recent Flickr changes.
    - Updated `webcollage' for recent Google changes.
    - Added Instagram and Bing as `webcollage' image sources.
    - Updated to latest autoconf.
    - Bug fixes.
  * Drop patch applied upstream:
    - debian/patches/12_upstream_use_cppflags.patch
  * Bump Standards-Version to 3.9.5 (no changes needed)

xscreensaver (5.23-1) unstable; urgency=low

  * New upstream release 5.23 (Closes: #729311)
    - New hack, geodesic
    - More heuristics for using RSS feeds as image sources
    - Improved Wikipedia parser
    - Updated webcollage for recent Flickr changes
    - Added Android to bsod
    - Made quasicrystal work on weak graphics cards
    - Better compression on icons, plists and XML files
    - Reverted that DEACTIVATE change. Bad idea.
    - Phosphor now supports amber as well as green
  * Dropped patches applied upstream:
    - 12_upstream_quasicrystal_texture_width.patch
    - 14_upstream_hexadrop_keyboard_exit.patch
    - 15_upstream_activate_faster_nontty.patch
  * debian/patches/12_upstream_use_cppflags.patch:
    Make sure CPPFLAGS are used (fixes hardening warnings)
  * debian/control: Update VCS fields (fixes Lintian warning)

xscreensaver (5.22-1) unstable; urgency=low

  * New upstream release 5.22 (Closes: #699833), changes since 5.15:
    - XInput devices now also ignore small mouse motions
    - Loading images via RSS feeds is much improved
    - Enlarged the texture image for lament
    - Made pipes be ridiculously less efficient, but spin
    - Added better mouse control to rubik, cube21, crackberg, and julia
    - Cosmetic improvements to queens and endgame
    - sonar can now ping local subnet on DHCP
    - Most savers now resize/rotate properly
    - New version of `fireworkx'
    - Minor fixes to `distort', `fontglide', `xmatrix'
    - New MacOS crash in `bsod'
    - New mode in `lcdscrub'
    - Gnome/KD...

Read more...

Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.