systemd-shim removal causes restart to logout

Bug #1221809 reported by Elfy on 2013-09-06
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
xfce4-session (Ubuntu)
Undecided
Unassigned

Bug Description

Had reports of systemd-shim not being installed following upgrade from 13.04 to 13.10.

This led to restart of machine looping to login screen.

Removal of systemd-shim causes same issue.

Something missing in dependencies perhaps.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xfce4-session 4.10.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
Date: Fri Sep 6 16:41:39 2013
InstallationDate: Installed on 2013-04-28 (131 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
MarkForUpload: True
SourcePackage: xfce4-session
UpgradeStatus: No upgrade log present (probably fresh install)

Elfy (elfy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-session (Ubuntu):
status: New → Confirmed
jose (o1485726) wrote :

upgraded from 13.04 to 13.10 beta, using lxde.
installing systemd-shim fixes this error message from the logout menu: "gdbus.error:org.freedesktop.dbus.error.serviceunknown: the name org.freedesktop.systemd1 was not provided by any .service file"

After the switch to systemd/logind xfce4-session should now recommend systemd-shim (it did recommend consolekit before its removal).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
affects: xfce4-power-manager (Ubuntu) → xubuntu-meta (Ubuntu)
no longer affects: xubuntu-meta (Ubuntu)

jose (o1485726) wrote on 2013-09-11: #3
upgraded from 13.04 to 13.10 beta, using lxde.
installing systemd-shim fixes this error message from the logout menu:
"gdbus.error:org.freedesktop.dbus.error.serviceunknown: the name org.freedesktop.systemd1 was not provided by any .service file"

I am also getting this error after upgrading from Lubuntu 13.04 to 13.10 (not a fresh install). However, after installing systemd-shim, I now get the following error when attempting to shutdown or reboot:
"GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1"

Toshiba Satellite A135-S4427
Lubuntu: 13.10

Martin Pitt (pitti) wrote :

It's a recommends for a reason that you can use the other services (hostnamectl, etc.) without -shim. But indeed logind is a rather critical piece of infrastructure these days, so I lifted the recommends to a depends.

Changed in systemd (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 204-5ubuntu3

---------------
systemd (204-5ubuntu3) trusty; urgency=low

  * Re-add login-monitor-no-machine.patch to quilt series.
 -- Martin Pitt <email address hidden> Thu, 07 Nov 2013 10:05:33 +0100

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
Changed in xfce4-session (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers