Ubuntu

Session is not save in Xfce

Reported by Jakub Jankiewicz on 2013-06-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4-session (Ubuntu)
Undecided
Unassigned

Bug Description

I use Ubuntu with XFce (10.10) and I when I turn off computer the session was saving, all programs positions and hidden menu in terminal emulator was saved. but when I've install Xubuntu 13.04 the session is no longer saved and when I run Terminal emulator I need to turn off the menu. I have in Session setting save session after logout (don't know exact option name because I have polish translation) and in Xfconf Editor I have set AutoSave and SaveOnExit to true and session is not save.

I copy some settings from old Ubuntu.

Jakub Jankiewicz (jcubic) wrote :

when I run ps aux | grep xfwm4 there is no --sm-client-id after xfwm4.

Jakub Jankiewicz (jcubic) wrote :

When I click save session in session setting, the session is restored on login, but it's not done automaticaly.

affects: xfce4 (Ubuntu) → xfce4-session (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-session (Ubuntu):
status: New → Confirmed

Does clearing the current session cache (Settings Manager > Session and Startup > Session) resolve the problem?

Jakub Jankiewicz (jcubic) wrote :

I think, that the issue was fixed in 13.10 (I've upgraded recently), need to do few more tests to be sure.

Jakub Jankiewicz (jcubic) wrote :

Confirm session is saved in 13.10.

I am closing this report, because the bug has been fixed at some point and cannot be confirmed in Ubuntu 13.10.

Changed in xfce4-session (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers