xfce4-sensors tries to use hddtemp even if it's missing

Bug #1003553 reported by Ivan Frederiks on 2012-05-23
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Xfce4-sensors-plugin
Fix Released
Medium
xfce4-sensors-plugin (Debian)
Confirmed
Unknown
xfce4-sensors-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

I found out, that my hdd does not have temperature sensor, so I removed hddtemp. Now when I launch xfce4-sensors it displays annoying notification about missing hddtemp (see attachment). This does not seem to be right way.

I use Ubuntu 12.04 i386 with xfce 4.10 from xubuntu ppa.

xfce4-sensors-plugin:
  Installed: 1.2.3-2+ppa1
  Candidate: 1.2.3-2+ppa1
  Version table:
 *** 1.2.3-2+ppa1 0
        500 http://ppa.launchpad.net/xubuntu-dev/xfce-4.10/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     1.2.3-2 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages

Hi,

a Debian user requested that sensor plugin would not warn every time about missing setuid stuff for hddtemp. If it's not configured with setuid bit, sensors should warn the fist time, but ignore it completely the following times.

Cheers,

--
Yves-Alexis

And if hddtemp is not present at all, same thing, the plugin could warn once, but only once.

there you go, this also fixed some null pointer problems.

Wanna close this one, too?

In , Xfce (xfce) wrote :

"there you go, this also fixed some null pointer problems."

Ivan Frederiks (idfred) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-sensors-plugin (Ubuntu):
status: New → Confirmed
greyor (greyor) wrote :

This issue has been bugging me lately for sure.

However, I think I've found a workaround:

In the configuration file for xfce4-sensors-plugin, located at $HOME/.config/xfce4/panel/xfce4-sensors-plugin-33.rc,
there is an option "Suppress_Hddtemp_Message" which accepts a boolean value.

In my configuration, it was set to "False," but setting it to "True" will in fact solve the problem.

I've attached a patch, although changing that one line in the file should be easy enough without the patch.
Hope this helps.

The attachment "Patch for xfce4-sensors-plugin-33.rc" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Seems this one is back (since a few months/years, actually, so reopening).

(In reply to comment #5)
> Seems this one is back (since a few months/years, actually, so reopening).

You may know that you can build without hddtemp support. What version do you use? There hasn't been any new source commit since a long time, last: 2012-12-28 20:51:53 (GMT).

(In reply to comment #6)
> (In reply to comment #5)
> > Seems this one is back (since a few months/years, actually, so reopening).
>
> You may know that you can build without hddtemp support.

I know. We build for all the distribution users, not only one people, so we do enable it at build time. What we need is a way to have it disabled at runtime.

Exactly what this bug report was about. The fix was committed, but there was a regression somehow at one point.

> What version do
> you use? There hasn't been any new source commit since a long time, last:
> 2012-12-28 20:51:53 (GMT).

1.2.5.

(In reply to Yves-Alexis Perez from comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Seems this one is back (since a few months/years, actually, so reopening).
> >
> > You may know that you can build without hddtemp support.
>
> I know. We build for all the distribution users, not only one people, so we
> do enable it at build time. What we need is a way to have it disabled at
> runtime.
>
> Exactly what this bug report was about. The fix was committed, but there was
> a regression somehow at one point.
>
> > What version do
> > you use? There hasn't been any new source commit since a long time, last:
> > 2012-12-28 20:51:53 (GMT).
>
> 1.2.5.

OK, what "warnings" are found? The current code intendedly alwys showed the notifications, but it was possible to shutdown the warnings dialog.

Gonna change it to only display the notification once, but for any user missing it, there will be trouble helping to track down issues with hddtemp.

commit bcad538..4ada645 : suppress option is now also respected for notifications as well as for dialogs.

Changed in xfce4-sensors-plugin (Debian):
status: Unknown → Confirmed
asgard2 (kamp000x) wrote :

On every login, this value in the config file is reset to false.
14.10 (Utopic)
ii xfce4-sensors-plugin 1.2.5-2 amd64 hardware sensors plugin for the Xfce4 panel

Changed in xfce4-sensors-plugin:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.