xfce4-screenshooter "open with" feature does not work

Bug #572823 reported by Igor Tarasov on 2010-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-screenshooter (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xfce4-screenshooter

Currentlly there is version 1.6.0 of xfce4-screenshooter in lucid repository. The problem is that at least with russian locale "open with" feature does not work due to space in temporary file name and a bug that it does not escape file path. So, in version 1.6.0 feature "open with" is unusable in some locales.

There is version 1.7.9 available at author's site and this bug is already fixed there. Also, this version is present in Debian testing repositories.

Lionel Le Folgoc (mrpouit) wrote :

1.7.9-1 is in maverick.

Changed in xfce4-screenshooter (Ubuntu):
status: New → Fix Released
Igor Tarasov (tarasov-igor) wrote :

No hope for lucid?

Lionel Le Folgoc (mrpouit) wrote :

1.7.9, no hope. But if you can point me to the affected translations (e.g. the ones where the space should be removed), this can be fixed in lucid. FWIW, I've already patched the russian po file to remove all extra trailing spaces.

Lionel Le Folgoc (mrpouit) wrote :

I found these strings:

> #: ../lib/screenshooter-dialogs.c:283
> msgid "Screenshot.png"
> msgstr "Снимок экрана.png"

> #: ../lib/screenshooter-dialogs.c:300
> #, c-format
> msgid "Screenshot-%d.png"
> msgstr "Снимок экрана-%d.png"

If the fix is as straightforward as removing the extra space in the middle, that can be fixed easily (I can't handle alone something more complicated as I can't speak/write Russian :p).

Thanks.

Igor Tarasov (tarasov-igor) wrote :

Yep, replacing space with underscore or dash should work.

Adolfo Jayme (fitojb) on 2013-06-18
no longer affects: xfce4-screenshooter (Ubuntu Lucid)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions