xfhelp4 is not installed

Bug #1054407 reported by Sean Davis on 2012-09-22
46
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xfce-screenshooter-plugin
Fix Released
Medium
xfce4-mailwatch-plugin
Unknown
Unknown
xfce4-power-manager
Fix Released
Medium
xfce4-mailwatch-plugin (Ubuntu)
Low
Unassigned
xfce4-power-manager (Ubuntu)
Low
Unassigned
xfce4-screenshooter (Ubuntu)
Low
Unassigned

Bug Description

xubuntu-desktop does not seem to ship 'xfhelp4', which is required by at least one application:

xfce4-screenshooter: Help button

xfhelp4 seems to be in the 'xfce4-utils' package.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xubuntu-desktop 2.161
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Fri Sep 21 21:30:53 2012
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120921)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 4404
use xfce_dialog_show_help() and remove bundled documentation

xfce4-power-manager still calls xfhelp4 on bundled documentation which is obviously broken since xfce-utils has been removed from Xfce 4.10.
Attached patch calls xfce_dialog_show_help() instead and removes the bundled documentation.

The help function is broken with Xfce 4.10 since it relies on xfhelp4 from xfce-utils which has been removed from Xfce 4.10.

Sean Davis (bluesabre) wrote :

Created attachment 4869
Display help page

In FreeBSD we use this patch, it displays man page.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
JenniferHodgdon (yahgrp) wrote :

I got the message today "xfhelp4 is not installed" when clicking on the Help button for the Mail Watcher xfce task bar plugin app, for a newly-installed copy of Xubuntu, after adding the Mail Watcher to my task bar.

Then I tried apt-get install xfce4-utils. However, this didn't work. The response said:

Package xfce4-utils is not available, but is referred to by another package. [...] However, the following packages replace it: xfce4-session:i386 xfce4-appfinder:i386 libxfce4ui-utils:i386 xfcd4-session xfce4-appfinder libxfce4ui-utils

It appears that this is actually an upstream XFCE bug: They've gotten rid of xfhelp4, and some of the panel apps are still referencing it. In support of this conclusion, I found two related bugs on their bugzilla (neither of which was for "Mail Watcher", though one is for "Screen Shooter", which is the panel app that was reported above):
https://bugzilla.xfce.org/show_bug.cgi?id=8847 [screen shooter app]
https://bugzilla.xfce.org/show_bug.cgi?id=8846 [power manager app]

I hesitate to report the Mail Watcher to XFCE because I'm not sure if Xubuntu is running the latest version.

To reproduce this bug with Mail Watcher:
a) Right click on your XFCE toolbar, and choose Panel > Add New Items
b) Find "Mail Watcher" in the list. Click "Add" to add it to the panel.
c) Right click on the Mail Watcher app icon. Choose Properties.
d) Click the "Help" button in the bottom left.

JenniferHodgdon (yahgrp) wrote :

I decided to report the Mail Watcher issue to XFCE after all:
https://bugzilla.xfce.org/show_bug.cgi?id=10185

affects: xubuntu-meta (Ubuntu) → xfce4-screenshooter (Ubuntu)
Changed in xfce4-screenshooter (Ubuntu):
status: Confirmed → Triaged
Changed in xfce4-power-manager (Ubuntu):
status: New → Triaged
Changed in xfce4-mailwatch-plugin (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in xfce4-power-manager (Ubuntu):
importance: Undecided → Low
Changed in xfce4-screenshooter (Ubuntu):
importance: Undecided → Low
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1054407

tags: added: iso-testing
Jackson Doak (noskcaj) wrote :

This has been fixed in debian with libxfce4ui 4.10.0-4, it just need syncing

Jackson Doak (noskcaj) on 2014-01-22
Changed in xfce4-screenshooter (Ubuntu):
status: Triaged → Fix Released
Changed in xfce4-power-manager (Ubuntu):
status: Triaged → Fix Released
Changed in xfce4-mailwatch-plugin (Ubuntu):
status: Triaged → Fix Released
Changed in xfce4-power-manager:
importance: Unknown → Medium
status: Unknown → Fix Released

Created attachment 5460
Proper patch using Xfce's built-in doc launcher

I've put the actual fix that uses libxfce4util properly in bug 10197 (https://bugzilla.xfce.org/show_bug.cgi?id=10197).

Changed in xfce-screenshooter-plugin:
importance: Unknown → Medium
status: Unknown → Confirmed

Newest patch applied in commit bbc5f465bbb3743bdc755b4add311281055c9158. Marking as resolved.

Changed in xfce-screenshooter-plugin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.