Icon with x is confusing: volume could be muted or turned down to zero

Bug #1665497 reported by Boris Gjenero on 2017-02-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-pulseaudio-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

If audio is muted, then instead of the volume level arcs in front of the speaker icon, there is an x. Mute button needs to be pressed to get sound. Volume keys still affect the volume setting, but there is no visual indication of that on the icon, or any audio indication because audio is muted.

If volume is turned all of the way down, the exact same icon is displayed. The volume needs to be increased to get sound. The mute button does actually work, but nothing seems to happen when you press it, because the same icon with the x is displayed always, and there is never any sound due to volume being turned down.

If you think that sound was muted but the volume was only turned all the way down, you press the mute button, but nothing changes. Then if you try to increase the volume again nothing changes, because you just muted sound.

This is ridiculously confusing.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: xfce4-pulseaudio-plugin 0.2.4-1
ProcVersionSignature: Ubuntu 4.8.0-37.39-generic 4.8.16
Uname: Linux 4.8.0-37-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Feb 16 19:55:20 2017
SourcePackage: xfce4-pulseaudio-plugin
UpgradeStatus: Upgraded to yakkety on 2016-10-13 (126 days ago)

Boris Gjenero (boris-gjenero) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers