Ubuntu

xfce4-power-manager fails to start (receives X window system error "BadName")

Reported by Björn Schließmann on 2011-08-04
134
This bug affects 26 people
Affects Status Importance Assigned to Milestone
xfce4-power-manager
Unknown
Unknown
xfce4-power-manager (Ubuntu)
Medium
Unassigned
Oneiric
High
Unassigned
Precise
Medium
Unassigned

Bug Description

Entering "xfce4-power-manager" in a console fails silently. Upon executing "xfce4-power-manager --nodaemon", the following is displayed. Adding "--sync" to the command line changes nothing; also I cannot find debug symbol packages to get some kind of stack trace.

(xfce4-power-manager:18094): xfce4-power-manager-WARNING **: could not map keysym 1008ffa8 to keycode

The program 'xfce4-power-manager' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 295 error_code 15 request_code 149 minor_code 11)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xfce4-power-manager 1.0.10-4
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
Date: Fri Aug 5 00:22:36 2011
ProcEnviron:
 LANGUAGE=en_GB:en_US:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-power-manager
UpgradeStatus: Upgraded to oneiric on 2011-08-03 (1 days ago)

Scott Bronson (bronson) wrote :

Is there any progress with this? It's still in Xubuntu Oneiric Beta 1.

Changed in xfce4-power-manager (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

Still there in beta2, for what it's worth.

Lionel Le Folgoc (mrpouit) wrote :

Could anyone try to install the dbgsym package (cf. <https://wiki.ubuntu.com/DebuggingProgramCrash#Debug_Symbol_Packages>) and provide a trace? Thanks.

Ted (ted-l-wood) wrote :

@Lionel Fe Folgoc -- Hopefully this is what you were looking for. I'm experiencing this same issue on Ubuntu 11.10 after installing the xubuntu-desktop package on top of a standard Ubuntu 11.10 install. The output of my Backtrace attempt is attached to this post. I ran two attempts in gdb, the first you'll see is without any arguments. The second attempt is with --no-daemon and --sync appended.

Unfortunately this bug has made it into the release :-(

$ xfce4-power-manager --debug
TRACE[xfpm-main.c:200] xfpm_start(): Starting the power manager
TRACE[xfpm-xfconf.c:156] xfpm_xfconf_load(): Using default configuration for general-notification
TRACE[xfpm-xfconf.c:156] xfpm_xfconf_load(): Using default configuration for lock-screen-suspend-hibernate
TRACE[xfpm-xfconf.c:156] xfpm_xfconf_load(): Using default configuration for power-save-on-battery
[snip]
TRACE[xfpm-power.c:1117] xfpm_power_hide_adapter_icon(): Hide adaptor icon
TRACE[xfpm-polkit.c:456] xfpm_polkit_check_auth_intern(): Action=org.freedesktop.udisks.drive-set-spindown is authorized=TRUE
TRACE[xfpm-disks.c:170] xfpm_disks_get_is_auth_to_spin(): Is auth to spin down disks : 1
TRACE[xfpm-disks.c:147] xfpm_disks_set_spin_timeouts(): On Battery=0 spin_down_enabled=0 timeout=800

The program 'xfce4-power-manager' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 312 error_code 15 request_code 150 minor_code 11)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I tried to make a backtrace but I couldn't find the debug package in ddebs (followed instructions from https://wiki.ubuntu.com/DebuggingProgramCrash#Debug_Symbol_Packages but no debug symbols package found)

mokrates (mmolle) wrote :

I think the heat on this bug should be higher. the power-manager is a central component of a system used on a mobile device, und xfce4-power-manager is the power-manager for lubuntu, which is an official ubuntu-distro now.

teranex (teranex) wrote :

I have the exact same problem on my Dell Studio 1558 after upgrading to Xubuntu 11.10.
If I open 'power manager' in the XFCE Settings Manager i get a blank window. If I try to open it from the commandline I get the mentioned error.
I also have a Dell Latitude e6510, which was also upgraded to Xubuntu 11.10, but on this laptop i can successfully run the powermanager. One difference on this laptop is that it was originally on Ubuntu on which i installed xubuntu-desktop, then I upgraded to Xubuntu 11.10, so the laptop also contains most/all the gnome packages.

Lionel Le Folgoc (mrpouit) wrote :

(Changing the heat, severity, or the fact that it's used by lubuntu won't solve the bug magically unless someone works on it.)

This might be fixed by this upstream commit, if someone wants to try: <http://git.xfce.org/xfce/xfce4-power-manager/commit/?id=6b86e87fabb8ffe7916aa9c18d8b21e8d7896870> (either that, or missing calls to gdk_error_trap_push() and gdk_error_trap_pop() around XRRQueryOutputProperty() in xfpm_brightness_xrand_get_limit() to handle the case when the output doesn't support the old "BACKLIGHT" atom).

Changed in xfce4-power-manager (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
taka jedna (taka-jedna) wrote :

I'm using a normal Ubuntu with xubuntu-desktop and that bug appeared after upgrading to 11.10. I have Dell Latitude C510.

Nelson (nrescobar+lp) wrote :

I also ran into this problem when upgrading my Thinkpad T60 to 11.10.

I believe this same problem was reported upstream in https://bugzilla.xfce.org/show_bug.cgi?id=7999.

Andrzej (ndrwrdck) wrote :

Tested with git HEAD of xfce4-power-manager (2011/10/25). Ubuntu 11.10.

$ gdb --args bin/xfce4-power-manager --debug --sync
(gdb) break _XError
(gdb) run
[...]
Breakpoint 1, 0xb769bc40 in _XError () from /usr/lib/i386-linux-gnu/libX11.so.6
(gdb) bt
#0 0xb769bc40 in _XError () from /usr/lib/i386-linux-gnu/libX11.so.6
#1 0xb769893d in ?? () from /usr/lib/i386-linux-gnu/libX11.so.6
#2 0xb7699927 in _XReply () from /usr/lib/i386-linux-gnu/libX11.so.6
#3 0xb77ae85f in XRRQueryOutputProperty () from /usr/lib/i386-linux-gnu/libXrandr.so.2
#4 0x0805f4c8 in xfpm_brightness_xrand_get_limit (brightness=<optimized out>, output=<optimized out>, min=0xbfffed38, max=0xbfffed3c) at xfpm-brightness.c:69
#5 0x0805f8e4 in xfpm_brightness_setup_xrandr (brightness=0x80f39a0) at xfpm-brightness.c:199
#6 xfpm_brightness_setup (brightness=0x80f39a0) at xfpm-brightness.c:533
#7 0x080590c3 in xfpm_backlight_init (backlight=0x809bdb0) at xfpm-backlight.c:387
#8 0xb78e3fab in g_type_create_instance () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#9 0xb78c33cb in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#10 0xb78c6509 in g_object_newv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#11 0xb78c7068 in g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#12 0x08059328 in xfpm_backlight_new () at xfpm-backlight.c:471
#13 0x0805050a in xfpm_manager_start (manager=0x809bc20) at xfpm-manager.c:543
#14 0x0804e451 in xfpm_start (bus=<optimized out>, client_id=0x0, dump=0) at xfpm-main.c:227
#15 0x0804eadf in main (argc=1, argv=0xbffff284) at xfpm-main.c:426

The above patch failed to work for me, but after some digging on the BTS, I found a patch that handles X11 errors properly, and presto, battery meter came back. Will upload a test patch to a PPA, and once I have confirmation from someone else, I'll do an upload to oneiric-proposed and start the SRU process to get this fixed for everyone.

Chris Clonch (cacack) wrote :

Looking forward to it. I came home to find my laptop still running. Everyone in my house is accustomed to just closing the lid and it going to sleep...

This affects one of my thinkpads, upgraded from ubuntu 11.04 to 11.10 and then with xubuntu-desktop loaded on top of it. Other computers seems to be fine, except this one.

Due to UDS, it appears this is probably not going to get an upload until the weekend. I'll see if I can do it tonight or tomorrow, but no promises.

Changed in xfce4-power-manager (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Changed in xfce4-power-manager (Ubuntu Precise):
importance: High → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.0.10-4ubuntu1

---------------
xfce4-power-manager (1.0.10-4ubuntu1) precise; urgency=low

  * debian/patches:
    - 03_trap-x-errors.patch: added, fix crash when all outputs don't support
      the backlight property. lp: #821170
 -- Lionel Le Folgoc <email address hidden> Sun, 13 Nov 2011 14:49:37 +0100

Changed in xfce4-power-manager (Ubuntu Precise):
status: Triaged → Fix Released

Thanks for your work on this Lionel. Will this fix be backported to Oneiric?

Kimmo Satta (ksatta79) wrote :

Would this be a trusted place to get it precompiled for oneiric:

https://launchpad.net/~bkandiyal/+archive/bhaskar-test/+build/2870381

?

I'm not recommending that you do the same, but I just installed packages built for precise on my oneiric box from https://launchpad.net/ubuntu/precise/+source/xfce4-power-manager. They seem to be working fine, but I will definitely uninstall and reinstall packages specific to oneiric if/when they become available.

Kimmo Satta (ksatta79) wrote :

k. I'll try that

I just compiled xfce4-power-manager with changes from https://launchpadlibrarian.net/83453821/xfce4-power-manager_1.0.10-4ubuntu1%7Eppa1.debian.tar.gz. It just contained a patch for backlight stuff. I still get the error:
"The error was 'BadName (named color or font does not exist)'."

Maybe the fix is a patch to 1.0.10-4ubuntu1, and 1.0.10-4ubuntu1 is not the patch itself which fixes the badname issue?

Kimmo Satta (ksatta79) wrote :

@Darian I did the same, seems to work so far :)

Lionel Le Folgoc (mrpouit) wrote :

The fix for oneiric is waiting for approval, and should be available for wider testing in a few days (you'll be able to test it as described on https://wiki.ubuntu.com/QATeam/PerformingSRUVerification and https://wiki.ubuntu.com/Testing/EnableProposed)..

(and fwiw, the patch included in https://launchpad.net/~bkandiyal/+archive/bhaskar-test/+build/2870381 is unrelated to this bug report ;-).

Hello Björn, or anyone else affected,

Accepted xfce4-power-manager into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xfce4-power-manager (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Thomas Meyer (shokah) wrote :

will this fix also be available for arch armel? I also ran into this bug on my toshiba ac100.

Has this fix been made available in oneiric-proposed - I can't find it in the archive?

Thomas Klute (thomas2-klute) wrote :

I got the fix through oneiric-proposed (amd64) this morning. After starting the power manager manually in the open session, it is working as expected until now.

Martin Pitt (pitti) on 2011-11-16
tags: added: verification-done
removed: verification-needed

The fix works for me although I haven't done a power cycle yet to ensure it starts correctly on boot.

The fix works well for me. It starts properly on commencement of a new session. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.0.10-4ubuntu0.1

---------------
xfce4-power-manager (1.0.10-4ubuntu0.1) oneiric-proposed; urgency=low

  * debian/patches:
    - 03_trap-x-errors.patch: added, fix crash when all outputs don't support
      the backlight property. lp: #821170
 -- Lionel Le Folgoc <email address hidden> Sun, 13 Nov 2011 23:30:04 +0100

Changed in xfce4-power-manager (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.