xfce4-power-manager crashed with SIGSEGV in g_main_context_dispatch()

Bug #713173 reported by gh0st19 on 2011-02-04
226
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Xfce4 Power Manager
Unknown
Unknown
xfce4-power-manager (Ubuntu)
High
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
High
Unassigned

Bug Description

Binary package hint: xfce4-power-manager

Power manager seems to crash after about 10 minutes after starting pc. Looks like same issue reported in 10.04

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xfce4-power-manager 1.0.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
CrashCounter: 1
Date: Fri Feb 4 00:19:30 2011
ExecutablePath: /usr/bin/xfce4-power-manager
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101201.2)
ProcCmdline: xfce4-power-manager
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x66495d: mov 0x20(%eax),%edx
 PC (0x0066495d) ok
 source "0x20(%eax)" (0xaaaaaaca) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: xfce4-power-manager
StacktraceTop:
 ?? ()
 ?? () from /lib/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 g_main_loop_run () from /lib/libglib-2.0.so.0
Title: xfce4-power-manager crashed with SIGSEGV in g_main_context_dispatch()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

gh0st19 (gh0st19) wrote :

StacktraceTop:
 xfpm_battery_notify_idle (data=0x20ac1848)
 g_idle_dispatch (source=0x20aea708,
 g_main_context_dispatch (context=0x20a8ba60)
 ?? ()

Changed in xfce4-power-manager (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=7264

Thanks for taking the time to make Ubuntu better!

Changed in xfce4-power-manager (Ubuntu):
status: New → Triaged
Charlie Kravetz (charlie-tca) wrote :

From the Xfce developer:

Can you try the git version ? i made some modifications yesterday which should
solve the issue.

Changed in xfce4-power-manager (Ubuntu):
status: Triaged → Incomplete

Can do..Where is the git file located is it in the xfce repos or does
xubuntu have it's own repo for the file

Rory

On 02/15/2011 08:37 AM, Charlie Kravetz wrote:
> > From the Xofce developer:
>
> Can you try the git version ? i made some modifications yesterday which should
> solve the issue.
>
> ** Changed in: xfce4-power-manager (Ubuntu)
> Status: Triaged => Incomplete
>

Charlie Kravetz (charlie-tca) wrote :

Please update your system, the latest release of xfce4-power-manager is version 1.0.10-1, which should resolve this issue for you. Let us know what happens with this latest update, please?

Lionel Le Folgoc (mrpouit) wrote :

I'd say it's not fixed. The stacktrace from Bug #813454 looks pretty similar (more detailed though, might be worth sending it upstream), and the description says it occurred on 1.0.10.

David Tomaschik (matir) wrote :

Still happening on Oneiric Beta 1 with version 1.0.10-4.

Changed in xfce4-power-manager (Ubuntu):
status: Incomplete → Confirmed
crys (schaefec) wrote :

Same here with current oneiric. Actually, this happened quite often in the past days, always shortly after awakening the laptop from suspend state.

happend for me too in 11.10. It happened after plugin off the power-adapater on my eeepc 901

Saab-FAN (voyager-schroeder) wrote :

Happened to me in 11.10 right after i removed the battery. Standby occasionally crashes the power-manager too.
I use a Acer Aspire One A101.

this bug seems to be fixed for me. Anyone else still having this bug? or can this bug be closed?

spaetz (spaetz) wrote :

No, this bug cannot be closed as fixed. I get this in the current oneiric stack (Architecture: amd64, Version: 1.0.10-4ubuntu1) quite often directly after bootup or suspend.

Changed in xfce4-power-manager (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
Lionel Le Folgoc (mrpouit) wrote :

The patch attached to the upstream bug report should fix this issue: <https://bugzilla.xfce.org/attachment.cgi?id=3912>. I'll upload it to precise later today.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.0.10-4ubuntu2

---------------
xfce4-power-manager (1.0.10-4ubuntu2) precise; urgency=low

  * debian/patches:
    - 04_clear-idles-for-removed-batteries.patch: added, fix crash when xfpm
      tries to refresh the status icon of a removed battery. lp: #713173
    - 05_fix-brightness-key-modifiers.patch: added, let the brightness keys
      work even when numlock is on.
    - xubuntu_fix-xfconf-type-brightness-level.patch: added, use the same type
      when writing and reading the brightness level with xfconf. lp: #923136
    - xubuntu_fix-status-icon-other-devices.patch: added, should fix broken
      status icons for other devices (phone, wireless kbd, mouse, etc.).
 -- Lionel Le Folgoc <email address hidden> Tue, 31 Jan 2012 20:35:17 +0100

Changed in xfce4-power-manager (Ubuntu Precise):
status: Triaged → Fix Released
dino99 (9d9) wrote :
Changed in xfce4-power-manager (Ubuntu Oneiric):
status: New → Invalid
Changed in xfce4-power-manager (Ubuntu Natty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.