[Lucid Xubuntu] power manager fails to dbus-activate hal

Bug #507097 reported by Charlie Kravetz on 2010-01-13
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xfce4-power-manager (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-power-manager

When lucid is starting, both on the GDM screen and the desktop, a message comes up "Xfce power manager: HAL daemon is not running". This causes the power manager to fail to work properly.

ProblemType: Bug
Architecture: i386
Date: Wed Jan 13 10:37:38 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Package: xfce4-power-manager 0.8.4.2-1ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: xfce4-power-manager
Tags: lucid
Uname: Linux 2.6.32-10-generic i686

Charlie Kravetz (charlie-tca) wrote :
Charlie Kravetz (charlie-tca) wrote :
Ara Pulido (apulido) wrote :

I get this as well in Xubuntu Alternate i386

Changed in xfce4-power-manager (Ubuntu):
status: New → Confirmed
TheReaperD (djones) wrote :

Using Xubuntu 10.04 - i386

Hardware:

Gateway MX6433 Laptop
AMD Turion 64 ML-30
512 MiB RAM

For more detail on hardware, see attached file.

Lionel Le Folgoc (mrpouit) wrote :

Martin: is there something to change on our side, or is the bug in hal?

Changed in xfce4-power-manager (Ubuntu):
status: Confirmed → Incomplete

Why is HAL not running for these folks? What happens when they try to re/start it manually?:
sudo service hal restart

Jonathan Thomas (echidnaman) wrote :

HAL is no longer a service that can be started via upstart. (https://edge.launchpad.net/ubuntu/+source/hal/0.5.14-0ubuntu2)

Martin Pitt (pitti) wrote :

hal is run through D-Bus activation now, instead of an init/upstart script. This is because booting/X/GNOME does not need hal any more these days.

If an app wants to connect to hal, it should get auto-spawned. This works fine for gnome-power-manager and pitivi at least. So perhaps x-p-m does something more cautious, like testing if hal is running before connecting to it (this doesn't work -- it just needs to go ahead connecting).

Does someone have a debug output of x-p-m? How is that done?

summary: - [Lucid Xubuntu] power manager fails to start because HAL daemon is not
- running
+ [Lucid Xubuntu] power manager fails to dbus-activate hal
Lionel Le Folgoc (mrpouit) wrote :

Martin: FWICT, xfce4-power-manager calls dbus_bus_name_has_owner to check that hal is already running. So this is as you wrote. Thanks for the hint. I can probably patch all xfce programs using hal to stop doing that...

But then I wonder if someone checked how many softwares are broken with your changes (main is probably fine because GNOME switched to *kit, but universe isn't). Some mass bug filling could be really useful...

Lionel Le Folgoc [2010-01-16 18:16 -0000]:
> I can probably patch all xfce programs using hal to stop doing
> that...

If it really does affect that many programs, then I wonder whether
this could be eased by forcing hal startup at the startup of XFCE by
using dbus-send to activate hal. Do you think that would be easier?

Lionel Le Folgoc (mrpouit) wrote :

libhal1
Reverse Depends:
  libexo-0.3-0
  exo-utils
  libthunar-vfs-1-2
  xfburn
  xfce4-volstatus-icon
  xfce4-governor-plugin
  xfce4-cddrive-plugin
  thunar-volman
hal
Reverse Depends:
  xfce4-power-manager
  thunar
  xfburn
  xubuntu-desktop
  xfce4-session

I haven't checked if they are affected or not, it's just a raw output.
Forcing hal to start with dbus-send can probably do it, but it's really ugly because xfce is modular, so components can be used separately without xfce4-session... Moreover, xfce4-power-manager will still fail to do anything useful when started by gdm.

derk (joeymon25) wrote :

I posted this duplicate of this problem Bug #508386 , so thanks to Dave Lentz for his xorg tip as that allowed me to login by getting my keyboard to work. I had to modify his xorg.conf for my devices and I have attached this just in case someone needs a tip. When you click away the message and then log in it does come back once more. Click though that and things are almost back to normal.

>When you ssh into the install, try starting HAL manually:
>sudo service hal restart

The service seems to be already running so this does not help.

service hal start

hal start/running, process 10995

>I forget if the packages are installed by default, but you'll need them for the above suggestion:
>sudo apt-get install xserver-xorg-input-mouse xserver-xorg-input-kbd

Yes they are.

Can I assume usb disks are not being mounted automatically for example could be due to this? This has worked on every prior version prior to this with the same kit.

Lionel Le Folgoc (mrpouit) wrote :

Xfce4-power-manager seems to be the only one affected, I'll make a quick and dirty patch to workaround this issue.

Changed in xfce4-power-manager (Ubuntu):
status: Incomplete → In Progress
importance: Undecided → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

Mmh, in fact I don't know if it's the only one affected. Please file a new bug report if you experience new problems (with tunar and automount for instance).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 0.8.4.2-1ubuntu3

---------------
xfce4-power-manager (0.8.4.2-1ubuntu3) lucid; urgency=low

  * debian/patches/xubuntu-assume-hal-is-available.patch: do not check for hal
    presence on the bus, it'll be spawned automatically on demand. lp: #507097
  * debian/patches/series: refreshed.
 -- Lionel Le Folgoc <email address hidden> Wed, 20 Jan 2010 21:41:48 +0100

Changed in xfce4-power-manager (Ubuntu):
status: In Progress → Fix Released
Zoolook (mr-zoolook) wrote :

Oops, sorry about that!

Changed in xfce4-power-manager (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.