Screen refuses to dim on battery

Bug #1067749 reported by bwat47 on 2012-10-17
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Xfce4 Power Manager
Unknown
Unknown
xfce4-power-manager (Debian)
Confirmed
Unknown
xfce4-power-manager (Gentoo Linux)
Fix Released
Medium
xfce4-power-manager (Ubuntu)
Medium
Jackson Doak

Bug Description

I have the XFCE power manager set to dim the screen to 40% on battery after 10 seconds. When I unplug my laptop the screen just never dims and stays at full brightness. I can change brightness fine using the hot keys on my keyboard, XFCE just refuses to do it automatically.

I have "Monitor Power Management Control" enabled in the power manager. I tried uninstalling xscreensaver in case that was conflicting, but it made no change.

I am using xubuntu 12.10 (clean install of daily build yesterday) with all updates. I have an Asus U52F laptop with an intel video card.

I do not have the gnome settings daemon installed, so I don't know what else could possibly be conflicting.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xfce4-power-manager 1.2.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Wed Oct 17 10:30:51 2012
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121015)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)

bwat47 (bwat47) wrote :
description: updated
bwat47 (bwat47) wrote :

It appears to be this bug: https://bugzilla.xfce.org/show_bug.cgi?id=8840

Could we get this patch backported to 12.10?

bwat47 (bwat47) wrote :

I've just downloaded the xfce power manager source, applied this patch, and installed the package. I am confirming that this does dix the issue, my screen now dims as expected and respects the xfce power manager settings.

bwat47 (bwat47) wrote :

I've attached the working patch I used, taken from the debian bug report here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676854

The attachment "Screen dim fix" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-power-manager (Ubuntu):
status: New → Confirmed
bwat47 (bwat47) wrote :

This is some pretty big lack of functionality, I can reproduce it on all my laptops...

Martin Matuska (mm-vx) wrote :

I confirm this bug fre Xubuntu 13.04.
The patch in the XFCE bug #8840 by Massimo Cavalleri fixes the issue, I am attaching it here, too.

Martin Matuska (mm-vx) wrote :

For the impatient, here is how you can build and test the patched package:

Create a build directory (e.g. build) and cd to it
Download the patch unify_level_brightness_to_gint.patch (provided above) to the directory.

sudo apt-get install fakeroot debhelper build-essential
sudo apt-get build-dep xfce4-power-manager
apt-get source xfce4-power-manager
patch -p0 < unify_level_brightness_to_gint.patch
cd xfce4-power-manager-1.2.0
dpkg-buildpackage -rfakeroot -uc -b
cd ..

Now you should have three .deb packages in the build directory.
Now simply replace the xfce4-power-manager with the patched version:
sudo dpkg -i xfce4-power-manager_1.2.0-1ubuntu2_amd64.deb

Changed in xfce4-power-manager (Gentoo Linux):
importance: Unknown → Medium
Changed in xfce4-power-manager (Debian):
status: Unknown → Confirmed
Pietrek B. (ptrbrzozowski) wrote :

This bug affects me too on Xubuntu 13.10 x86_64. I've build a deb containg the patch from M. Cavalleri, you can get it here: http://ubuntuone.com/5Fgy9GpiRxlKFMAve0d6Bs
Does the trick for me, hope it saves you some time :)

Martin Matuska (mm-vx) wrote :

This patch does only one thing - uses gint32 instead of glong for brightness levels.
There are no other changes to the code.
Both auto-dimming and panel plugin work on my 64-bit Ubuntu 13.04 with this patch.

To apply, download patch and:
sudo apt-get install fakeroot debhelper build-essetial
sudo apt-get build-dep xfce4-power-manager
apt-get source xfce4-power-manager
patch -p0 < xfce4-power-manager-brightness.patch
cd xfce4-power-manager-1.2.0
dpkg-buildpackage -rfakeroot -uc -b
cd ..

Now you should have 3 deb packages.

Upstream merge a solution:
<http://git.xfce.org/xfce/xfce4-power-manager/commit/?id=05d12e12596512f7a31d3cdb4845a69dc2d4c611>

Can we add this patch to the gentoo ebuild, please?

(In reply to Christoph Junghans from comment #1)
> Upstream merge a solution:
> <http://git.xfce.org/xfce/xfce4-power-manager/commit/
> ?id=05d12e12596512f7a31d3cdb4845a69dc2d4c611>
>
> Can we add this patch to the gentoo ebuild, please?

because this is...

1. simple as adding "${FILESDIR}"/${P}-foo.patch
2. and the commit is in (from) upstream repository

...you could have just merged it yourself to Portage

but okay, I've done it now :)

+*xfce4-power-manager-1.2.0-r2 (24 Jul 2013)
+
+ 24 Jul 2013; Samuli Suominen <email address hidden>
+ +xfce4-power-manager-1.2.0-r2.ebuild,
+ +files/xfce4-power-manager-1.2.0-brightness_level_gint32.patch:
+ Backport upstream patch for brightness level handling wrt #474092 by
+ Christoph Junghans

Changed in xfce4-power-manager (Gentoo Linux):
status: Unknown → Fix Released
Martin Matuska (mm-vx) wrote :
Changed in xfce4-power-manager:
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Committed
status: Fix Committed → Confirmed
importance: Undecided → Unknown
status: Confirmed → Unknown
Sergio Benjamim (sergio-br2) wrote :

Fix Released, but is it in Ubuntu Saucy? I'm having the same problem in Saucy.

tags: added: saucy
Changed in xfce4-power-manager (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: trusty
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1067749

tags: added: package-qa-testing
Jackson Doak (noskcaj) on 2014-01-22
Changed in xfce4-power-manager (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.2.0-3ubuntu3

---------------
xfce4-power-manager (1.2.0-3ubuntu3) trusty; urgency=medium

  * Add 07_fix-screen-dimming.patch. LP: #1067749
  * Add DEP3 Header to 06_add-shutdown-reboot-functionality-for-systemd.patch
 -- Jackson Doak <email address hidden> Wed, 22 Jan 2014 16:02:45 +1100

Changed in xfce4-power-manager (Ubuntu):
status: In Progress → Fix Released
Dr. Wolfgang Näser (naeser) wrote :

xfce power management does not function correctly. Screen cannot be dimmed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.