Ubuntu

xfce4-places-plugin crashed with SIGSEGV in g_type_check_instance_cast()

Reported by Steve Beattie on 2008-09-18
452
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xfce4-places-plugin (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-places-plugin

RELEASE: Intrepid
CD/DVD Variant: 32bit Xubuntu desktop cd live environment
ISO BUILD: 20080917.1

Was playing around with gTwitter trying to follow a link to an @user, when thunar just fell over (I think).

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/xfce4/panel-plugins/xfce4-places-plugin
Package: xfce4-places-plugin 1.1.0-1
ProcAttrCurrent: unconfined
ProcCmdline: /usr/lib/xfce4/panel-plugins/xfce4-places-plugin socket_id 18874408 name places id 2 display_name Places size 24 screen_position 1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: xfce4-places-plugin
StacktraceTop:
 g_type_check_instance_cast ()
 ?? ()
 g_cclosure_marshal_VOID__OBJECT ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: xfce4-places-plugin crashed with SIGSEGV in g_type_check_instance_cast()
Uname: Linux 2.6.27-3-generic i686
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Steve Beattie (sbeattie) wrote :

StacktraceTop:IA__g_type_check_instance_cast (type_instance=0x656d696d, iface_type=135923800)
pview_destroy_menu (view=0x81c4a78) at view.c:527
IA__g_cclosure_marshal_VOID__OBJECT (closure=0x8496660, return_value=0x0, n_param_values=2,
IA__g_closure_invoke (closure=0x8496660, return_value=0x0, n_param_values=2, param_values=0x81c9990,
signal_emit_unlocked_R (node=0x81a70f0, detail=0, instance=0x8212800, emission_return=0x0,

Changed in xfce4-places-plugin:
importance: Undecided → Medium

I am marking this bug confirmed since there is enough information for the developers to begin working on it. Thanks for helping make Xubuntu better

This bug has 5 duplicates with information also

Changed in xfce4-places-plugin:
status: New → Confirmed

bug produced during boot process. Using Ibex alpha 5

markor (markoresko) wrote :

Also happens on Xubuntu Alternate 8.10 Beta amd64.

just had software update problem has'nt repeated itself, cheers for now

John

>----Original Message----
>From: <email address hidden>
>Date: 07/10/2008 16:00
>To: <email address hidden>
>Subj: [Bug 271689] Re: xfce4-places-plugin crashed with SIGSEGV in
g_type_check_instance_cast()
>
>Also happens on Xubuntu Alternate 8.10 Beta amd64.
>
>--
>xfce4-places-plugin crashed with SIGSEGV in
g_type_check_instance_cast()
>https://bugs.launchpad.net/bugs/271689
>You received this bug notification because you are a direct
subscriber
>of the bug.
>
>Status in “xfce4-places-plugin” source package in Ubuntu: Confirmed
>
>Bug description:
>Binary package hint: xfce4-places-plugin
>
>RELEASE: Intrepid
>CD/DVD Variant: 32bit Xubuntu desktop cd live environment
>ISO BUILD: 20080917.1
>
>Was playing around with gTwitter trying to follow a link to an @user,
when thunar just fell over (I think).
>
>ProblemType: Crash
>Architecture: i386
>DistroRelease: Ubuntu 8.10
>ExecutablePath: /usr/lib/xfce4/panel-plugins/xfce4-places-plugin
>Package: xfce4-places-plugin 1.1.0-1
>ProcAttrCurrent: unconfined
>ProcCmdline: /usr/lib/xfce4/panel-plugins/xfce4-places-plugin
socket_id 18874408 name places id 2 display_name Places size 24
screen_position 1
>ProcEnviron:
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:
/usr/games
> LANG=en_US.UTF-8
> SHELL=/bin/bash
>Signal: 11
>SourcePackage: xfce4-places-plugin
>StacktraceTop:
> g_type_check_instance_cast ()
> ?? ()
> g_cclosure_marshal_VOID__OBJECT ()
> g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
> ?? () from /usr/lib/libgobject-2.0.so.0
>Title: xfce4-places-plugin crashed with SIGSEGV in
g_type_check_instance_cast()
>Uname: Linux 2.6.27-3-generic i686
>UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare
>

See your new look Tiscali Homepage - http://www.tiscali.co.uk

___________________________________________________

Alejandro Mery (amery) wrote :

Places has always crashed for me. It crashed in 8.04, in 8.10 beta (x86) and now also using xubuntu's ppa =)

smmalis37 (smmalis37) wrote :

Every boot, there's Apport!

Changed in xfce4-places-plugin (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Confirmed → In Progress
Lionel Le Folgoc (mrpouit) wrote :

Fixed since xfce4-places-plugin 1.1.0-2.

Changed in xfce4-places-plugin (Ubuntu):
status: In Progress → Fix Released
tags: added: iso-testing
To post a comment you must log in.