Crashes when trying to mount a drive (gnome-mount not installed)

Bug #138675 reported by Vincent on 2007-09-10
2
Affects Status Importance Assigned to Milestone
xfce4-places-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xfce4-places-plugin

When trying to mount a drive with the Places plugin, it crashes (i.e. disappears from the panel). This might be because gnome-mount was not installed (which will be default when Gutsy's out, but still...) but then it should display an error message instead of crash.

This was on Xubuntu Gutsy Tribe 5 running from my USB drive (i.e. as a LiveCD).

Jani Monoses (jani) wrote :

this was fixed a while ago, please use daily images for testing. thanks

Changed in xfce4-places-plugin:
status: New → Fix Released
Lionel Le Folgoc (mrpouit) wrote :

No, the bug still exists... if someone installs the xfce4 package without having xubuntu-desktop nor gnome-mount installed, drive mount will be broken.

We could put back a dependency on gnome-mount in libexo, but that's not very optimal, and all xfce packages will FTBFS...

Changed in xfce4-places-plugin:
status: Fix Released → Incomplete
Jani Monoses (jani) wrote :

thunar did not crash AFAIK. So places should be made not to crash if mounting fails and keep gnome-mount as recommended. Is the FTBFS issue not going to be solved during gutsy?

Lionel Le Folgoc (mrpouit) wrote :

Fixed in thunar 0.9.0-1ubuntu2, which does not rely on gnome-mount anymore.

Changed in xfce4-places-plugin:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers