XFCE: cannot unminimize windows, sometimes

Bug #977910 reported by Martin Pohlack on 2012-04-10
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Xfce4 Panel
Unknown
Unknown
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Sometimes, after some days of usage, my XFCE session turns completely useless by not allowing me to unminimize windows.

I cannot click program buttons in the taskbar to get them unminimized or focused. Instead of reacting, the window buttons blink for attention. The only way to show a program is by ALT-tabbing to it. Focusing via mouse also works if it is not minimized.

I am not sure where the actual problem is located, but restarting xfwm4 does not seem to have an effect.

Completely killing the session and logging in again fixes the problem.

Usually this broken state persists until restart, today I have seen it revert itself after some time.

> lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

> apt-cache policy xfwm4
xfwm4:
  Installed: 4.8.1-1
  Candidate: 4.8.1-1
  Version table:
 *** 4.8.1-1 0

> apt-cache policy xfce4-panel
xfce4-panel:
  Installed: 4.8.3-0ubuntu1
  Candidate: 4.8.3-0ubuntu1
  Version table:
 *** 4.8.3-0ubuntu1 0

I expect to be able to unminimized and focus windows by clicking in their button in the taskbar.
Instead, no change in focus or minimized state is happening and they start to blink for attention.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Jaxon (bjackson0971) wrote :

I can reproduce this bug by running Xfe (X File Explorer, A FOX toolkit app) and then double clicking a document to launch an associated app such as a pdf with xpdf or acroread, or a jpg with geeqie. Running killall xfwm4 will fix the problem for me.

I ran xfwm4 from a console and reproduced it, but there was no error message printed. I can get a strace log file as well, but I don't know what to look for in the output.

Martin Pohlack (mp26+launch) wrote :
Martin Pohlack (mp26+launch) wrote :

Does this always work for you? I just tried and it did not trigger the bug for me.

Do you have a xinerama (multi-screen) setup?

Jaxon (bjackson0971) wrote :

This has worked several times when I've tried it. I have a Dell Latitude E6500, which has Intel integrated graphics, with an external monitor using a DisplayPort to DVI adapter. I don't have xinerama explicitly configured in xorg.conf, but the Xorg log shows "(II) Initializing built-in extension XINERAMA"

I'm using Mageia 2, not Ubuntu BTW.

Thanks for the link to the xfce bugzilla. Should I repost my report there?

Martin Pohlack (mp26+launch) wrote :

I would focus on the xfce bugtracker in the future, as it seems to be an upstream bug.

Regarding xinerama, are you using the internal and external monitor at the same time? Showing different content or in cloning mode?

I run xfce on 3 machines and see the problem only on one machine, the only one with two monitors attached (the other two are laptops).

Jaxon (bjackson0971) wrote :

Both monitors are in use and with different content. I was on the external when I did the testing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.