[Maverick] XFCE system tray became unusable after libgtk upgrade

Bug #586012 reported by Evgeny Kapun on 2010-05-26
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Xfce panel
Confirmed
Unknown
gtk+2.0 (Ubuntu)
Low
Unassigned
xfce4-panel (Ubuntu)
High
Unassigned

Bug Description

After upgrade to libgtk2.0-0 2.21.0-1ubuntu2, XFCE system tray stopped working. No icons are visible, and CPU load is 100% while tray is displayed (task manager attributes most of this load to X server). Workaround is to downgrade libgtk2.0-0 to version 2.20.1-0ubuntu1.

Architecture: amd64
Linux 2.6.34-3-generic
xserver-xorg 1:7.5+5ubuntu1
xserver-xorg-video-intel 2:2.9.1-3ubuntu5
libxfce4util4 4.6.2-1ubuntu1
libxfcegui4-4 4.6.4-1
libexo-0.3-0 0.3.107-1ubuntu1
xfce4-panel 4.6.4-1

WORKAROUND:
When installing Maverick Meerkat, the systray appears in the middle of the screen, with three icons flashing constantly. This prevents the installation from the live environment, and makes the desktop pretty much unusable after any installation completes.

To use the system after starting, open Applications -> System -> System Monitor. It will take a few seconds to minutes to open due to those flashing windows/icons. Hilight and kill the following Processes:

gnome-volume-control-applet
nm-applet
update0-notifier
xfce4-power-manager

Now you should be able to use the system as usual until the next login.

tags: added: maverick xubuntu
summary: - System tray became unusable after upgrade to xfce4-panel 4.6.4-1
+ [Maverick] System tray became unusable after upgrade to xfce4-panel
+ 4.6.4-1

I've found that this bug is actually triggered by upgrade of libgtk2.0-0, not xfce4-panel. Version 2.21.0-1ubuntu2 is affected, and version 2.20.1-0ubuntu1 isn't.

summary: - [Maverick] System tray became unusable after upgrade to xfce4-panel
- 4.6.4-1
+ [Maverick] XFCE system tray became unusable after upgrade to libgtk2.0-0
+ 2.21.0-1ubuntu2
description: updated

More info from a duplicate bug report:
"When I login notification area icons appears (decorated by WM) centered on screen, just to disappear right after. After that a new window is spawned witch once again disappear.

The icon windows will keep flashing in the middle of the screen until i kill xfce4-panel. Once I start a new xfce4-panel the same thing happens once again.

The sound (xfce4-mixer) icon is attached to the panels notification area as expected, all other icons are affected by above mentioned problem."

We don't know yet if this is an expected new behavior in gtk+ or a regression…

Evgeny Kapun (abacabadabacaba) wrote :

Marking this bug as confirmed because it has a duplicate with the same symptoms.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
description: updated
description: updated
Fabio Marconi (fabiomarconi) wrote :

Another workaround is to remove notify area

Morris Cavestro (fly82) wrote :

I have this bug. When i start the livecd start xfce4 and appear a 2windows and the desktop i can't use. For use i can stop the proces on system monitori xfce4 and after this a i can use normaly.

Evgeny Kapun (abacabadabacaba) wrote :

libgtk2.0-0 2.21.1-1ubuntu1 is also affected.

summary: - [Maverick] XFCE system tray became unusable after upgrade to libgtk2.0-0
- 2.21.0-1ubuntu2
+ [Maverick] XFCE system tray became unusable after libgtk upgrade
Francesco Ruvolo (ruvolof) wrote :

Same for me.

I had to kill xfce4-power-manager e xfce4-volume-control-applet to use the system.

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Jean.c.h (slug71) wrote :

I can confirm this bug.

Removing the 'Notification Area' from the panel seems to make the flashing go away. Of course you will not see nm or any other indicators though.

Lukas Hejtmanek (xhejtman) wrote :

Looks like gtk 2.21.0 has also problem with screen corruption. It seems that some Expose events are missed, gtk applications do not redraw their windows correctly after virtual desktop switch.

Bertrand Croq (bcroq) wrote :

"gtk applications do not redraw their windows correctly after virtual desktop switch"

Not only after virtual desktop switch... but this should be in another bug report.

Jean.c.h (slug71) wrote :

Updates that came through recently seem to be working ok.

Cyrus Harmon (ch-launchpad) wrote :

Latest version works for me too. Thanks!

Rickard Närström (riccetn) wrote :

As of libgtk+2.0 2.21.2-0ubuntu2 rgba and client side decorations is (temporary) disabled. This seems to be related to those features and thus can't be seen with this version.

The bug is still there and we will most likely see it once again when rgba and csd is activated again.

Sebastien Bacher (seb128) wrote :

the gtk rgba change has been turned off until alpha2 since nobody has time to work on fixing those bugs for now and we did collect the feedback required for now, the change will come back later in the cycle though so the bug still should be investigated

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
tags: added: gtk-csd
Changed in xfce4-panel:
status: Unknown → Confirmed
Pedro Villavicencio (pedro) wrote :

This change is not going to be included in Maverick since it's not ready yet, and it's going to be looked at next cycle, Since the change was not included, is the panel still working fine or you're still getting the issue even though the change was not included anymore? Thanks.

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Incomplete
Charlie Kravetz (charlie-tca) wrote :

This is not affecting the panel as of Maverick Beta. The live environment and the installations are working.

Fabio Marconi (fabiomarconi) wrote :

Egual in mine tests of maverick beta, panels works well in live session, in real installations and in qemu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-panel - 4.7.5-0ubuntu1

---------------
xfce4-panel (4.7.5-0ubuntu1) natty; urgency=low

  * Upload to natty (pkg-xfce svn r4611).

xfce4-panel (4.7.5-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * New upstream development release.
  * debian/control:
    - refreshed (b-)deps for this new major release
    - add myself to Uploaders
    - bump Standards-Version to 3.9.1.
  * debian/NEWS: dropped, unneeded.
  * debian/xfce4-panel.shlibs: refreshed, bump to (>= 4.7.2).
  * debian/xfce4-panel.lintian-overrides: refreshed, new lib name.
  * debian/xfce4-panel.preinst: added, handles removal of old conffiles.
  * debian/xfce4-panel.postinst: explicitly set -e.
  * debian/*.install: refreshed.
  * debian/rules:
    - call dpkg-buildflags
    - dropped rc files mangling as they don't exist anymore
    - updated removal of *.{l,}a files.
  * debian/xfce4-panel.{preinst,postinst,prerm}: use dpkg-maintscript-helper
    to remove pre-xfconf config files.
  * Bugs fixed by 4.7.x/4.8.x series:
    - rgba support lp: #586012
    - disappearing menus lp: #53897
    - xrandr support lp: #176174, Closes: #432914
    - Fails to reap children, creating zombies lp: #420187
    - DND of desktop-files on the panel to create new launchers Closes: #480380

  [ Yves-Alexis Perez ]
  * New upstream development release
  * debian/xfce4-panel.install:
    - install wrapper and migrate tools in xfce4-panel package
    - update plugins paths
  * debian/rules:
    - update path when removing .a/.la files for plugins.
    - add hardening flags to {C,LD}FLAGS
  * debian/control:
    - add build-dep on hardening-includes
 -- Lionel Le Folgoc <email address hidden> Sat, 04 Dec 2010 15:45:53 +0100

Changed in xfce4-panel (Ubuntu):
status: Triaged → Fix Released
Changed in gtk+2.0 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.