xfce4-panel crashed with SIGSEGV in SmcRequestSaveYourself()

Bug #386850 reported by lw on 2009-06-14
484
This bug affects 72 people
Affects Status Importance Assigned to Milestone
xfce4-panel (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-panel

$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

$ apt-cache policy xfce4-panel
xfce4-panel:
  Installed: 4.6.0-1ubuntu1

I'm using a LiveCD of Xubuntu 9.04. This happened right after booting in the the desktop.

xfce4-panel crashed when I clicked the exit button in the top right corner. This may be a duplicate of https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/347231. I'm including all the information generated by the automatic crash reporter here.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/xfce4-panel
MediaBuild: Xubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: xfce4-panel 4.6.0-1ubuntu1
ProcCmdline: xfce4-panel
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: xfce4-panel
StacktraceTop:
 SmcRequestSaveYourself () from /usr/lib/libSM.so.6
 logout_session () from /usr/lib/libxfcegui4.so.4
 ?? ()
 ?? ()
 ?? () from /usr/lib/libglib-2.0.so.0
Title: xfce4-panel crashed with SIGSEGV in SmcRequestSaveYourself()
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

lw (lw-lavabit) wrote :
lw (lw-lavabit) wrote :

Just another note: unlike https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/347231, I am using a LiveCD of the latest Jaunty release (not an alpha release). The LiveCD iso was created Mon, 20 Apr 2009 14:35:55 UTC according to /cdrom/dists/jaunty/Release

StacktraceTop:SmcRequestSaveYourself (smcConn=0x8b2f2e8, saveType=2,
logout_session (session_client=0x8b2d990)
evaluate_run_state () at panel-app.c:257
signal_pipe_io (source=0x8b2e940, cond=G_IO_IN, data=0x0)
g_io_unix_dispatch (source=0x8b2e988,

Changed in xfce4-panel (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Steve Beattie (sbeattie) wrote :

This still exists in the karmic alpha 3 live cd candidate image dated 20090722.3, marking confirmed.

visibility: private → public
Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Chriki™ (chrikitm) wrote :

I had the same issue with a Karmic (final) live CD as described above when the exit button in the top right corner was clicked.

Not sure what happened. I tried to exit the xubuntu 9.10 live cdrom session by clicking the exit button at the top right of the screen.

Lionel Le Folgoc (mrpouit) wrote :

Could someone retry on lucid? I think this issue should be fixed. Thanks.

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Incomplete
Charlie Kravetz (charlie-tca) wrote :

This worked in a VitualBox Lucid session, and on my new systems, but it still fails on the 400MHz cpu with 256MB ram. Had help open, clicked the quit icon, panels are gone.

AlexDudko (alex-ald) wrote :

It almost always happens in Lucid (alpha-3) (both i386 and amd-64) - crashes after clicking the logout button. The behavior is the same as in bag https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/347231
The same behavior happened several times in Debian Squeeze, and also xfce4-panel didn't boot in case when session wasn't saved and there was an application running before reboot or shutdown.

Changed in xfce4-panel (Ubuntu):
status: Incomplete → Confirmed
Changed in xfce4-panel (Ubuntu):
status: Confirmed → Triaged
Bill Hammond (ka1ssr) wrote :

Panel went away while trying to exit xfce. Using live Xubuntu 10.04 CD.

Fabio Marconi (fabiomarconi) wrote :

Fixed on 20100705 (tested amd64 only)

Changed in xfce4-panel (Ubuntu):
status: Triaged → Fix Released
Fabio Marconi (fabiomarconi) wrote :

I don't know why now it won't work.
Sorry.

Changed in xfce4-panel (Ubuntu):
status: Fix Released → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Retested 20100705 but it wouldn't work.

The bug is returned with release 20100715 (current 15/07/2010)

John Doe (johndoe32102002) wrote :

I received this bug in the live Xubuntu 10.04 CD upon logging out from Xubuntu.

tags: added: jaunty karmic lucid
Charlie Kravetz (charlie-tca) wrote :

@John Doe:
You most likely experienced bug 53897 , which can be reproduced by hitting the "Quit" button two times before the logout/restart/shutdown screen appears in the live cd environment. This bug seems to be harder to reproduce, since it occurs when logging in.

newbie 2573 (astrophysic) wrote :

using live-cd of xubuntu 10.10 i386

Lionel Le Folgoc (mrpouit) wrote :

It should be fixed with xfce4-panel 4.7.x in natty, hopefully. If it's still not fixed in natty, please open a new bug report with apport so that we get up-to-date data (the panel code changed a lot in the 4.7.x branch, so the existing stracktraces won't be so useful). Thanks.

Changed in xfce4-panel (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers