[Jaunty] Can not use "Log Off" button on panel after using applications in desktop cd

Bug #360630 reported by Charlie Kravetz on 2009-04-13
6
Affects Status Importance Assigned to Milestone
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xfce4-panel

RELEASE: Jaunty development version, pre-release candidate
CD/DVD VARIANT: 32-bit Xubuntu Desktop cd
ISO BUILD: 2009-04-13

SYMPTOMS: After using any applications on the live desktop, attempts to restart or shutdown using the "Log Off" icon on the top panel cause the panels to disappear. If I use the Applications -> Log Out button, restart or shutdown proceeds as expected.

CAUSE: xfce4-panel segfault at 6f000007 ip b78b792e sp bf91f7b0 error 4 in libgobject-2.0.so.0.2000.1[b7892000+3c000]

STEPS TO REPRODUCE:
    (I have not been able to reproduce this bug using VirtualBox, it happens only on actual hardware)
1. start the hardware system using the Xubuntu jaunty-desktop-i386.iso
2. click on the HELP icon on the top panel; after it opens, close it.
3. click on the Firefox icon on the top panel; view a couple of websites; close it.
4. click on the "Log Out" icon on the right of the top panel.
5. Observe both panels disappear and no further action happens. You can not now shutdown, since you have no panels.
6. If you had opened Applications, click on Log Out, it would have worked as you expect it to.
7. There are no logs in /var/crash; /var/log/syslog shows the above line; also attaching the ~/.xsession-errors log, since it shows several errors.

WORKAROUND:
Use the Applications -> Log Out button instead of the panel icon to shutdown/restart/hibernate/suspend/ etc.

Craig Huffstetler (xq) wrote :

Confirmed using Live CD (daily build) on IBM/Lenovo z61m.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

reproduced the crash; attaching the /var/syslog, ~/.xsession-errors log, and a backtrace using gdb

Charlie Kravetz (charlie-tca) wrote :

~/.xsession-errors log

Charlie Kravetz (charlie-tca) wrote :

backtrace after installing xfce4-panel-dbg package; did not cause panels to disappear until after I finished getting the backtrace. As soon as gdb finished running, the panels disappeared.

description: updated
tags: added: jaunty
tags: added: iso-testing
Lionel Le Folgoc (mrpouit) wrote :

Should be fixed in lucid. Please file a new bug report with an up-to-date backtrace if you're still experiencing this issue.

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers