xfce4-panel locks itself if a contextual menu is open while the application is closing

Bug #1778380 reported by GridCube
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xfce4 Panel
Fix Released
High
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

closing an application from the contextual menu and then opening the contextual menu while the application is closing makes it so the panel gets locked if the application is no longer listed.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xfce4-panel 4.12.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Jun 24 00:25:55 2018
InstallationDate: Installed on 2016-02-13 (861 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: xfce4-panel
UpgradeStatus: Upgraded to bionic on 2018-04-06 (78 days ago)

Revision history for this message
In , CDGSThermi (e-noel) wrote :

As the tile says, the panel locks up when the context menu (right click menu on an application's panel object in the task bar) is open while any application with an object in the task bar terminates.

After it locks up, one can not interact with the panel or anything in it anymore. It changes when a tab is closed and one can change tabs using alt+tab though. Using alt+f4 to close all tabs and then hitting it once again brings up a menu that enables users to log off, reboot, restart, suspend and other things.

After the user logs off and logs back in, the panel works again.

This is reproducible.

Revision history for this message
In , CDGSThermi (e-noel) wrote :

It's still a thing in panel version 4.12.2.

Revision history for this message
GridCube (gridcube) wrote :
Revision history for this message
In , CDGSThermi (e-noel) wrote :

Still a thing in version 4.12.4

Revision history for this message
Theo Linkspfeifer (lastonestanding) wrote :

According to https://bugzilla.xfce.org/show_bug.cgi?id=13600, this bug is fixed in version 4.13.

Changed in xfce4-panel:
importance: Unknown → High
status: Unknown → Confirmed
Revision history for this message
In , Andreldm-2 (andreldm-2) wrote :

This is very likely fixed in 4.13, as reported in Bug 13600.
Can you check this version?

Changed in xfce4-panel:
status: Confirmed → Incomplete
Revision history for this message
In , CDGSThermi (e-noel) wrote :

Fixed in 4.13.0. Thank you for your time and efforts.

Changed in xfce4-panel:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.