Applications Menu plugin clips panel icon.

Bug #1756608 reported by Alistair Buxton on 2018-03-17
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xfce4-panel (Ubuntu)
Undecided
Simon Steinbeiß

Bug Description

To reproduce:

    Select Adwaita theme in Appearance.
    Add Applications Menu widget to panel.
    Set it to use a circle icon.

Result:

    The top and bottom of the icon are clipped, regardless of how big you make the panel. It consistently removes 2-3 pixels from the top and bottom of the icon.

Screenshots attached, with a Whisker menu icon (which renders correctly) for comparison. Whisker menu is dark blue, Applications Menu is light blue.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xfce4-panel 4.12.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Mar 17 21:48:58 2018
InstallationDate: Installed on 2018-03-15 (2 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180315)
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Alistair Buxton (a-j-buxton) wrote :
Alistair Buxton (a-j-buxton) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1756608

tags: added: iso-testing
Sean Davis (bluesabre) wrote :

Confirmed that this still affects the GTK3 panel in Xubuntu 18.10.

Sean Davis (bluesabre) wrote :

Also confirmed to still affect Xubuntu 19.04.

tags: added: cosmic disco
Simon Steinbeiß (ochosi) wrote :

I can't confirm the bug with xfce4-panel 4.13.4 (self-built) on cosmic (18.10).
I added a screenshot that shows whiskermenu (on the left, dark blue) and the internal applications menu plugin (light blue, on the right) on a 20px tall panel with Adwaita. Both icons are equally un-clipped.

Simon Steinbeiß (ochosi) wrote :

After some comments from Thaddäus I managed to reproduce the problem and pushed a fix to git master:
https://git.xfce.org/xfce/xfce4-panel/commit/?id=3abbe78bfa3c643f7d31338e97682d8490a09a59

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Simon Steinbeiß (ochosi)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-panel - 4.13.4-1ubuntu1

---------------
xfce4-panel (4.13.4-1ubuntu1) disco; urgency=medium

  * d/patches/lp1756608.patch:
    - Fixes icon clipping for the applications menu (LP: #1756608)
    - Renders menu and launcher icons at the same size (LP: #1756612)

 -- Sean Davis <email address hidden> Fri, 05 Apr 2019 19:52:16 -0400

Changed in xfce4-panel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers