Use mouse hover events to activate/close plugin menus

Bug #147308 reported by Vincent on 2007-09-30
8
Affects Status Importance Assigned to Milestone
xfce4-panel (Ubuntu)
Wishlist
Unassigned

Bug Description

When I click the Applications menu (in Gutsy), and I move my cursor right to hover over the applications menu, I expect the Applications menu to close and the Places menu to open, just as is the case in menu's in most applications (e.g. click the "File" menu in Firefox, then hover "Edit").

Now, keeping in mind Xfce's modular design, I don't know whether it is possible, but if it is, it would be best to have this implemented IMO.

Jani Monoses (jani) wrote :

this will only happen if places functionality is added to xfdesktop. Right now these are unfortunately separare panel plugins

Changed in xfce4-places-plugin:
importance: Undecided → Wishlist
Charlie Kravetz (charlie-tca) wrote :

I'm marking this confirmed/wishlist, since it is not going to happen in Version 8.04 or 8.10. Perhaps at a future version, this could be implemented

Changed in xfce4-places-plugin:
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Behavour for both items in Xubuntu 9.10 is the same now. Both the 'Applications' menu and 'Places' require a left-click on the mouse to open them. Since this bug does request both panel items acting the same, I am closing this bug report as fixed.

Changed in xfce4-places-plugin (Ubuntu):
status: Confirmed → Fix Released
Vincent (vinnl) wrote :

Charlie, can you hover from one to the other? (That's what the bug requested, though awkwardly worded.)

Charlie Kravetz (charlie-tca) wrote :

Actually, I have to click on both of them in Xubuntu 9.10 and lucid to show anything. Hovering doesn't drop either one any more.

Vincent (vinnl) on 2010-03-08
Changed in xfce4-places-plugin (Ubuntu):
status: Fix Released → Confirmed
affects: xfce4-places-plugin (Ubuntu) → xfce4-panel (Ubuntu)
summary: - Places plugin does not conform to expected behaviour in combination with
- Applications menu
+ Use mouse hover events to activate/close plugin menus
Alistair Buxton (a-j-buxton) wrote :

This bug is ancient. It is highly unlikely we will be able to fix it, as the application menu and places menu are two different plugins, so they can't communicate directly. So we would have to make a message passing system in the panel or combine the two plugins in to one.

On my desktop I also have a third menu for settings (just like the good old Gnome 2) - this is a separate instance of the applications menu, with a custom menu XML. It also doesn't open on mouseover, for the same reason.

The indicator menus over at the right also have this problem cmpared with how they work in Unity.

This bug used to annoy me at first but it's really very minor compared to the effort required to fix it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers