dragging applications in the task bar causes repaint errors

Bug #1397095 reported by Daniel Kessel on 2014-11-27
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Xfce panel
Fix Released
Medium
xfce4-panel (Ubuntu)
Medium
Unassigned

Bug Description

I am using the xubuntu-staging PPA on real hardware.

When dragging running applications in the task bar, black boxes appear in the panel.
The black boxes appear where whiskermenu and the places plugin would normally be drawn. When moving the mouse over the black boxes, they get redrawn correctly.

This happens on real hardware and on VirtualBox.

Virtualbox running current daily.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xfce4-panel 4.11.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic i686
ApportVersion: 2.14.7-0ubuntu10
Architecture: i386
CurrentDesktop: XFCE
Date: Thu Nov 27 20:22:51 2014
InstallationDate: Installed on 2014-03-16 (256 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140316)
SourcePackage: xfce4-panel
UpgradeStatus: Upgraded to vivid on 2014-11-20 (6 days ago)

Only external panel plugins placed left of the window buttons and close to the left screen seem to be affected by this glitch. Hovering over these panel items with the cursor restores the panel appearance.

xfce4-panel 4.10.0git-d296ca7 (Xfce 4.10)
Xubuntu 14.04 LTS Alpha 2

Related bug report (xfce4-whiskermenu-plugin):
https://github.com/gottcode/xfce4-whiskermenu-plugin/issues/37

Daniel Kessel (dkessel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

Can confirm this in vbox for whiskermenu icon.

I can't confirm for places plugin.

Nor can I confirm on hardware - panel moved to the bottom. Many changes from default panel here - no windows buttons. Adding windows buttons to the panel and still unable to confirm there.

Elfy (elfy) on 2014-11-27
description: updated
Changed in xfce4-panel:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xfce4-panel (Ubuntu):
importance: Undecided → Medium
Sean Davis (bluesabre) wrote :

The easiest way I have found to reproduce on hardware is just click and drag an item in the window list. Whiskermenu will become black until hovering it again.

This issue is triggered by the following gtk_widget_get_snapshot call:

http://git.xfce.org/xfce/xfce4-panel/tree/plugins/tasklist/tasklist-widget.c#n3032

Requirements for this glitch to occur when dragging a window button:

- panel placed on top
- show button labels
- any external panel plugin placed leftmost within the panel

Created attachment 5969
Do not use widget snapshot as tasklist draw icon

*** Bug 11567 has been marked as a duplicate of this bug. ***

*** Bug 11573 has been marked as a duplicate of this bug. ***

Too bad this fix did not make it into 4.12.0...

Works perfectly for me, nevertheles... Thanks!

*** Bug 11897 has been marked as a duplicate of this bug. ***

*** Bug 9096 has been marked as a duplicate of this bug. ***

What is the current status?

Thaddaeus Tintenfisch' patch works perfectly for me.
But it is neither committed to git nor released.

*** Bug 12001 has been marked as a duplicate of this bug. ***

Pushed the patch to git master:
8dc83f5 Do not use widget snapshot as tasklist draw icon

In , step21 (step21) wrote :

On Xubuntu 15.04 with XFCE 4.12, the bug is still active.

There is now no need of the snapshot widget to reproduce the bug.
To reproduce the bug, just boot the Xubuntu ISO as a live-CD into a VirtulBox, open a Thunar window then drag it.
The Whisker button disappears...

Xubuntu 14.04.3 XFCE 4.10

Bug is still present but:

- Panel is placed on bottom of the screen
- No external plugins used

*** Bug 12275 has been marked as a duplicate of this bug. ***

In , Luka (catai) wrote :

Created attachment 6606
Video of bug (theora ogg)

Mint 17.3 Xfce 4.12 Confirm bug, added details video. Please report to developers. Thanks!

Daniel Kessel (dkessel) wrote :

Still present in xenial.

tags: added: xenial
Nairwolf (nairwolf) wrote :

I can confirm it's still present on Xubuntu 16.04 amd64. But, the bug is different from the first screenshot from Daniel Kessel at #2.

This is what I have : https://i.imgur.com/sEC2C2l.png

Rip bLadez Ash (videxx) wrote :

Still hasn't been fixed: https://imgur.com/IUYPcnO

GVS (gvscheik1-g) wrote :

This bug is even worse on Xenial than stated above. And, on my system I believe the issue is with Whiskermenu alone and not with the panel: I.e., I have read that it only happens if Whiskermenu is in the far left of the panel etc. etc.... I have also read that any external plugin icon will do it if in the far left position. Not the case on all my XFCE systems (including other distros).

The truth is no matter where you put Whiskermenu on an XFCE 4.12 panel along with "Window Buttons" the icon will go black if the buttons are dragged. No other icon has this issue even if in the supposed offending position. Hence my opionion that this is really now a Whiskermenu issue alone.

I have tested the above assertions on Manjoro, Ubuntu, and Debian running XFCE 4.12. It is identical across distros. Again... seems like a Whiskermenu bug to me as I can not get another other plugin icon to do it on Xenial regardless of panel position.

Here is a fix. It is a bit of a kludge, but it works until they actually "fix" it.

1) Create another panel and place it to the far left of your panel with window buttons.
2) Move the Whiskermenu icon to the new panel and make the panel as short as possible using the panel's preferences.
3) Adjust the length of your main panel to account for the length of the new panel and have them meet. You may notice a seperation line... or not. It depends on your wallpaper darkness and how transparent your panels are etc..

Now you can drag Window buttons in the main panel and the tiny panel with Whiskermenu will be unaffected.

Nothing else works.

GVS (gvscheik1-g) wrote :

The above should read: "It is identical across distros. Again... seems like a Whiskermenu bug to me as I can not get another other plugin icon to do it on Xenial or other distros regardless of panel position."

For me, this issue occurs ONLY with Whiskermenu, and occurs regardless of position on a panel... including the far right of the window buttons.

Gottcode needs to look hard at this instead of sluffing it off on XFCE.

Kev Bowring (flocculant) wrote :

I've found that if you remove then re-add whisker to the panel then it's no longer affected by this.

Ivan Kozik (ludios) wrote :

There is a patch available:

"This has been fixed [0] and version 4.12.1 is no longer suffering this issue.

[0] https://git.xfce.org/xfce/xfce4-panel/commit/?id=8dc83f507d7340fa46c5b8927e5b320c5595fb7d
" https://bugzilla.xfce.org/show_bug.cgi?id=10656#c17

Ivan Kozik (ludios) wrote :

I can confirm that the xfce4-panel 4.12.1-2 package in Debian 9.0 (stretch) does not have this problem. I would recommend pulling that in. There are only a few other non-translation changes since 4.12.0 and they look like bugfixes.

Changed in xfce4-panel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.