wrapper-2.0 crashed with SIGSEGV in strrchr()

Bug #1389400 reported by Elfy on 2014-11-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Early vivid install with staging ppa.

Indicator panel crashes, readding to panel - get remove or execute box as it keeps crashing

Default indicators in the indicator-panel

Applications/Messages and Sound

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: xfce4-panel 4.11.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CrashCounter: 1
CurrentDesktop: XFCE
Date: Tue Nov 4 20:49:50 2014
ExecutablePath: /usr/lib/x86_64-linux-gnu/xfce4/panel/wrapper-2.0
ExecutableTimestamp: 1413285282
InstallationDate: Installed on 2014-10-24 (11 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022)
ProcCmdline: /usr/lib/x86_64-linux-gnu/xfce4/panel/wrapper-2.0 /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/libindicator-plugin.so 6 18874410 indicator Indicator\ Plugin Provides\ a\ panel\ area\ for\ Unity\ indicators.\ Indicators\ allow\ applications\ and\ system\ services\ to\ display\ their\ status\ and\ interact\ with\ the\ user.
ProcCwd: /home/hob
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f29e28ca1f5 <strrchr+37>: movdqu (%rdi),%xmm0
 PC (0x7f29e28ca1f5) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xfce4-panel
StacktraceTop:
 strrchr () at ../sysdeps/x86_64/strrchr.S:32
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
Title: wrapper-2.0 crashed with SIGSEGV in strrchr()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Elfy (elfy) wrote :
information type: Private → Public
Elfy (elfy) on 2014-11-04
description: updated

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1385624, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-amd64-retrace
Elfy (elfy) wrote :

Please unmark this as a dupe and if necessary mark https://bugs.launchpad.net/bugs/1385624 as the dupe.

I specifically set this bug AND marked it as private so those dev's involved in the Xubuntu team could access it.

Thanks

Elfy (elfy) wrote :

I marked it as public I meant.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints