Applications Menu plugin not showing Wine Programs submenu

Bug #1332385 reported by ToZ on 2014-06-20
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Xfce panel
Confirmed
Medium
garcon
Fix Released
Medium
garcon (Ubuntu)
Undecided
Unassigned
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

In Xubuntu 14.04, the Applications Menu plugin no longer shows the Wine Programs submenu.

$ apt-cache policy xfce4-panel
xfce4-panel:
  Installed: 4.11.0-0ubuntu1
  Candidate: 4.11.0-0ubuntu1
  Version table:
 *** 4.11.0-0ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status

Interestingly, if I right-click on the desktop, the xfdesktop menu display does show the Wine Programs submenu. Therefore, issue must exist with the xfce4-panel applications menu plugin.

I understand that the whisker menu plugin is the new default menu in 14.04, but some prefer the lighter, built-in applications menu plugin. This worked in previous versions of Xubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4-panel 4.11.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
CurrentDesktop: XFCE
Date: Thu Jun 19 22:25:03 2014
InstallationDate: Installed on 2014-04-09 (71 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Beta i386 (20140325.1)
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

ToZ (toz) wrote :
In , ToZ (toz) wrote :

I have been building Xfce from git (currently, xfce4-panel 4.11.1git-afc0031 (Xfce 4.10) ). The Applications Menu plugin does not display the Wine Programs submenu (it does in 4.10). Interestingly, if I right-click on the desktop and use xfdesktop's display of the Application Menu, it does show up. Issue is also present in Xubuntu 14.04.

ToZ (toz) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Phil Pemberton (philpem) wrote :

I can confirm this. If I use the Whisker menu, the WINE Programs menu appears fine. But on the Applications menu, it doesn't.

Chris (darkhelmetchris) wrote :

I can also confirm this bug on the following distributions:
1. Xubuntu 14.04 (amd64) with xfce4-panel 4.11.0
2. Linux Lite 2.0 (amd64) with xfce4-panel 4.11.0
On both distributions, the "Applications Menu, Wine" plugin does not show the "Programs" sub-menu.

Further, I see the same behavior ToZ found:
On both distributions, the Whisker menu correctly shows the "Wine, Programs" sub-menu.
On both distributions, the right-click desktop menu correctly shows the "Applications, Wine, Programs" sub-menu.

Angus G. (angus-gabb) wrote :

The same annoying bug appears on Linux Mint 17 (based on Ubuntu 14.04) with xfce4-panel 4.11.0-0ubuntu1 too.
But in opposite Wine does appear neither on the Whisker nor the xfdesktop menu ($ xfdesktop --menu) but in the application finder (alt+F3).
The underlying xfce4-applications.menu lists all Wine entries under "Other" but links them somehow with the category "Wine". But at this point my understanding of tree structure here and category structure there stops. If anybody could point out a good resource how the mentioned programs operate I would greatly appreciate it.

The bug described by ToZ comes from a more general Bug.

In Xfce, if a menu contains only submenues, this menu is not visible.
Using the "menu principal" in french or "Main menu", from the "alacarte" package, you can add a "new item" to the menu, then the menu will be visible.

For example, if you add any "new item" to the "Programs" menu of "Wine", then the "Programs" menu of "Wine" will be visible.
Il you remove all "item" from the "Programs" menu, it will disapear.

The same is true for any other menu, having only "submenus" without any items.
You can try adding a submenu to "System", it will not appear until you add an item to this submenu.

Temporarly, a way to deal with this bug is to add any "new item" to a menu, to make it appear.

This was tested with XUbuntu 14.04, on different computers and different installations.

I tested also that this bug doesn't exist under KDE and GOME, but exist under XUbuntu and under Xfce.

Changed in xfce4-panel:
importance: Unknown → Medium
status: Unknown → Confirmed

Since xfce4-popup-applicationsmenu was ported to new GarconGtkMenu [1], using <OnlyUnallocated> in menu file some categories aren't shown.

If <OnlyUnallocated> is used and all items are allocated to some sub-menu then the main category isn't shown at all. There's also a report about the issue in Launchpad [2].

Right click menu in desktop doesn't suffer this issue as IIUC it isn't ported to GargonGtkMenu.

[1] http://git.xfce.org/xfce/xfce4-panel/commit/?id=eb2098a7d18df0a2ecd995f781cc7c861337e1f6
[2] https://launchpad.net/bugs/1311981

Created attachment 6170
Screenshot of nonworking menu

Here's the screenshot about nonworking menu. I'm sorry about all text being in Finnish, but "Pelit" (games) and "Tiede" (sciences) categories are missing.

Created attachment 6171
Screenshot of working menu

Here's the screenshot of the working right click menu in desktop. You can see "Pelit" (games) and "Tiede" (sciences) categories.

Created attachment 6172
Used menu file

And here's the menu file.

Created attachment 6173
Fix for bug 11801

Seems the problem lies in garcon-gtk and there's an easy fix for it. See the attached patch for latest gargon git.

Tested it quickly and it seems to be working, at least for me.

*** Bug 9825 has been marked as a duplicate of this bug. ***

I've made source and .deb packages containing the fix. The packages are compatible with Ubuntu 14.04 "trusty" and are at http://uberstudent.net/pool/main/g/garcon/

Created attachment 6533
Add-menu-even-if-there-are-no-direct-children-except.patch

This is a patch against garcon.. why doesn't the whisker-menu have the problem, doesn't it use garcon?

Thanks!
Applied against xfce-base/garcon-0.5.0 on Gentoo, works as expected =)

Thanks, pushed to master in:
commit 6ce5f2f7d6e98493deb8153ea28f37d4489c5e21
Author: Jani Välimaa <email address hidden>
Date: Tue Apr 7 20:24:55 2015 +0300

    Fix missing menus when all items are in submenus (bug 11801)

    Signed-off-by: Eric Koegel <email address hidden>
http://git.xfce.org/xfce/garcon/commit/?id=6ce5f2f7d6e98493deb8153ea28f37d4489c5e21

I tried the patch with garcon 0.5.0 under Fedora 25, but the "Wine" entry and, more importantly for me, the "Crossover" and "Windows Applications" entries, installed by crossover, are still not shown in the Application Menu or the Whisker Menu, even after a reboot.

The missing entries are shown in the Application Finder, even without the patch, and they are also present under KDE, from which I recently switched, which should mean that they are present in the system.

Is there some cache clean-up that I need to do, in addition to rebuilding the library, or does the patch simply not work for my system?

jgratero (jgratero) wrote :

I can confirm this goes on with Xubuntu 16.04

groby (groby) wrote :

Same on Ubuntu-Studio 17.04

wgoltz (wgoltz) wrote :

In Xubuntu 17.04, adding new menus works as described by bernard5 for both applications menu and whisker menu panel items. The "other" menu in the applications menu panel seems to require a reboot to get it visible, after a bit of playing with the hide menu button. I am also affected by what looks like bug 1293151 in menulibre and the appearance of a "select an executable.." window which shows up sometimes when I hit the hide menu button. Hard to pick which action causes which result.

wgoltz (wgoltz) wrote :

(the hide menu buttons in menulibre)

wgoltz (wgoltz) wrote :

On my system, any changed to any menu causes the "other" menu item to hide in the application menu plugin (but it doesn't hide in the whisker menu). It reappears after a reboot.

Changed in xfce4-panel (Debian):
status: Unknown → New

Apparently, this was fixed in garcon (Xfce's menu library).

Xubuntu 18.04 includes version 0.6.1, and is therefore not affected by this bug anymore.

https://git.xfce.org/xfce/garcon/tree/NEWS

Changed in garcon (Ubuntu):
status: New → Fix Released
Changed in xfce4-panel (Ubuntu):
status: Confirmed → Invalid
no longer affects: xfce4-panel (Debian)
Changed in garcon:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.