Fails trying to hide the xfce4-panel panel 1

Bug #1049450 reported by David on 2012-09-12
172
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Xfce panel
Fix Released
Medium
xfce4-panel (Debian)
Confirmed
Unknown
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

In XFCE desktop, the panel 1, fail the auto hide mode.

I'm in ubuntu 12.10, versión beta. My architecture machine is i686.
The source package is: xfce4-panel 4.10.0 (Xfce 4.10).

After that, some times, don't work propperly the auto hide panel 1. And I have to kill and then rerun xfce4-panel to work via command line.
It is a problem, because when I have windows opened, as for example, LibreOffice, with that panel no working auto hide, I can't see the tool box, as File, Edit, Help, ... etc, menus of the LibreOffice.

I expected to happen that the panel 1 dissapear in a few seconds, because I had activated the "Auto Hide" in Preferences.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xfce4-panel 4.10.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic i686
ApportVersion: 2.5.1-0ubuntu7
Architecture: i386
Date: Wed Sep 12 05:15:32 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120905.2)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

After the sessions menu has been opened once the panel does not hide any more when autohide is enabled. Downstream report is at https://bugzilla.novell.com/show_bug.cgi?id=764310.

Further info, I was able to clear this bug by changing the panel mode to deskbar and then back to horizontal. This worked a few times but is no longer effective.

For me it was a click on the Action button for shutdown, etc, that killed the autohide.

Further info, reboot this morning gave restored autohide. clicking on Indicator plugin, action buttons or radio tray removes the autohide function. Switching to deskbar and back to horizontal cured this once but now it's stuck, until reboot I guess.

David (davidgptc02) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed

(In reply to comment #2)
> now it's stuck, until reboot I guess.

Hallo,

try runnung the "xfce4-panel -r" to fix the broken autohide, it works at least for me.

Created attachment 4661
Fix panel autohide broken by the Actions plugin menu

Fix:
Check the button toggle status in actions_plugin_menu() and avoid to popup
the menu if the button is not pressed.

Srinivas Murthy (smurthygr) wrote :

Same problem to me. I have two panels, top and bottom. Top panel autohides without any problem. Bottom panel does not autohide. Xubuntu 12.10, AMD64, Nvidia GT520, 8GB.

Pgr (pgr) wrote :

Can be trigger with Verve and running kate, konsole, lxterm and many other programs. Is reset by running xfce4-panel -r in the verve command line.
Using Mint 14 with
xfce4-panel (4.10.0-1ubuntu2) quantal
xfce4-verve-plugin (1.0.0-1build2) quantal

Michel Ruiz (michel-ruiz26) wrote :

Using Voyager 12.10 with xfce4-panel (4.10.0-1ubuntu2) quantal
3 panels but only the top-one have the problème
It's triggered only by using the "name" button (right top) and clicking left button of the mouse
I have created a button with "xfce4-panel -r" command (Kurapika29's idea)

kura (dash29-free) wrote :

I found this in .xsession-errors
"(xfce4-panel:10385): GLib-WARNING **: GChildWatchSource: Exit status of a child process was requested but ECHILD was received by waitpid(). Most likely the process is ignoring SIGCHLD, or some other thread is invoking waitpid() with a nonpositive first argument; either behavior can break applications that use g_child_watch_add()/g_spawn_sync() either directly or indirectly."
If that could help

Reproducible with xfce4-panel 4.10.0-1ubuntu2 under Quantal.
Set panel autohide=true.

*Click "Action Buttons" (as default it is in right top corner and label is your (login) name)
 -menu opens
*Click button again to cancel Menu.
OR
*Click somewhere else to hide Menu.
OR
*Select some entry from Menu (suspend/hibernate/lock screen)

-> Panel is not hiding anymore.
---
Workaround: run
xfce4-panel -r &
----
Upstream bug (with patch):
https://bugzilla.xfce.org/show_bug.cgi?id=8960

Which I got working:
apt-get source xfce4-panel
sudo apt-get build-dep xfce4-panel
cd xfce4-panel
wget https://bugzilla.xfce.org/attachment.cgi?id=4661
patch -p1 < attachment.cgi\?id\=4661
rm attachment.cgi\?id\=4661
dpkg-source --commit
fakeroot dpkg-buildpackage
sudo dpkg -i ../xfce4-panel_4.10.0-1ubuntu2_*.deb
xfce4-panel -r &

Jacob (jacob11) wrote :

Nick (or some other helpful Xfce developer) fixed the Xfce panel autohide bug some months ago.

The quickest/easiest way I know of to remove that bug - along with several others, including the "desktop background fails to switch to a random one from the user's list of chosen backgrounds at N minutes (N selected by user) properly" - is to open a terminal window and type:

sudo add-apt-repository ppa:xubuntu-dev/xfce-4.10

followed by:

sudo add-apt-repository ppa:xubuntu-dev/xfce-4.12

This will add both repos to your sources list (along with their keys). Next, you will want to refresh the latest list of software for your system, by typing (again, in the terminal window):

sudo apt-get update

Now you can update your system as you normally would, either in the terminal or via your GUI update manager (in which case you could have skipped typing sudo apt-get update and simply have told your update manager to refresh its cache).

NOTES: These two PPAs are run by the Xubuntu developers, so should not have any malicious code in them. I have added them to numerous (approximately 25) computers ranging in age from a three-day old laptop and a two-month old desktop to laptops/desktops that are over eight years old - running Xubuntu, Mint Xfce, and Ultimate Edition (all are "Ubuntu derivatives" and can, therefore, use PPAs) in both 32- and 64-bit versions. Although 25 examples of success is a relatively small sampling, it was a rather good mix of hardware and I witnessed ZERO problems so, while as always I must add the disclaimer of "YMMV," I have every reason to believe that you will also have no trouble. These two repos are set up to work with distros based on Ubuntu's versions Precise, Quantal, and Raring (12.04LTS, 12.10, and 13.04).

QUESTION: With all due respect (not being one to make value-judgements, I will have to leave it to others to quantify this, lol), since this bug was fixed a long time ago (in "computer time" terms) by the Xfce developers, and the fix has been available both through PPAs and other "places" (including source code), and the fix has STILL not landed in the official mainstream update channel, shouldn't the status be changed, rightfully, from "Confirmed" to "Won't Fix?" It's not like the problem - or more to the point, the solution to the problem - is new. Or... Perhaps this bug needs a new status created just for it, "Already fixed... but not for the masses."

Hope this helps (I know it will)!

(In reply to Petr Gajdůšek from comment #4)
> Created attachment 4661 [details]
> Fix panel autohide broken by the Actions plugin menu

The bug is still present in 4.10.1. Please, consider pushing it.

Debian bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714066

Srinivas Murthy (smurthygr) wrote :

It is really strange to see that when there is a fix it is not included 'for the masses'. I think I shall add the two PPAs, but I worry about changing other things that I am not facing any problems right now and facing new problems!

Srinivas Murthy (smurthygr) wrote :

Ok. I have done it, if there are any problems, is there any way to revert? Please let me know as I am not an expert. Thanks.

Kilian Holzinger (kili4n) wrote :

also experiencing this on xubuntu 13.10.
it usually occurs after unlocking a locked screen. or after waking up from hibernation.

Remun.J (remun-j66) wrote :

Me too Kilian after resuming a suspend and when clicking two times on the default top-right button with your login name on it. The bottom panel is hiding okay but the top panel on the other hand doesn´t hide. Have to reboot or reset the panels in the terminal with xfce4-panel -r ... Hope they can fix this : )

Remun.J (remun-j66) wrote :

Strange i somehow fixed it by moving around some buttons in the task bar and changed the action menu on the right to some button (actually i disabled most and left with one i need most, the off button). Okay i will still test it the next days so i will report when someting goes wrong. Also created that launcher button to reset all panels with the xfce4-panel -r command ...

From what I have experienced I think wherever the problematic panel is doesn't matter, be it top, left, right, or bottom.
The panel with the action buttons (the one with your user name on it, with log out, shutdown, and other options) tends to be the one with the autohide problem.
#7 already solves the problem, though I had to add some 'sudo's in the commands for it to completely work.
I agree with #8 on the supposed status of this bug.

Steffen Petersen (spet) wrote :

I recently upgraded my Xubuntu from Precise to Saucy (I actually did a fresh install) and this bug persists: After going to sleep, my only panel fails to auto-hide.

@jacob11 quite reasonably asked, why the patch fixing this bug hasn't made it to the release channel. Here six moths later, the question still goes unanswered.

Dear devs, with all possible respect for your work, please include the known fix or let us know why you wont.

Confirmed, Saucy 13.10. When it happens running

     xfce4-panel -r

fix the issue. It happens just with the top panel for me (panel 1); panel 0 works ok.

Shimon Zadok (shimon-zadok) wrote :

This happens for also in 13.10. No matter how much I reset the panel, it still comes back.
Every time my PC goes into lock, and I log back in, the panel is stuck.

Lucio Crusca (lucrus) wrote :

In my case xfce4-panel -r is not an acceptable workaround because it kills and restarts the whole X server, so it's not that different compared to a reboot.

Bug is still present in Debian Jessie.

> Petr Gajdůšek 2012-10-14 08:16:38 CEST
> Created attachment 4661 [details]

Patch unapplied and ignored since 2012? Is anyone still maintaining xfce4-panel?

The bug has been reported in Xubuntu 14.04 (package xfce4-panel 4.11.0-0ubuntu1):

For the description in 14.04 (can be replicated):
https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/1325348

For the thread where this issue has been followed since 05/2013:
https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/1183147

Changed in xfce4-panel (Debian):
status: Unknown → Confirmed
Changed in xfce4-panel:
importance: Unknown → Medium
status: Unknown → Confirmed

Thank you and sorry for the massive delay. I have pushed the patch to master.

Srinivas Murthy (smurthygr) wrote :

I upgraded to xubuntu 14.04 and the problem persisted. I have now reinstalled Xubuntu 14.04 (for different reasons) and the problem still persists. When I suspend the system and come back, the panels do not autohide. I have to use the 'xfce4-panel -r' command to make the panels autohide again.

I also have this same fault. I have top & bottom auto-hide panels on xubuntu 14.04. If I even look at my top-right suspend/shut down/restart/logout menu item the auto-hide stops. Logging out and back in, or entering command "xfce4-panel -r" fixes it, but it is irritating. It's all too easy to open the menu item by mistake on my laptop, resulting in some unrepeatable language, again :)

Since the patch has been pushed, I'm marking this as fixed.

Changed in xfce4-panel:
status: Confirmed → Fix Released
Srinivas Murthy (smurthygr) wrote :

The problem still continues for me. I have two panels. Even if I click once on the shutdown button on my bottom panel, it refuses to autohide, however the top panel autohides as usual. I have to use the command 'xfce4-panel -r' to make the bottom panel autohide again.

Apologies for asking a dumb question, but how do I find out what version of xfce4-panel contains the fix? I'm on xubuntu 14.04 and I haven't seen an update yet.

johny why (johnywhy) wrote :

hello,

i'm running xfce 4.10.1.

my panel 1 does not auto-hide.

i see this bug is over 5 years old.

a patch is mentioned above.

do i need to download this patch separately from xfce?

how can i fix this?

i'm running kernel 3.14.20, if that matter.

thx

hawran (hawran.diskuse) wrote :

#29, #31 - EXACTLY.

The workaround (xfce4-panel -r from a cmdline) works, however, this is REALLY ANNOYING.
(And shame, I'd say: Bug #1049450 reported by David on 2012-09-12)

SYSINFO:
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.3 LTS
Release: 14.04
Codename: trusty
$

xfce 4.10

Srinivas Murthy (smurthygr) wrote :

After so many years and so many new versions, the problem continues for me. If I click the shutdown button, the bottom panel does not autohide and I have to use the workaround. The patch which is supposed to have been pushed does not appear to work.

nick_s (nickstylianou) wrote :

This also affects me on a fresh install of xubuntu-14.04.3-desktop-amd64 with all updates.
The command xfce4-panel --version reports "xfce4-panel 4.11.0 (Xfce 4.10)".

A workaround that seems to have fixed it for me is to insert a separator as the last item in my panel (to the right of the "Action Buttons" item).

Srinivas Murthy (smurthygr) wrote :

I have the same version and I tried adding a separator after 'Action Buttons', but the problem continues for me. Only the workaround (xfce4-panel -r from a cmdline) works. I wonder how this remains unresolved for so long. Is nobody else using Xface.

I moved on to 15.10 and the problem is fixed there.

nick_s (nickstylianou) wrote :

Srinivas, just for completeness, you may want to compare with my panel settings, which are:
 Mode: Horizontal
 (YES) Lock Panel
 (YES) Automatically show and hide the panel
 (NO) Don't reserve space on borders
 Row Size (pixels): 32
 Number of rows: 1
 Length (%): 100
 (YES) Automatically increase the length
and my panel is located at the top edge of the screen.

Note that the tooltip help for the "Automatically show and hide the panel" checkbox says "This only works when the panel is attached to a screen edge", so try unlocking your panel then moving it to make sure its location snaps to a screen edge (and then lock your panel again).

However, the screen edge can be a problem if you're using a television for your display (e.g. for a Home Theatre PC), as these often overscan (i.e. the edges of your desktop are beyond the edges of the display).

Srinivas Murthy (smurthygr) wrote :

My panel preferences are exactly the same. I tried removing the separator at the end as I already had it with the same result. Adding the separator again also made no difference. Upgrading to 15.10 may be the only real solution.

Srinivas Murthy (smurthygr) wrote :

Now I have upgraded to Xubuntu 15.10, and the problem seems to have been solved. Thanks for everyone concerned.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.