Panel 0 xfce4-indicator-plugin misbehavior in Trusty

Bug #1302571 reported by Richard Elkins on 2014-04-04
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
xfce4-indicator-plugin (Ubuntu)
Medium
Sean Davis

Bug Description

This is a minor annoyance in my opinion. Please don't classify this as "High".

Original gross symptoms:
* Indicator plug-in is missing the Sound Menu and Power Mgmt indicators.
* The "Hidden" check boxes were confusing because clicking (set or reset) didn't always produce visible changes (pending restart of the xfce4-panel).

Working with Simon Steinbeiß, I installed an additional PPA:
sudo add-apt-repository ppa:thad-fisch/test
sudo apt-get update
sudo apt-get install xfce4-indicator-plugin

Some observations follow.

The good news:
* The Sound Menu indicator which was not visible before is now visible.
* Setting the overall "hide indicators by default" function now works. The change is visible immediately and Logout-login shows "No Indicators" on Panel 0.
* Clearing the "hide indicators by default" function now works. The change is visible immediately and Logout-login shows the indicators restored on Panel 0.
* Setting the "hidden" switch on an individual indicator works. The change is visible immediately and Logout-login shows the indicator to be missing as expected on Panel 0.

Room for improvement:
* Still missing on Panel 0: Power Management indicator. This machine has indicator-power 12.10.6+14.04.20140328-0ubuntu1 installed.
* Clearing a "hidden" switch appears to be like a dead action because no change to the checkbox is immediately visible to the operator. However, after logout-login, the reset did actually take even though it was not visible before logout. Clearing the box should be immediately visible even though logout-login is needed for the clear to be in effect.

Need any tests or further logs or other info from me?

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4 (not installed)
ProcVersionSignature: Ubuntu 3.13.0-22.44-generic 3.13.8
Uname: Linux 3.13.0-22-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Apr 4 07:38:40 2014
InstallationDate: Installed on 2013-10-08 (177 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Beta amd64 (20131008)
SourcePackage: xfce4
UpgradeStatus: Upgraded to trusty on 2014-03-25 (9 days ago)

Related branches

Richard Elkins (texadactyl) wrote :
affects: xfce4 (Ubuntu) → xfce4-indicator-plugin (Ubuntu)
Alistair Buxton (a-j-buxton) wrote :

It says right on the config "Please restart the panel for visibility changes to take effect."

I don't think that one is easily fixable, and certainly not for trusty.

Richard Elkins (texadactyl) wrote :

Yes, I know about that notice. But, the checkbox should reflect the last click affect (checked on or off) or one begins to wonder whether or not the panel took note of the operator request for a change. Of course, the user should do as I indicated above what I did before expecting to see the affect on Panel 0: logout and re-login.

At the top, I did recommend that this not be a high priority. Unfortunately, it is an issue that people upgrading from Precise and Saucy are going to see under similar circumstances.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-indicator-plugin (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1302571

tags: added: package-qa-testing
Simon Steinbeiß (ochosi) wrote :

@Richard: Just to be sure: do you actually have a battery in your computer, i.e. is it a laptop? The power-indicator is only shown when there's a device with a battery and hidden on desktops.

Richard Elkins (texadactyl) wrote :

Thank you, @Simon.

No, I do not have a battery as it is a desktop. Clearly, I misinterpreted the "Power Manager" indicator function. However, why is the Power Manager indicator present in the indicator table if it is inapplicable as you stated? The indicator shouldn't be in the table if it is undefined for the user. Agree?

Again, this bug report should not be viewed as a high priority. Aside from the PPA fix referred to in the bug description, I would recommend not taking any more action before the release unless there is some "low hanging fruit" that someone would like me to try out (E.g. a 2nd PPA).

Xubuntu QA should develop a test case specifically for the indicators as this is not the first time in the last 12 months that we've seen regression in this area.

It's a usability issue that doesn't limit the functionality of a core package.

Changed in xfce4-indicator-plugin (Ubuntu):
importance: Undecided → Medium
Mike Yontz (swftech) wrote :

I have also lost my sound indicator/menu after a recent update. I also noticed that there are no longer sound settings anywhere to be found. Normally in system settings there is a sound option, but that seems to have disappeared as well.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1302571

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-indicator-plugin - 2.3.2-0ubuntu2

---------------
xfce4-indicator-plugin (2.3.2-0ubuntu2) trusty; urgency=medium

  * Add 01_upstart-init.patch (Fixes LP: #1302571)
 -- Sean Davis <email address hidden> Mon, 07 Apr 2014 21:48:58 -0400

Changed in xfce4-indicator-plugin (Ubuntu):
status: Confirmed → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in xfce4-indicator-plugin (Ubuntu):
assignee: nobody → Sean Davis (smd-seandavis)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Bug attachments