blank Properties window

Bug #1290803 reported by Sergio Benjamim on 2014-03-11
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Xfce4 Indicator Plugin
Fix Released
High
xfce4-indicator-plugin (Ubuntu)
High
Jackson Doak

Bug Description

I'm getting a blank Properties window when i previously closes it by the window close/exit button.

Steps to reproduce:

- right click in some gtk3 indicator, click in Properties;
- closes the Properties window by the window close/exit button;
- try to open the Properties window again, and you will get a blank window.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4-indicator-plugin 2.3.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CasperVersion: 1.338
Date: Tue Mar 11 11:57:35 2014
LiveMediaBuild: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140311)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-indicator-plugin
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Sergio Benjamim (sergio-br2) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1290803

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-indicator-plugin (Ubuntu):
status: New → Confirmed
Jack Kern (schproodle) wrote :

vbox 4.3.8 64bit

Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

xfce4-indicator-plugin:
  Installed: 2.3.0-0ubuntu1
  Candidate: 2.3.0-0ubuntu1
  Version table:
 *** 2.3.0-0ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Can NOT reporduce problem in 14.04

Simon Steinbeiß (ochosi) wrote :

Running xfce4-panel from the terminal, I get the following error message:
(wrapper-2.0:7138): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed

So this is either a regression in xfce4-indicator-plugin or in the xfce4-panel's wrapper2.

summary: - blanck Properties window
+ blank Properties window
description: updated
Jack Kern (schproodle) wrote :

I was able to reproduce the indicator plugin blank window problem, if you continue using the "close" button, it will work fine until you use "X" to close the window.

Changed in xfce4-indicator-plugin (Ubuntu):
importance: Undecided → High

If you click the "X" button to close the Properties window, it will not render properly the next time you open it. Using the "Close" button instead does not trigger the faulty behavior.

Terminal output:
  wrapper-2.0:7138): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed

Version:
  xfce4-indicator-plugin 2.3.1-0ubuntu1

Distribution:
  Xubuntu 14.04 LTS (Dev)

Changed in xfce4-indicator-plugin:
importance: Unknown → High
status: Unknown → Confirmed

Should be now fixed in:
162fac0 Fix blank properties window, but #10749

I applied your patch and can confirm that it resolves the problem. Thanks!

Jackson Doak (noskcaj) on 2014-03-15
Changed in xfce4-indicator-plugin (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jackson Doak (noskcaj)
milestone: none → ubuntu-14.04-beta-2
Changed in xfce4-indicator-plugin:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-indicator-plugin - 2.3.2-0ubuntu1

---------------
xfce4-indicator-plugin (2.3.2-0ubuntu1) trusty; urgency=medium

  * New upstream release.
    - Fixed xfce bug #10749: "blank properties window". LP: #1290803
 -- Jackson Doak <email address hidden> Sun, 16 Mar 2014 09:01:47 +1100

Changed in xfce4-indicator-plugin (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.