xfce4-appfinder crashed with SIGSEGV in g_type_check_instance_cast()

Bug #1016671 reported by Elizabeth K. Joseph on 2012-06-22
292
This bug affects 59 people
Affects Status Importance Assigned to Milestone
xfce4-appfinder
Unknown
Unknown
xfce4-appfinder (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Here's what I did:

Launched xfce4-appfinder from the default bottom panel, launched gimp from it.

Logged out.

Logged back in, and crash report symbol appeared in the top panel.

I still seem to be able to launch appfinder without a problem.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: xfce4-appfinder 4.10.0-1
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic x86_64
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
Date: Fri Jun 22 11:06:00 2012
ExecutablePath: /usr/bin/xfce4-appfinder
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120622)
ProcCmdline: xfce4-appfinder
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f97cd6608f0 <g_type_check_instance_cast+16>: mov (%rdi),%rax
 PC (0x7f97cd6608f0) ok
 source "(%rdi)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: xfce4-appfinder
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: xfce4-appfinder crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Elizabeth K. Joseph (lyz) wrote :

StacktraceTop:
 g_type_check_instance_cast (type_instance=0xaaaaaaaaaaaaaaaa, iface_type=iface_type@entry=80) at /build/buildd/glib2.0-2.33.2/./gobject/gtype.c:3994
 xfce_appfinder_window_icon_theme_changed (window=0x7f97d199c010) at appfinder-window.c:1452
 _g_closure_invoke_va (closure=0x7f97d1b4acd0, return_value=0x0, instance=0x7f97d1980080, args=0x7fff90759a48, n_params=0, param_types=0x0) at /build/buildd/glib2.0-2.33.2/./gobject/gclosure.c:840
 g_signal_emit_valist (instance=0x7f97d1980080, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fff90759a48) at /build/buildd/glib2.0-2.33.2/./gobject/gsignal.c:3207
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.33.2/./gobject/gsignal.c:3352

Changed in xfce4-appfinder (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-appfinder (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1016671

tags: added: iso-testing
Blair Chasteen (darkstormyrain) wrote :

Running ubuntu-studio live from my dvd-ram drive. I hit alt-f2 to bring up app finder then I got the crash report notification.

Linux ubuntu-studio 3.5.0-9-lowlatency #8-Ubuntu SMP PREEMPT Thu Aug 9 16:53:37 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Mark Preston (emarkpreston) wrote :

Powered up computer. First thing that happened after entering my password and watching XFCE desktop come on-screen is the error message: Sorry, Ununtu 12.04 has experienced an internal error. If you notice further problems, try restarting the computer.

I then click "Continue" to send a report. I have done this now nearly a dozen times. I'm not complaining. I'm only confused.

Forest (foresto) wrote :

You're not the only one, Mark. On xubuntu 12.10, xfce4-appfinder crashes for me about a dozen times a day, both at login and often when I hit Alt+F2 to run a command by name. Ubuntu's crash UI appears each time, but I have no idea whether the reports we send are being seen.

Kai Blin (kai.blin) wrote :

Still present in today's 13.04 beta

tags: added: raring
Changed in xfce4-appfinder (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Lionel Le Folgoc (mrpouit)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-appfinder - 4.10.0-1ubuntu1

---------------
xfce4-appfinder (4.10.0-1ubuntu1) raring; urgency=low

  * debian/patches/01_fix-crash-detach-icon-theme.patch: added, fix 'invisible'
    crash on logout. lp: #1016671
 -- Lionel Le Folgoc <email address hidden> Sat, 16 Mar 2013 22:43:28 +0100

Changed in xfce4-appfinder (Ubuntu):
status: In Progress → Fix Released
Shiki (shiki) wrote :

The fixed package should be pushed into Quantal as well.
(I uploaded the patched version into my personal PPA as soon as Nick replied and didn't have a crash ever since.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.