xfce crashes repeatedly after changing icon theme to default

Bug #65870 reported by Przemek K. on 2006-10-13
22
Affects Status Importance Assigned to Milestone
human-cursors-theme (Ubuntu)
Medium
Daniel Holbach
kubuntu-default-settings (Ubuntu)
Medium
Unassigned
xfce-mcs-manager (Ubuntu)
Undecided
Unassigned

Bug Description

xfce crashes repeatedly after changing icon theme to default, after manually editing the config file and changing back to tango everything works fine

Przemek K. (azrael) wrote :

Here's the crash report, I couldn't send it earlier due to a proxy error

Jani Monoses (jani) wrote :

I can reproduce this

Changed in xfce-mcs-manager:
status: Unconfirmed → Confirmed
Jani Monoses (jani) wrote :

apparently LP ate my previous comment?
The cursor.theme file shipped by human-cursors-theme that is installed in /usr/share/icons/default/index.theme lacks a Directory= entry as requested by the fdo icon theme spec. This makes the whole Xfce desktop crash. It should be more resilient and needs fixing to be 'liberal in what it accepts' but the cursor theme file need fixing as well.
Just an empty Directories= appended suffices to keep xfce from crashing.

Daniel Holbach (dholbach) wrote :

Does this happen with industrial-cursor-theme also? It does not have a Directories entry either.

Changed in human-cursors-theme:
assignee: nobody → dholbach
status: Unconfirmed → Needs Info
Jani Monoses (jani) wrote :

installed industrial but it does not appear in the icon theme selector. Which is correct since it is a cursor theme. So the prob with human could be that it is named index.theme which is the name of icon them files?

66193 is similar and I reproduced it, and the reporter said that affects gnome as well.

Jani Monoses (jani) wrote :

renaming index.theme to cursor.theme solves the problem as well by not even showing this in the icon theme options. I think this is the better solution actually, no need to modify the file.

Daniel Holbach (dholbach) wrote :

Fix works on Ubuntu and Xubuntu.

Added:
 Hidden=true
 Directories=

Changed in human-cursors-theme:
status: Needs Info → Fix Committed
Daniel Holbach (dholbach) wrote :

Marking RC, confirmed by Dup.

Changed in kubuntu-default-settings:
status: Unconfirmed → Confirmed
Changed in human-cursors-theme:
importance: Undecided → Medium
Daniel Holbach (dholbach) wrote :

 human-cursors-theme (0.4-0ubuntu1) edgy; urgency=low
 .
   * New release:
     - cursor.theme: added Hidden=True entry to make it not show up as a Icon
       theme in XFCE, added Directories= entry to make xfce-mcs-manager not crash
       (Malone: #65870)

Changed in human-cursors-theme:
status: Fix Committed → Fix Released
Matt Zimmerman (mdz) wrote :

Note that human-cursors-theme is waiting in the unapproved queue; should be processed after RC

Jani Monoses (jani) on 2006-10-20
Changed in xfce-mcs-manager:
status: Confirmed → Fix Released
Daniel Holbach (dholbach) wrote :

 kubuntu-default-settings (1:6.10-61) edgy; urgency=low
 .
   * ./cursors/default/index.theme,
     ./cursors/index.theme: added Directories= entries. (Malone: #67631, #65870)

Changed in kubuntu-default-settings:
importance: Undecided → Medium
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers