xfburn crashed with SIGSEGV in burn_fifo_source_shoveller()

Bug #321238 reported by Eric Dantie
8
Affects Status Importance Assigned to Milestone
xfburn (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xfburn

failed at 96% of burning a CDROM

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/xfburn
Package: xfburn 0.4.0-0ubuntu1
ProcCmdline: xfburn
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_IE.UTF-8
 LANGUAGE=en_IE:en
Signal: 11
SourcePackage: xfburn
StacktraceTop:
 burn_fifo_source_shoveller ()
 ?? () from /usr/lib/libburn.so.4
 start_thread () from /lib/libpthread.so.0
 clone () from /lib/libc.so.6
 ?? ()
Title: xfburn crashed with SIGSEGV in burn_fifo_source_shoveller()
Uname: Linux 2.6.28-5-generic x86_64
UserGroups: adm admin audio cdrom clamav dialout dip floppy fuse lpadmin plugdev pulse sambashare video

Revision history for this message
Eric Dantie (edantie) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:burn_fifo_source_shoveller (
fifo_worker_func (w=<value optimized out>)
start_thread () from /lib/libpthread.so.0
clone () from /lib/libc.so.6
?? ()

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xfburn:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Comments from Xfce developer:
  ------- Comment #1 From David Mohr 2009-02-22 05:50:40 UTC (-) [reply] -------

This is a known problem with libburn versions < 0.5.6. Please update to libburn
0.5.6 or newer, where this problem will not occur anymore.

I've made libburn 0.5.6 the required minimum version from now on (see rev.
6738).

Changed in xfburn:
status: Triaged → Fix Committed
Changed in sfburn:
status: Unknown → Fix Released
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Libburn 0.6.4-1 is now in karmic.

Changed in xfburn (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.