FFe: Please package xfburn 0.5.0

Bug #1282937 reported by Jackson Doak
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xfburn (Ubuntu)
Undecided
Jackson Doak

Bug Description

Please update xfburn to the new 0.5.0 release. All the major changes are already in as patches, but 4 years of bugfixes and translation improvements (One translation is completely broken in 0.4.3) are in the new release. A debdiff is attached.

Revision history for this message
Jackson Doak (noskcaj) wrote :
Pjotr12345 (computertip)
no longer affects: xfburn (Debian)
Revision history for this message
Pjotr12345 (computertip) wrote :

I think it's very important to have this bugfix release in 14.04, as it's the new LTS.... It'll make a real quality difference, not only for Xubuntu, but also for Lubuntu and even for Ubuntu (many Ubuntu users prefer Xfburn, which integrates well in Unity).

Revision history for this message
Heimen Stoffels (vistaus) wrote :

Xfburn was always a great tool for burning and the fact that it just had a major release after 4 years proves it still is! Please make 0.5.0 available in 14.04 - It'll make 14.04 even better!

Revision history for this message
David Mohr (bugs-da) wrote :

I think it is important to note that all the major changes in 0.5.0 have been thoroughly tested since they were included as patches to 0.4.3 before. This means that accepting this package has a low chance of regressions and will provide the advantages that others have already mentioned.

Sorry for getting the release so late out of the door!

Revision history for this message
Pjotr12345 (computertip) wrote :

@David Mohr: no need to apologize for anything.... The main thing is: we have this fine bugfix release. Thanks to you! :-)

Now if we could get it into Xubuntu 14.04, that would be "the icing on the cake".....

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your work, trusty is feature frozen, you are going to need an ffe for that update (https://wiki.ubuntu.com/FeatureFreeze)

Jackson Doak (noskcaj)
summary: - Please package xfburn 0.5.0
+ FFe: Please package xfburn 0.5.0
Revision history for this message
Jackson Doak (noskcaj) wrote :
Revision history for this message
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj)
description: updated
Revision history for this message
Jackson Doak (noskcaj) wrote :
Revision history for this message
Jackson Doak (noskcaj) wrote :
Changed in xfburn (Ubuntu):
status: In Progress → New
Pjotr12345 (computertip)
Changed in xfburn (Ubuntu):
status: New → Confirmed
Revision history for this message
Jackson Doak (noskcaj) wrote :

the status should be NEW for the release team to grant an FFe

Changed in xfburn (Ubuntu):
status: Confirmed → New
Revision history for this message
Pjotr12345 (computertip) wrote :

@Jackson Doak: I'm sorry. :-)

Thanks for your support for this release, by the way. Much appreciated.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfburn (Ubuntu):
status: New → Confirmed
Revision history for this message
Stephen Michael Kellat (skellat) wrote :

Consideration Of Documentation Sign-off For Feature Freeze Exception

1. Doc String Freeze has not yet hit.
2. xubuntu-docs does not contain screenshots of programs so any change in package would not impact shipped documentation in that respect.
3. The program is mentioned in two chapters of xubuntu-docs. The relevant passage that needs to be considered is from Chapter 5 which states:

"You can make your own CDs and DVDs by burning files onto a blank disc using the CD or DVD writer drive of your computer.

"Xfburn is the default application in Xubuntu to complete these tasks. Xfburn allows you to to easily create audio CDs, burn CDs and DVDs with either plain data or disk images and prepare blank re-writable disks for a new burn.

"In order to launch Xfburn, go to → Multimedia → Xfburn.

"Once launched, you can insert a CD-R(W) or DVD-R(W) you wish to write to and then select the button corresponding to the action you wish to take (New Data Composition, Audio CD, etc.)."

Before Sign-off can be given from Documentation, an answer is required as to whether or not the passage above remains valid with respect to the new version in terms of functionality. If it is, Sign-off may be granted. If not, a merge proposal to xubuntu-docs to fix the passage needs to be prepared expeditiously.

Revision history for this message
Pjotr12345 (computertip) wrote :

@Stephen Michael Kellat: the documentation passage is still fully valid for Xfburn 0.5.0. No changes necessary.

I tested it in Xubuntu 14.04 (I used Alien to convert an RPM from Fedora Rawhide to a .deb, because Fedora has already packaged Xfburn 0.5.0 for Rawhide).

Revision history for this message
Stephen Michael Kellat (skellat) wrote :

The attached screenshot looks okay. The question is whether or not the deployment of whiskermenu makes the text above still make sense. Will xfburn still be found under Multimedia or will some fiddling still need to be handled?

Once that can be answered we can dispose of Docs Sign Off and then XPL Sign Off would be the last to go.

Revision history for this message
Jackson Doak (noskcaj) wrote : Re: [Bug 1282937] Re: FFe: Please package xfburn 0.5.0

It's still multimedia in whiskermenu

On Mon, Mar 3, 2014 at 1:51 PM, Stephen Michael Kellat <<email address hidden>
> wrote:

> The attached screenshot looks okay. The question is whether or not the
> deployment of whiskermenu makes the text above still make sense. Will
> xfburn still be found under Multimedia or will some fiddling still need
> to be handled?
>
> Once that can be answered we can dispose of Docs Sign Off and then XPL
> Sign Off would be the last to go.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282937
>
> Title:
> FFe: Please package xfburn 0.5.0
>
> Status in "xfburn" package in Ubuntu:
> Confirmed
>
> Bug description:
> Please update xfburn to the new 0.5.0 release. All the major changes
> are already in as patches, but 4 years of bugfixes and translation
> improvements (One translation is completely broken in 0.4.3) are in
> the new release. A debdiff is attached.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xfburn/+bug/1282937/+subscriptions
>

Revision history for this message
Stephen Michael Kellat (skellat) wrote :

Based upon the answers given and unless countermanded by Xubuntu Docs lead Jack Fromm, I'm granting Docs Sign Off for this Feature Freeze Exception. The next stop is requesting Sign Off by Xubuntu Project Leader which is then followed by requesting the Feature Freeze Exception be granted by release team.

Revision history for this message
Pasi Lallinaho (knome) wrote :

As long as the uploader commits to fix any potential regressions, I'm fine with this. Thus, approving with my Xubuntu Project lead hat on.

Revision history for this message
Pjotr12345 (computertip) wrote :

Thank you, Pasi!

The developer, David Mohr, has told me that he's willing to do a new "emergency bugfix release", in the unlikely event that serious regressions would appear in 0.5.0. So I think we can be reassured about that...

Revision history for this message
Sebastien Bacher (seb128) wrote :

setting the status to "New" since the release team uses that to sort out things that are waiting for review

Changed in xfburn (Ubuntu):
status: Confirmed → New
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Unsubscribing sponsors as the FFe has not been approved yet. Please subscribe back once it is.

Revision history for this message
Iain Lane (laney) wrote :

Ok. Ack.

I'd appreciate it if you could contribute this package back to Debian.

Revision history for this message
Jackson Doak (noskcaj) wrote :

I've already forwarded this to debian

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks, there is no vcs link nor tarball to sponsor there though.

Can you give us something that can be sponsored, e.g at least the url of the upstream tarball and the debian directory, or the upstream tarball and a .dsc/.diff.gz

Revision history for this message
Jackson Doak (noskcaj) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Sponsored, thanks!

Changed in xfburn (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfburn - 0.5.0-0ubuntu1

---------------
xfburn (0.5.0-0ubuntu1) trusty; urgency=medium

  * New upstream release (LP: #1282937)
  * Drop all patches except the .desktop one, fixed upstream
 -- Jackson Doak <email address hidden> Fri, 21 Feb 2014 19:03:28 +1100

Changed in xfburn (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers