Touchscreen working on Lucid Alpha 2, Breaks with Recent Upgrades

Bug #510311 reported by Shaved Wookie on 2010-01-20
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xf86-input-wacom (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by RussianNeuroMancer

Bug Description

Binary package hint: xorg

Not sure if this is a Xorg bug, a HAL bug, a devicekit bug or a kernel bug, but here goes:

When I installed Kubuntu Lucid Alpha 2 (alternate cd) on my Dell Latitude XT my touchscreen worked without any configuration (at least mouse movement and clicking). It worked the next day after reboot, but after upgrading all packages on Monday the 18'th and rebooting the touchscreen no longer works. I'm guessing this has something to do with the removal of HAL, but the thing that has me curious is that the touchscreen still seems to be registering in both /dev/input/mouse1 and /dev/input/mice. Despite this (and the touchpad, pointer nipple and usb mouse all working) it just doesn't seem to influence the cursor at all.

By the way, by "working" I'm only referring to using the screen in single touch, mouse mode, not n-trig's multitouch (although I'm looking forward to getting that working eventually :)

Thought I should let you guys know as the touchscreens are fairly unusual technology rapidly becoming more popular.

Let me know what other info I can provide to help.

ProblemType: Bug
Architecture: amd64
Date: Wed Jan 20 14:28:46 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
MachineType: Dell Inc. Latitude XT
Package: xorg 1:7.5+1ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-11-generic root=UUID=c55032f1-5275-49d9-a3bc-722ba5f6d910 ro quiet splash nomodeset
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu1
 libgl1-mesa-glx 7.7-0ubuntu8
 libdrm2 2.4.17-0ubuntu1
 xserver-xorg-video-intel 2:2.9.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20091125.0061c4db-0ubuntu2
SourcePackage: xorg
Uname: Linux 2.6.32-11-generic x86_64
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 05/12/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0Y041C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd05/12/2008:svnDellInc.:pnLatitudeXT:pvr:rvnDellInc.:rn0Y041C:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude XT
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.32-11-generic

Shaved Wookie (shavedwookie) wrote :
Bryce Harrington (bryce) on 2010-01-21
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Shaved Wookie (shavedwookie) wrote :

I don't pretend to know anything about this area. I am curious though, why would an input device problem would be assigned to the ati video driver?

I looked through XOrg.0.log and found a whole bunch of references to the wacom module not being found. That led me to noticing that xserver-xorg-input-wacom having not installed properly. It complains of needing xserver-core >= 2:1.6.2. Strangely, the installed version 2:1.7.3.902-1ubuntu9 doesn't seem to register as being sufficient, and so xserver-xorg-input-wacom fails to install, which looks like the root of the problem to me.

I assume that there is some kind of packaging problem blocking the needed dependencies, and that when xserver-xorg-input-wacom / xserver-core are updated that the wacom module will be installable solving this.

...or I could be wildly, brazenly, completely wrong. :-)

Shaved Wookie (shavedwookie) wrote :
Download full text (3.1 KiB)

Gah. After some updates I was able to install xserver-xorg-input-wacom. No change. Probably the most interesting part was this excerpt from Xorg.0.log:

(**) Option "Device" "/dev/input/by-path/pci-0000:00:13.1-usb-0:2:1.0-event-mouse"
(**) stylus: always reports core events
(**) Option "Mode" "Absolute"
(**) Option "Touch" "on"
(**) Option "Button1" "1"
(**) Option "Button2" "3"
(**) Option "Button3" "2"
(II) XINPUT: Adding extended input device "stylus" (type: STYLUS)
(--) stylus: using pressure threshold of 15 for button 1
(--) stylus: Wacom Unknown USB tablet speed=38400 maxX=9600 maxY=7200 maxZ=256 resX=1016 resY=1016 tilt=enabled
(--) stylus: top X=0 top Y=0 bottom X=9600 bottom Y=7200 resol X=1016 resol Y=1016
(**) Option "Device" "/dev/input/by-path/pci-0000:00:13.1-usb-0:2:1.0-event-mouse"
(**) eraser: always reports core events
(**) Option "Mode" "Absolute"
(**) Option "Button1" "2"
(**) Option "Button9" "0"
(II) XINPUT: Adding extended input device "eraser" (type: ERASER)
(--) eraser: top X=0 top Y=0 bottom X=9600 bottom Y=7200 resol X=1016 resol Y=1016
(**) Option "Device" "/dev/input/by-path/pci-0000:00:13.1-usb-0:2:1.0-event-mouse"
(**) touch: always reports core events
(**) Option "Mode" "Absolute"
(**) Option "TopX" "0"
(**) Option "TopY" "0"
(**) Option "BottomX" "9600"
(**) Option "BottomY" "7200"
(**) Option "Touch" "on"
(II) XINPUT: Adding extended input device "touch" (type: TOUCH)
(--) touch: top X=0 top Y=0 bottom X=9600 bottom Y=7200 resol X=1016 resol Y=1016

(II) config/udev: Adding input device "HID 1b96:0001" (/dev/input/event7)
(**) Option "Device" "/dev/input/event7"
(II) "HID 1b96:0001": type not specified, assuming 'stylus'.
(II) "HID 1b96:0001": other types will be automatically added.
(WW) "HID 1b96:0001": device file already in use by stylus. Ignoring.
(II) UnloadModule: "wacom"
(EE) PreInit returned NULL for ""HID 1b96:0001""
(II) config/udev: Adding input device "HID 1b96:0001" (/dev/input/event8)
(**) Option "Device" "/dev/input/event8"
(II) "HID 1b96:0001": type not specified, assuming 'stylus'.
(II) "HID 1b96:0001": other types will be automatically added.
(**) "HID 1b96:0001": always reports core events
(II) "HID 1b96:0001": hotplugging dependent devices.
(**) Option "Device" "/dev/input/event8"
(**) "HID 1b96:0001" eraser: always reports core events
(II) XINPUT: Adding extended input device ""HID 1b96:0001" eraser" (type: ERASER)
(--) "HID 1b96:0001" eraser: using pressure threshold of 15 for button 1
(--) "HID 1b96:0001" eraser: Wacom Unknown USB tablet speed=38400 maxX=9600 maxY=7200 maxZ=256 resX=1016 resY=1016 tilt=enabled
(--) "HID 1b96:0001" eraser: top X=0 top Y=0 bottom X=9600 bottom Y=7200 resol X=1016 resol Y=1016
(**) Option "Device" "/dev/input/event8"
(**) "HID 1b96:0001" touch: always reports core events
(II) XINPUT: Adding extended input device ""HID 1b96:0001" touch" (type: TOUCH)
(--) "HID 1b96:0001" touch: top X=0 top Y=0 bottom X=1024 bottom Y=1024 resol X=1016 resol Y=1016
(II) "HID 1b96:0001": hotplugging completed.
(II) XINPUT: Adding extended input device ""HID 1b96:0001"" (type: STYLUS)
(--) "HID 1b96:0001": top X=0 top Y=0 bottom X=9600 bottom Y=7200 resol X=1016 resol Y=1...

Read more...

Bryce Harrington (bryce) wrote :

[Sorry, the automatic refiler guessed -ati but it guessed wrong]

Try recent updates. Between alpha-2 and now we've reworked wacom. Actually now it's provided by a different package xf86-input-wacom, which uses udev instead of hal.

affects: xserver-xorg-video-ati (Ubuntu) → xf86-input-wacom (Ubuntu)
Changed in xf86-input-wacom (Ubuntu):
status: New → Incomplete
Shaved Wookie (shavedwookie) wrote :

Thanks Bryce,

I felt pretty presumptuous second guessing "you" when your little finger knows more about X than I'll likely learn in the next decade! Glad to hear I wasn't entirely insane (at least this time).

xf86-input-wacom doesn't seem to have made it down the line yet, in fact after updating and searching for wacom, it still only sees the xserver-xorg-input-wacom package. I'm guessing it's just still on its way. I'm in the process of doing a 50 package update at the moment though, so I'll let you know how that goes.

Thanks again for your help!

Shaved Wookie (shavedwookie) wrote :

No improvement so far. I can give logs if needed.

Quick question:

How do I actually try xf86-input-wacom? It's listed at packages.ubuntu.com as being in main, but Kpackagekit / Synaptic / Apt don't see any package by that name after updating. I found it on launchpad, but https://launchpad.net/ubuntu/+source/xf86-input-wacom looks like it is only used to build xserver-xorg-input-wacom, which I already had installed.

So does this mean I already have xf86-input-wacom? Is there something else I need to do to try it? Does this new system need a .fdi file?

Kiwinote (kiwinote) wrote :

This regression is not fixed by xf86-input-wacom.

Changed in xf86-input-wacom (Ubuntu):
status: Incomplete → Confirmed
tags: added: tx2
Bryce Harrington (bryce) on 2010-03-02
tags: added: regression-potential
Bryce Harrington (bryce) wrote :

> I felt pretty presumptuous second guessing "you" when your little finger knows more about X than I'll likely learn in the next decade! Glad to hear I wasn't entirely insane (at least this time).

Triaging bugs is time consuming and tedious so I created scripts to do it for me. However they're fairly imperfect.

> xf86-input-wacom doesn't seem to have made it down the line yet, in fact after updating and searching for wacom, it still only sees the xserver-xorg-input-wacom package. I'm guessing it's just still on its way. I'm in the process of doing a 50 package update at the moment though, so I'll let you know how that goes.

xf86-input-wacom is the source package name. The binary name (which shows up in the installer) is xserver-xorg-input-wacom (same as the old driver).

Bryce Harrington (bryce) on 2010-03-03
tags: added: kubuntu
Timo Aaltonen (tjaalton) wrote :

Please attach the _full_ Xorg.0.log after you've plugged it in, and also the resulting file of 'udevadm info --export-db > udevdb.txt'.

Changed in xf86-input-wacom (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xf86-input-wacom (Ubuntu):
status: Incomplete → Invalid
Shaved Wookie (shavedwookie) wrote :

Ok, thanks for the kick in the pants to get this posted. Anyway, I digress...

I did, in fact, get the touchscreen and stylus working, but only by following the instructions for Lucid here:
http://ubuntuforums.org/showthread.php?t=1252492

This compiles a new hid-ntrig.ko module as well as changing 10-wacom.fdi As far as I can see multitouch isn't working, but is being worked on by Ayuthia / Favux / Rayfir. My hid-ntrig.ko is the one posted by Ubuntiac (see the link in post#1).

My current (working) xorg.0.log is attached. Let me know if you'd like me to remove these changes and post that xorg.0.log as well.

Shaved Wookie (shavedwookie) wrote :

I'd also like to add that stylus pressure only works in GTK apps and not in KDE based ones. My research seems to sugest though that this is a bug in QT only looking for tablets with particular names that is patched around in OpenSuse and has a patch accepted to QT 4.6.3 by Lukas Tvrdy.

Shaved Wookie (shavedwookie) wrote :

Also, I actually *am* using the latest dev version of Kubuntu, if you count updating daily . If you'd like me to download Beta 1 / the daily iso and test that just let me know and I will.

Changed in xf86-input-wacom (Ubuntu):
status: Invalid → Confirmed
Timo Aaltonen (tjaalton) wrote :

aiui both the kernel and the wacom x driver have pulled the n-trig changes, so things should work better?

Changed in xf86-input-wacom (Ubuntu):
status: Confirmed → Incomplete
Shaved Wookie (shavedwookie) wrote :

Having updated and restarted today, it seems to give stylus tracking and clicks, but no pressure (in GTK and QT apps). Touch moves the cursor, but doesn't seem to register clicks. When I use a self compiled hid-ntrig.ko for myself, I get pressure in GTK apps and touch clicks, but currently I only have what's delivered by the packages.

Not sure if there's any specific xorg.conf(.d) / udev thats needed for this setup.

Is there any info I can provide that would help?

Shaved Wookie (shavedwookie) wrote :

Actually, I just realised - I *do* get pressure for the stylus in GTK apps. I just forgot to configure extended input devices in Gimp. :-/

Still no pressure in QT apps...

Timo Aaltonen (tjaalton) wrote :

ok, so this bug seems to be solved then.

you need to file another bug against qt regarding the support there.

Changed in xf86-input-wacom (Ubuntu):
status: Incomplete → Fix Released
Kiwinote (kiwinote) wrote :

not quite. As Shaved Wookie mentioned above, touch moves the cursor (which it didn't before the kernel update), but doesn't register clicks.

Changed in xf86-input-wacom (Ubuntu):
status: Fix Released → Confirmed
C de-Avillez (hggdh2) on 2010-08-24
tags: removed: regression-potential
Kiwinote (kiwinote) wrote :

The touchscreen works now with the new utouch efforts.

Changed in xf86-input-wacom (Ubuntu):
status: Confirmed → Fix Released
Shaved Wookie (shavedwookie) wrote :

Confirmed.

Touch has actually been working for a while on my TX2, so I think this bug can be closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers