Ubuntu

X11 crashes after plugging in wacom tablet

Reported by Timo Dickscheid on 2009-04-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xf86-input-wacom (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-wacom

I did a normal system update of ubuntu jaunty on Thursday Apr 24 2009, which required a restart. After the next restart, with my Wacom Bamboo table plugged in, X11 won't start. Killing gdm, unpluggin the tablet, and restarting gdm worked fine.

I use some HAL custom configurations as proposed on https://help.ubuntu.com/community/Wacom.fdi. These configurations went previously fine (both on latest 8.10 as on the jaunty system before yesterday), but I attach the files. In xorg.conf, I have no wacom settings at all.

When pluggin in the Tablet again in the running X11 session, it will crash as well. X11 logfile says that the wacom driver was loaded, but "top/bottom area overlaps with another devices". The last action in X11 is loading the Logitech USB-PS/2 Optical Mouse driver. Last lines of Xorg.0.log (the full file is attached):

------
II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
(**) Logitech USB-PS/2 Optical Mouse: (accel) filter chain progression: 2.00
(**) Logitech USB-PS/2 Optical Mouse: (accel) filter stage 0: 20.00 ms
(**) Logitech USB-PS/2 Optical Mouse: (accel) set acceleration profile 0

Backtrace:
0: /usr/X11R6/bin/X(xorg_backtrace+0x26) [0x4f1b66]
1: /usr/X11R6/bin/X(xf86SigHandler+0x41) [0x485a61]
2: /lib/libc.so.6 [0x7fd09d0db040]
3: /usr/lib/xorg/modules/input//wacom_drv.so [0x7fd098afb035]
4: /usr/X11R6/bin/X(ActivateDevice+0x3e) [0x447a8e]
5: /usr/X11R6/bin/X(OpenInputDevice+0x10) [0x4968e0]
6: /usr/X11R6/bin/X(ProcXOpenDevice+0xa3) [0x545823]
7: /usr/X11R6/bin/X(Dispatch+0x364) [0x44e304]
8: /usr/X11R6/bin/X(main+0x3bd) [0x433d8d]
9: /lib/libc.so.6(__libc_start_main+0xe6) [0x7fd09d0c65a6]
10: /usr/X11R6/bin/X [0x433219]
Saw signal 11. Server aborting.
(II) UnloadModule: "wacom"
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
(II) Logitech USB-PS/2 Optical Mouse: Close
(II) UnloadModule: "evdev"

------

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic x86_64

Timo Dickscheid (dicksche) wrote :
Timo Dickscheid (dicksche) wrote :
Timo Dickscheid (dicksche) wrote :
Timo Dickscheid (dicksche) wrote :
ValiSystem (vali-system) wrote :

Exact same problem here, i tried to remove all my custom config, but X crashes each time I plug the tablet (bamboo1), with the same backtrace you attached.

Did you manage to make it work after removing your custom configs ?

ValiSystem (vali-system) wrote :

I found that i left a file '/etc/hal/fdi/policy/10-wacom.fdi' that i needed to make the tablet work on intrepid, everything is working fine now, even with a custom config to enable TCPButton.

Timo Dickscheid (dicksche) wrote :

Incredible: You're fully right. Removing my /etc/hal/fdi/policy/custom_wacom.fdi, that I created for use under 8.10, solved the problem for now. Interestingly the same configuration file worked previously fine under jaunty; only after the update on Apr 24 2009 the problem appeared. Thanks.

I'll now try to get a custom configuration running without crashes.

Changed in wacom-tools (Ubuntu):
status: New → In Progress
Timo Dickscheid (dicksche) wrote :

I now also have a working custom configuration, attached are the old .fdi (which induced the crash) and the new one which works. Note that the settings are not identical, however.

The tablet support is now actually much better now then in 8.10: Pen, Scrollarea and Erase work like a charm. Great!

Timo Dickscheid (dicksche) wrote :
Timo Dickscheid (dicksche) wrote :

So the original problem is solved now, but it is still unclear why X11 crashes with the above old configuration file. I leave this bug in progress for now.

tommy (yobbobandana) wrote :

I think the problem is with setting the wacom driver in the custom .fdi file.

Here's one which seems to be working perfectly. You can now set any X options for stylus, eraser etc. :).

It should be tablet inspecific as well (matches any device already using the wacom X driver).

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
pallart (pallart) wrote :
Download full text (3.8 KiB)

I'm experiencing exactly the same symptoms as in the first post. Not sure that wacom-tool is involved, because the bug persists after I've uninstalled it.

X11 crash a few seconds after I've plugged the device and while I move the cursor, as well with the touchpas as with the pen. Then GDM try to restart, but seems to crash and restart in loop, until I unplug the tablet.

My configuration:
Bamboo Fun A5.
Jaunty

Here's what I found in /var/log/message:

Sep 7 17:14:11 portable-jackphil kernel: [ 96.255264] Xorg[2832]: segfault at 10 ip 080d8832 sp bfc078f0 error 4 in Xorg[8048000+19d00
0]
Sep 7 17:14:14 portable-jackphil kernel: [ 99.090634] Xorg[3677]: segfault at 2fd7d40b ip b7cda17b sp bfbe270c error 4
Sep 7 17:14:16 portable-jackphil kernel: [ 101.733821] Xorg[3702]: segfault at 2fd55ee5 ip b7cc817b sp bfed31ec error 6
Sep 7 17:14:52 portable-jackphil kernel: [ 136.988407] Xorg[3731]: segfault at 28 ip 080d8832 sp bfb6d690 error 4 in Xorg[8048000+19d00
0]
Sep 7 17:14:54 portable-jackphil kernel: [ 139.742065] Xorg[4265]: segfault at 961ccec5 ip b7d7d178 sp bfb87eac error 6
Sep 7 17:14:57 portable-jackphil kernel: [ 142.576290] Xorg[4292]: segfault at c68dff36 ip b7c52178 sp bf85a3bc error 7
Sep 7 17:35:06 portable-jackphil kernel: [ 657.794564] Xorg[2808]: segfault at 40 ip 080d8832 sp bfc6a5e0 error 4 in Xorg[8048000+19d00
0]
Sep 7 17:35:09 portable-jackphil kernel: [ 660.602027] Xorg[4066]: segfault at 0 ip b7caf17a sp bfdb98dc error 6
Sep 7 17:35:12 portable-jackphil kernel: [ 663.158383] Xorg[4092]: segfault at c1e4a7c8 ip b7c48182 sp bfc52f6c error 5
Sep 7 17:36:52 portable-jackphil kernel: [ 763.489646] Xorg[4120]: segfault at 10 ip 080d8832 sp bf90fc30 error 4 in Xorg[8048000+19d00
0]
Sep 7 17:36:55 portable-jackphil kernel: [ 766.277740] Xorg[4693]: segfault at 0 ip b7bfa17a sp bfd0502c error 6
Sep 7 17:36:57 portable-jackphil kernel: [ 768.843225] Xorg[4719]: segfault at c02aa7c9 ip b7c16182 sp bfc2073c error 7
Sep 7 17:37:00 portable-jackphil kernel: [ 771.473711] Xorg[4749]: segfault at 2fd9a065 ip b7d0117b sp bfc0bf2c error 6
Sep 7 18:40:05 portable-jackphil kernel: [ 107.395817] Xorg[2816]: segfault at 100001a ip 080d8832 sp bf9ccff0 error 4 in Xorg[8048000+
19d000]
Sep 7 18:40:08 portable-jackphil kernel: [ 110.530614] Xorg[3978]: segfault at 2fd74af5 ip b7cf017b sp bfaf8e1c error 6
Sep 7 18:40:11 portable-jackphil kernel: [ 113.409203] Xorg[4005]: segfault at c7b5005d ip b7c8e178 sp bfb966bc error 7
Sep 7 18:40:14 portable-jackphil kernel: [ 116.247976] Xorg[4088]: segfault at 2fd10ce5 ip b7c8a17b sp bfe951bc error 6
Sep 7 18:40:21 portable-jackphil kernel: [ 123.332212] Xorg[4114]: segfault at 2fd04485 ip b7c7b17b sp bf9854ac error 6
Sep 7 18:40:34 portable-jackphil kernel: [ 136.046206] Xorg[4204]: segfault at 2fe16dd5 ip b7d7d17b sp bff85aac error 6

--------------------------------------------------------------------
 lshal | grep -i wacom
  info.vendor = 'Wacom Co., Ltd' (string)
  usb_device.vendor = 'Wacom Co., Ltd' (string)
  info.linux.driver = 'wacom' (string)
  usb.vendor = 'Wacom Co., Ltd' (string)
  info.callouts.add = {'hal-setup-wacom'} (string list)
  info.product...

Read more...

John Rocheleau (johnrocheleau) wrote :

My Issue in KARMIC

The solution above to remove the /etc/hal/fdi/policy/custom_wacom.fdi file solved my probelm as well, which is related but different.

I upgraded to Karmic from Jaunty and even though my swap file size was plenty large enough (reference to the release notes on Karmic about the Xserver crash when Karmic inadvertently reduces the swap file size), my system WOULD NOT BOOT with the Wacom Intuous 3 tablet plugged in. I un-installed the Ubuntu Wacom tools and driver set and unplugged the tablet. Then I could boot up again (actually, it would boot up but I would have to try 3 or 4 times before it finally would boot)

On seeing this bug report I found the above mentioned file. It must have been created when I configured the tablet in one of the graphics programs. After removing it I can boot up again with the tablet plugged in and all works fine except the eraser.

I haven't tried the suggested config files pointed to in comment #11 above. When I examine them, they are just one line of numbers, whereas my old file was quite lengthy with many directives set. Can you use that file as it is and just insert that line of numbers to replace the entire contents of the old custom__wacom.fdi or do you rename the file to just custom.fdi? The comment seems to say that using the custom_wacom.fdi name is a problem.

John Rocheleau (johnrocheleau) wrote :

NOTE: TO EDIT WORDING ERROR IN #13 ABOVE:

In the bracketed text at end of second paragraph, I meant that I had to reboot 3 or 4 times to boot up when the tablet was plugged in and drivers were installed. I DID NOT mean that after unplugging and un-installing drivers that it took several tries to boot. I worded that terribly; sorry. No edit functions on these comments.

John Rocheleau (johnrocheleau) wrote :

UPDATE: Karmic not booting with the wacom intuous 3 tablet plugged in.

Being able to boot up was short-lived. I've confirmed now that with the wacom Intuous 3 tablet plugged in, Karmic 9.10 will not boot up. I have to unplug the tablet to boot the system up. The tablet works fine when the system is running and I plug it in. I just can't boot with it plugged in. As I mentioned above I removed the Custom_wacom.fdi file. This improved the situation (it seemed), as I could sometimes boot up first try, whereas before, it was always three or four tries before the computer would boot.

Perhaps I should create a ticket for this separately? The tablet was working fine in Jaunty 9.04

Timo Aaltonen (tjaalton) wrote :

jaunty or karmic won't see any wacom updates anymore, and I believe this is fixed in lucid. If you can still reproduce it, feel free to reopen or file a new bug against xf86-input-wacom.

affects: wacom-tools (Ubuntu) → xf86-input-wacom (Ubuntu)
Changed in xf86-input-wacom (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers