Wacom Cintiq not working in Ubuntu 17.10

Bug #1755239 reported by eezacque on 2018-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-input-wacom (Ubuntu)
Undecided
Unassigned

Bug Description

The screen of the tablet works, the stylus cannot be found.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xserver-xorg-input-wacom 1:0.34.0-0ubuntu2
ProcVersionSignature: Ubuntu 4.13.0-36.40-generic 4.13.13
Uname: Linux 4.13.0-36-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 12 17:36:24 2018
DistUpgraded: 2018-03-08 12:19:15,834 DEBUG icon theme changed, re-reading
DistroCodename: artful
DistroVariant: ubuntu
InstallationDate: Installed on 2014-10-24 (1234 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: ASUS All Series
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-36-generic root=/dev/mapper/ubuntu--vg-root ro acpi_enforce_resources=lax quiet splash vt.handoff=7
SourcePackage: xf86-input-wacom
UpgradeStatus: Upgraded to artful on 2018-03-08 (4 days ago)
dmi.bios.date: 06/24/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2501
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z97-PRO(Wi-Fi ac)
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2501:bd06/24/2015:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ97-PRO(Wi-Fiac):rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: ASUS MB
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz 1:0.9.13.1+17.10.20170901-0ubuntu1
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.8-0ubuntu0~17.10.1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.8-0ubuntu0~17.10.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Wed Mar 7 19:06:07 2018
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.4-0ubuntu0.7

eezacque (eezacque) wrote :
eezacque (eezacque) wrote :

Just discovered that if I switch on my Wacom Cintiq while the settings panel is on screen, the panel shows the tablet for a split second, and immediately returns to 'No tablet detected'

eezacque (eezacque) wrote :

After reboot the tablet shows up in my Wacom settings panel.
However, the stylus can only control the cursor on the main screen, while calibration makes no sense.

eezacque (eezacque) wrote :

This is fixed as per Ubuntu 18.04

Timo Aaltonen (tjaalton) on 2018-05-30
Changed in xf86-input-wacom (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers