Intuos4 detected but non-functional

Bug #1259048 reported by Andrew Somerville
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xf86-input-wacom (Ubuntu)
Undecided
Unassigned

Bug Description

Product: Intuos4 (ptk-640)

Symptoms:

 * Xorg.0.log shows driver is installed [1]
 * `xwacomset list` shows all parts: [2]
 * One error seen: [ 9548.550] (EE) Wacom Intuos4 6x9 stylus: Invalid type 'touch' for this device.
 * If I attempt to use the pen as I plug it in, I see about 3 seconds of pen moving the pointer before it stops working
 * Happens in both 13.04 and 13.10
 * Had been working int 12.10

[1]:

[ 9548.509] (II) config/udev: Adding input device Wacom Intuos4 6x9 (/dev/input/mouse3)
[ 9548.509] (II) No input driver specified, ignoring this device.
[ 9548.509] (II) This device may have been added with another device file.
[ 9548.528] (II) config/udev: Adding input device Wacom Intuos4 6x9 (/dev/input/event15)
[ 9548.529] (**) Wacom Intuos4 6x9: Applying InputClass "evdev tablet catchall"
[ 9548.529] (**) Wacom Intuos4 6x9: Applying InputClass "Wacom class"
[ 9548.529] (II) LoadModule: "wacom"
[ 9548.529] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 9548.549] (II) Module wacom: vendor="X.Org Foundation"
[ 9548.549] compiled for 1.14.2.901, module version = 0.20.0
[ 9548.549] Module class: X.Org XInput Driver
[ 9548.549] ABI class: X.Org XInput driver, version 19.1
[ 9548.549] (II) Using input driver 'wacom' for 'Wacom Intuos4 6x9'
[ 9548.549] (**) Wacom Intuos4 6x9: always reports core events
[ 9548.549] (**) Option "Device" "/dev/input/event15"
[ 9548.549] (II) Wacom Intuos4 6x9: type not specified, assuming 'stylus'.
[ 9548.549] (II) Wacom Intuos4 6x9: other types will be automatically added.
[ 9548.549] (--) Wacom Intuos4 6x9 stylus: using pressure threshold of 27 for button 1
[ 9548.549] (--) Wacom Intuos4 6x9 stylus: Wacom USB Intuos4 tablet maxX=44704 maxY=27940 maxZ=2047 resX=200000 resY=200000 tilt=enabled
[ 9548.549] (II) Wacom Intuos4 6x9 stylus: hotplugging dependent devices.
[ 9548.550] (EE) Wacom Intuos4 6x9 stylus: Invalid type 'touch' for this device.
[ 9548.550] (II) Wacom Intuos4 6x9 stylus: hotplugging completed.
[ 9548.564] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.1/usb1/1-1/1-1.3/1-1.3:1.0/input/input18/event15"
[ 9548.564] (II) XINPUT: Adding extended input device "Wacom Intuos4 6x9 stylus" (type: STYLUS, id 18)
[ 9548.564] (**) Wacom Intuos4 6x9 stylus: (accel) keeping acceleration scheme 1
[ 9548.565] (**) Wacom Intuos4 6x9 stylus: (accel) acceleration profile 0
[ 9548.565] (**) Wacom Intuos4 6x9 stylus: (accel) acceleration factor: 2.000
[ 9548.565] (**) Wacom Intuos4 6x9 stylus: (accel) acceleration threshold: 4
[ 9548.565] (**) Wacom Intuos4 6x9 eraser: Applying InputClass "evdev tablet catchall"
[ 9548.565] (**) Wacom Intuos4 6x9 eraser: Applying InputClass "Wacom class"
[ 9548.565] (II) Using input driver 'wacom' for 'Wacom Intuos4 6x9 eraser'
[ 9548.565] (**) Wacom Intuos4 6x9 eraser: always reports core events
[ 9548.565] (**) Option "Device" "/dev/input/event15"
[ 9548.565] (**) Option "Type" "eraser"
[ 9548.565] (--) Wacom Intuos4 6x9 eraser: Wacom USB Intuos4 tablet maxX=44704 maxY=27940 maxZ=2047 resX=200000 resY=200000 tilt=enabled
[ 9548.572] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.1/usb1/1-1/1-1.3/1-1.3:1.0/input/input18/event15"
[ 9548.572] (II) XINPUT: Adding extended input device "Wacom Intuos4 6x9 eraser" (type: ERASER, id 19)
[ 9548.573] (**) Wacom Intuos4 6x9 eraser: (accel) keeping acceleration scheme 1
[ 9548.573] (**) Wacom Intuos4 6x9 eraser: (accel) acceleration profile 0
[ 9548.573] (**) Wacom Intuos4 6x9 eraser: (accel) acceleration factor: 2.000
[ 9548.573] (**) Wacom Intuos4 6x9 eraser: (accel) acceleration threshold: 4
[ 9548.573] (**) Wacom Intuos4 6x9 cursor: Applying InputClass "evdev tablet catchall"
[ 9548.573] (**) Wacom Intuos4 6x9 cursor: Applying InputClass "Wacom class"
[ 9548.573] (II) Using input driver 'wacom' for 'Wacom Intuos4 6x9 cursor'
[ 9548.573] (**) Wacom Intuos4 6x9 cursor: always reports core events
[ 9548.573] (**) Option "Device" "/dev/input/event15"
[ 9548.573] (**) Option "Type" "cursor"
[ 9548.573] (--) Wacom Intuos4 6x9 cursor: Wacom USB Intuos4 tablet maxX=44704 maxY=27940 maxZ=2047 resX=200000 resY=200000 tilt=enabled
[ 9548.580] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.1/usb1/1-1/1-1.3/1-1.3:1.0/input/input18/event15"
[ 9548.580] (II) XINPUT: Adding extended input device "Wacom Intuos4 6x9 cursor" (type: CURSOR, id 20)
[ 9548.581] (**) Wacom Intuos4 6x9 cursor: (accel) keeping acceleration scheme 1
[ 9548.581] (**) Wacom Intuos4 6x9 cursor: (accel) acceleration profile 0
[ 9548.581] (**) Wacom Intuos4 6x9 cursor: (accel) acceleration factor: 2.000
[ 9548.581] (**) Wacom Intuos4 6x9 cursor: (accel) acceleration threshold: 4
[ 9548.581] (**) Wacom Intuos4 6x9 pad: Applying InputClass "evdev tablet catchall"
[ 9548.581] (**) Wacom Intuos4 6x9 pad: Applying InputClass "Wacom class"
[ 9548.581] (II) Using input driver 'wacom' for 'Wacom Intuos4 6x9 pad'
[ 9548.581] (**) Wacom Intuos4 6x9 pad: always reports core events
[ 9548.581] (**) Option "Device" "/dev/input/event15"
[ 9548.581] (**) Option "Type" "pad"
[ 9548.582] (--) Wacom Intuos4 6x9 pad: Wacom USB Intuos4 tablet maxX=44704 maxY=27940 maxZ=2047 resX=200000 resY=200000 tilt=enabled
[ 9548.588] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.1/usb1/1-1/1-1.3/1-1.3:1.0/input/input18/event15"
[ 9548.588] (II) XINPUT: Adding extended input device "Wacom Intuos4 6x9 pad" (type: PAD, id 21)
[ 9548.589] (**) Wacom Intuos4 6x9 pad: (accel) keeping acceleration scheme 1
[ 9548.589] (**) Wacom Intuos4 6x9 pad: (accel) acceleration profile 0
[ 9548.589] (**) Wacom Intuos4 6x9 pad: (accel) acceleration factor: 2.000
[ 9548.589] (**) Wacom Intuos4 6x9 pad: (accel) acceleration threshold: 4

[2]:
# xsetwacom list
Wacom Intuos4 6x9 stylus id: 18 type: STYLUS
Wacom Intuos4 6x9 eraser id: 19 type: ERASER
Wacom Intuos4 6x9 cursor id: 20 type: CURSOR
Wacom Intuos4 6x9 pad id: 21 type: PAD

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-input-wacom 1:0.20.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Mon Dec 9 00:53:01 2013
DistUpgraded: 2013-12-08 13:59:34,206 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
InstallationDate: Installed on 2012-09-08 (456 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64+mac (20120425.1)
MachineType: Apple Inc. MacBookPro5,3
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-14-generic root=UUID=3567569c-e865-460c-8c33-9cd08e418b53 ro quiet splash
SourcePackage: xf86-input-wacom
UpgradeStatus: Upgraded to saucy on 2013-12-08 (0 days ago)
dmi.bios.date: 06/15/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP53.88Z.00AC.B03.0906151647
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22587C8
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22587C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP53.88Z.00AC.B03.0906151647:bd06/15/09:svnAppleInc.:pnMacBookPro5,3:pvr1.0:rvnAppleInc.:rnMac-F22587C8:rvr:cvnAppleInc.:ct10:cvrMac-F22587C8:
dmi.product.name: MacBookPro5,3
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.49+git20131202.c3d96897-0ubuntu0sarvatt~raring
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Sun Dec 8 14:26:48 2013
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.3-3ubuntu2

Revision history for this message
Andrew Somerville (andy-somerville) wrote :
Revision history for this message
Andrew Somerville (andy-somerville) wrote :

Tried with xserver-xorg-input-wacom 1:0.20.0-0ubuntu1
same problem.

Also noted that if I `sudo rmmod wacom; sleep 1; sudo modprobe wacom` I again get momentary pointer movement when using the pen.

Revision history for this message
Andrew Somerville (andy-somerville) wrote :

`fuser /dev/input/event15` showed a process called mouseemu was holding on to the device preventing it from working propperly.

Killing that process allows the pad to work correctly it seems though I'm unsure what caused mouseemu to run in the first place.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xf86-input-wacom (Ubuntu):
status: New → Confirmed
Revision history for this message
PeterKnaggs (peter-knaggs) wrote :

This bug also occurs for me on Ubuntu 14.04, on a MacBook Pro
( http://www.penlug.org/foswiki/bin/view/Main/HardwareInfoAppleMacBookProA1297 )
and since the touchpad is managed using Synaptics (synclient) there appears to be no need
for the "mouseemu" program to be running or even installed on this machine.

I de-installed mouseemu as follows, and rebooted the machine, and now the Wacom Intuos4 works normally again:

sudo apt-get remove mouseemu

To avoid needing to reboot, I also tried the steps mentioned above, and that also got the Intuos4 working properly.

sudo killall mouseemu
sudo apt-get remove mouseemu
sudo rmmod wacom; sleep 1; sudo modprobe wacom

To get the pen pressure to be recognized by inkscape, the following workaround is still needed:

export LIBOVERLAY_SCROLLBAR=0
inkscape

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

not a driver bug, closing

Changed in xf86-input-wacom (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.