Multitouch support not available for Synaptics touchpads v7.2

Bug #308191 reported by Davide P. on 2008-12-15
786
This bug affects 171 people
Affects Status Importance Assigned to Milestone
HP tm2 packages
Fix Released
Medium
Linux
Fix Released
Medium
Open Input Framework
High
Henrik Rydberg
Baltix
Medium
Mantas Kriaučiūnas
xf86-input-multitouch (Ubuntu)
Wishlist
Daniel Joo Sung Yi
Declined for Jaunty by Steve Langasek
Nominated for Karmic by Martin Maier
Declined for Lucid by Bryce Harrington
Nominated for Maverick by sebaw
Nominated for Precise by Ahmed Shams

Bug Description

I've tried to enable the multi-touch feature on my Samsung NC10 touchpad enabled (Synaptics) but I did't find a way for correctly do it working.
I've started from this how-to http://www.ibm.com/developerworks/opensource/library/os-touchpad/?ca=dgr-lnxw02os-touchpad&S_TACT=105AGX59&S_CMP=GRsitel

I've tried to run this:
synclient -m 100

but it seems that recognize only a single finger.

This touchpad has multi-touch feature since i correctly make it running under windows xp, but I like to be able to use it under Linux too.

I'm running last updated Intrepid Ubuntu.

Also affecting last updated Karmic (k)ubuntu.

[Possible Fix]
Install this ppa - ppa:utouch-team/utouch

Davide P. (scaltro) wrote :
FriedChicken (domlyons) on 2008-12-31
Changed in xserver-xorg-input-synaptics:
status: New → Confirmed
Paweł (paff) wrote :

I also ask you to solve this problem.

I'm using Jaunty (2.6.28-10-generic) and the synaptics driver detects only a single finger. Tried with:
# synclient -m 100

crashsystems (crashsystems) wrote :

Per charlie-tca's recommendation on #ubuntu+1, I'm commenting on this bug early and often. After following the instructions on https://wiki.ubuntu.com/DebuggingTouchpadDetection I have several files to share with everyone. The ones with only a small bit in them I'll include in-line in this comment. The others will be attached to this and a subsequent comment.

#laptop:
bios-version:A02
system-manufacturer:Dell Inc.
system-product-name:Inspiron 1420
system-version:Not Specified

#uname-a:
Linux crashsystems 2.6.28-11-generic #35-Ubuntu SMP Wed Mar 18 21:55:34 UTC 2009 x86_64 GNU/Linux

#version_signature
Ubuntu 2.6.28-11.35-generic

crashsystems (crashsystems) wrote :

...and the other file

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xserver-xorg-input-synaptics:
importance: Undecided → Medium
status: Confirmed → Triaged
Viale Fabrice (viale-fabrice) wrote :

I have found this tweak. However I have not personally tested it.
http://ubuntu-snippets.blogspot.com/2009/03/multi-touch-for-anyall-synaptics.html

spi (spi-gmxpro) wrote :

This tweak is only a workaround as it uses the option EmulateTwoFingerMinZ - as soon as you touch the touchpad even with only one finger but exceed the defined value this is detected as a two finger touch.

If the user touches the touchpad in two locations, then raises the first finger that touched the pad, the mouse jumps to the location of the second finger as if a full move occurred. This happens on Synaptics touchpads.

To reproduce:
Touch the pad in the upper right and hold
Touch with another finger lower left and hold
Release the finger in the upper right
Mouse jumps to lower left edge of the screen, sometimes selecting text along the way

I have noticed a few symptoms related to the problem. They can be tracked down in ComputeDeltas() in synaptics.c:

1) Sometimes deltas are so big that they couldn't possibly happen in so little time (e.g. in less than 20 milliseconds).

2) A comparison between the timestamp in priv->move_hist and hw->millis shows that something went wrong and that an event was skipped, hence the deltas are wrong (or at least bigger than they should be).

3) Usually when 2) takes place, the next few deltas happen to be inaccurate too.

I have written a patch which is more of a workaround for the touchpads that I own and I believe that, at least 2) could be fixed in a better way. Consider the patch as an additional description.

Let me know if there is something I can do to help or where you would like to see this problem fixed.

I might be worth checking the finger value too, i.e. if the fingers down go
from 2 to 1, then a jump to another position should possibly be ignored.

Please attach the patch to this bugreport, I'd be interested to see it.

Created an attachment (id=25641)
Jumpy cursor patch

Sorry, something went wrong when I tried to attach the patch.

The finger value was the 1st thing I checked but it didn't seem to solve the problems that I was experiencing.

I just tried this patch and it makes the touchpad quite unpredictable. Moving fast towards a point on the screen (a common thing if you want to close a window) makes the touchpad quite edgy with some movements swallowed, etc.

We can't merge this patch as it is. Can you take the finger value into account in the calculations? i.e. if the previous finger value was 2 and is now 1 and there was a huge movement then smoothen it out?

(In reply to comment #4)
> I just tried this patch and it makes the touchpad quite unpredictable. Moving
> fast towards a point on the screen (a common thing if you want to close a
> window) makes the touchpad quite edgy with some movements swallowed, etc.
>
> We can't merge this patch as it is. Can you take the finger value into account
> in the calculations? i.e. if the previous finger value was 2 and is now 1 and
> there was a huge movement then smoothen it out?
>

Sure, I can do that again but it wouldn't work if an event was skipped and we would end up smoothening out the wrong movements.

I'll see what I can do.

As this is currently only happening on the touchpads of the newer Minis, would it be acceptable to just detect the model of such touchpads and apply this as a quirk for them?

I have a T61 and it's happening for me too, so this doesn't just affect the Dell minis.

(In reply to comment #7)
> I have a T61 and it's happening for me too, so this doesn't just affect the
> Dell minis.
>

Right, but the reason why the cursor jumps and the solution to the problem may vary according to models.

For example, let's consider the solution which involves smoothening movements when the previous finger value was 2 and is then 1:

1) The Synaptics touchpad in the Dell Mini 10V doesn't detect multiple fingers and two-fingers emulation doesn't work well. If I want that touchpad to detect 2 fingers (through emulation) I can set the relevant properties manually but then my thumb (or using my index with a slightly bigger pressure) is treated as if it were two fingers. And I can't use this solution because there's no clear way to distinguish between 2 fingers and 1 finger.

2) The Synaptics touchpad in my Fujitsu-Siemens detects multiple fingers (natively) and this solution reduces the issue.

3) The Elantech in my Eee 901 Go doesn't report finger pressure but emulation works well and so on.

Furthermore different values assigned to the "threshold" variable (in my patch) can improve or worsen the situation according to the model.

For this reason I was wondering if quirks could be added for different touchpads (when no general solution can be found).

What do you think?

(In reply to comment #8)
> (In reply to comment #7)
> > I have a T61 and it's happening for me too, so this doesn't just affect the
> > Dell minis.
> >
>
[...]
> For this reason I was wondering if quirks could be added for different
> touchpads (when no general solution can be found).
>
> What do you think?
>

I recognize this problem from some time ago. Have you tried applying the ubuntu patches to see if the problem goes away? (apt-get source xserver-xorg-input-synaptics, then look in debian/patches.) There might even be additional patches available at ubuntuforums for this. I am particularly thinking of the patches that disable movement when more than one finger is or recently was in contact with the touchpad.

Created an attachment (id=27760)
Quirk - First draft

I was thinking of something like the attached patch.

NOTE: this quirk is just for Synaptics touchpads and therefore it's applied only if priv->model == MODEL_SYNAPTICS.

If the touchpad can detect multi-finger events then, as Peter suggested, we smoothen out movements after the user raises the second finger from the touchpad. This works well with the Synaptics touchpad in my Fujitsu laptop.

If the touchpad can't detect multi-finger events (e.g. the Dell Mini 10v, the HP Mini, etc.) we smoothen movement events which are (usually) too big take place in so little time. I know that this is not perfect but, as reported by our customers, it's still a big improvement. Furthermore I'm not sure how accurate we can be with this kind of touchpads. Better ideas are always welcome though.

What do you think?

(In reply to comment #10)
> Created an attachment (id=27760) [details]
> Quirk - First draft
>
> I was thinking of something like the attached patch.
>
> NOTE: this quirk is just for Synaptics touchpads and therefore it's applied
> only if priv->model == MODEL_SYNAPTICS.

fwiw, my synaptics doesn't do multi-finger, so MODEL_SYNAPTICS is not a good quirk selector. priv->has_double and priv->has_triple are set if the touchpad has multi-finger capabilities. This is regardless of the model.

I find the patch quite hard to review, indentation has a certain randomized component to it. the second half (the non-multifinger part) is the one I tested on my non-multifinger pad and it basically made the touchpad unusable for any larger movements. So this part definitely needs fine-tuning.

why is threshold a double? threshold could be based on the pad dimensions too since a movement of 90 on an ALPS is significantly more than on a synaptics pad.

rather than the wasTimeSkipped approach it'd be better to just dump the old values back into the history so dx/dy is automatically 0 on the next run.

(for a final version of that patch, the xf86Msg must disappear too, it'd spam the logs)

> If the touchpad can detect multi-finger events then, as Peter suggested, we
> smoothen out movements after the user raises the second finger from the
> touchpad. This works well with the Synaptics touchpad in my Fujitsu laptop.

I cannot test this. Henrik, any comments?

> If the touchpad can't detect multi-finger events (e.g. the Dell Mini 10v, the
> HP Mini, etc.) we smoothen movement events which are (usually) too big take
> place in so little time. I know that this is not perfect but, as reported by
> our customers, it's still a big improvement. Furthermore I'm not sure how
> accurate we can be with this kind of touchpads. Better ideas are always welcome
> though.

is it possible to make conditional on two-finger emulation in this case. i.e. only smooth if two-finger emu was triggered?

(In reply to comment #11)
> fwiw, my synaptics doesn't do multi-finger, so MODEL_SYNAPTICS is not a good
> quirk selector. priv->has_double and priv->has_triple are set if the touchpad
> has multi-finger capabilities. This is regardless of the model.
>
This is why I did "if (priv->has_double)". Furthermore I don't own ALPS touchpad.

> I find the patch quite hard to review, indentation has a certain randomized
> component to it. the second half (the non-multifinger part) is the one I tested
Yes, I've just noticed that and I'll fix it.

> why is threshold a double? threshold could be based on the pad dimensions too
> since a movement of 90 on an ALPS is significantly more than on a synaptics
> pad.
Good point. Do you refer to priv->minx (etc.) or is there some variable with the physical dimension of the pad?

>
> rather than the wasTimeSkipped approach it'd be better to just dump the old
> values back into the history so dx/dy is automatically 0 on the next run.
>
Ok.

> (for a final version of that patch, the xf86Msg must disappear too, it'd spam
> the logs)
>
Yes, of course. I forgot to remove that.

> is it possible to make conditional on two-finger emulation in this case. i.e.
> only smooth if two-finger emu was triggered?
>
Yes but two-finger emulation doesn't really work well on the Dell Mini 10v therefore it never gets triggered.

(In reply to comment #9)
> I recognize this problem from some time ago. Have you tried applying the ubuntu
> patches to see if the problem goes away? (apt-get source
> xserver-xorg-input-synaptics, then look in debian/patches.) There might even be
> additional patches available at ubuntuforums for this. I am particularly
> thinking of the patches that disable movement when more than one finger is or
> recently was in contact with the touchpad.
>

I wrote the patches in Ubuntu (I'm a Canonical employee) but if you have links to additional patches I would be glad to have a look at them.

Created an attachment (id=27846)
Quirk - Second draft

This patch has the following changes:
1) threshold is an int;
2) the driver now appends skipped events to priv->move_hist;
3) I added priv->model_version so that we can affect as few touchpads as possible. Now the driver tests priv->model, priv->has_double and priv->model_version before the quirk is applied.

NOTE: this patch should be tested with kernel 2.6.29 or higher, otherwise priv->has_double is always reported = 1 instead of its real value.

Any comments?

The Asus EeePC 1005HA-M is affected by this as well. Multitouch works fine in Windows 7, but synclient only recognizes 1 finger.

Same version of Ubuntu as mentioned above.

Created an attachment (id=27915)
Quirk - Third draft

As regards appending skipped events to priv->move_hist, it makes the cursor jump even when only 1 finger is on the touchpad which is not ideal.

I went back to the was_time_skipped approach. The rest of the patch is the same as before.

I just compared the first version of the patch "Jumpy cursor patch" with the current third version. I tested the first version a while ago on my touchpad which does _NOT_ have multifinger capabilities. I tested this one too.

My comments were that this makes the touchpad unusable as it is quite easy to trigger the threshold when moving fast. Your solution was to special case it for some models and ignore the problem for all others. This is _not_ a solution.

IIRC, dell have alps touchpads with dimensions of 1024. So calculate the threshold based on that and then we can try if the same calculation is valid for synaptics touchpads.

Also, can you remind me again why we need to fix a behaviour for a functionality that the hardware doesn't support? i.e. why we need to behave properly for multi-finger touches if the touchpad is a single-finger pad? I think we discussed that on IRC once but I forgot.

Having just trawled the launchpad reports I see the following picture:
- you filed a bugreport in launchpad about the behaviour described here.
- you applied a patch in ubuntu
- this caused a regression with other touchpads
  https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/405943
  which, incidentally is the same issue I described in comment 4.
- you fixed this regression by making special-casing your touchpad so that those users that reported the regression don't see the effect of the patch anymore.

Can you please point to a user (other than you) who has been affected by this behaviour and who confirms that the patch fixes it?

Because, quite frankly, right now I'm not particularly inclined to add special-cases and half-broken patches to the driver to fix something that doesn't seem to affect a lot of users just so we can not support something that isn't supported by the hardware anyway...

(In reply to comment #16)
> IIRC, dell have alps touchpads with dimensions of 1024.

don't know why I thought that, they have synaptics pads.

<email address hidden> wrote:
> http://bugs.freedesktop.org/show_bug.cgi?id=21614
>
>
>
>
>
> --- Comment #16 from Peter Hutterer <email address hidden> 2009-08-19 17:38:25 PST ---
> I just compared the first version of the patch "Jumpy cursor patch" with the
> current third version. I tested the first version a while ago on my touchpad
> which does _NOT_ have multifinger capabilities. I tested this one too.
>
> My comments were that this makes the touchpad unusable as it is quite easy to
> trigger the threshold when moving fast. Your solution was to special case it
> for some models and ignore the problem for all others. This is _not_ a
> solution.
>
> IIRC, dell have alps touchpads with dimensions of 1024. So calculate the
> threshold based on that and then we can try if the same calculation is valid
> for synaptics touchpads.
>
> Also, can you remind me again why we need to fix a behaviour for a
> functionality that the hardware doesn't support? i.e. why we need to behave
> properly for multi-finger touches if the touchpad is a single-finger pad? I
> think we discussed that on IRC once but I forgot.
>
> Having just trawled the launchpad reports I see the following picture:
> - you filed a bugreport in launchpad about the behaviour described here.
> - you applied a patch in ubuntu
> - this caused a regression with other touchpads
>
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/405943
> which, incidentally is the same issue I described in comment 4.
> - you fixed this regression by making special-casing your touchpad so that
> those users that reported the regression don't see the effect of the patch
> anymore.
>
> Can you please point to a user (other than you) who has been affected by this
> behaviour and who confirms that the patch fixes it?
>
> Because, quite frankly, right now I'm not particularly inclined to add
> special-cases and half-broken patches to the driver to fix something that
> doesn't seem to affect a lot of users just so we can not support something that
> isn't supported by the hardware anyway...
>
>

I concur. Temporarily moving from a multi-touch device to a single-touch
device one is bound to notice that they don't behave the same. Using one
finger to point and click is the only supported gesture on single-touch
devices.

Download full text (3.9 KiB)

(In reply to comment #16)
> I just compared the first version of the patch "Jumpy cursor patch" with the
> current third version. I tested the first version a while ago on my touchpad
> which does _NOT_ have multifinger capabilities. I tested this one too.
>
> My comments were that this makes the touchpad unusable as it is quite easy to
> trigger the threshold when moving fast. Your solution was to special case it
> for some models and ignore the problem for all others. This is _not_ a
> solution.

Right, it's a workaround (after all it's a hardware problem). And it has to be very specific to the touchpad model (i.e. to its real dimensions and resolution).

>
> IIRC, dell have alps touchpads with dimensions of 1024. So calculate the
> threshold based on that and then we can try if the same calculation is valid
> for synaptics touchpads.

I have a few netbooks whose touchpads report the same dimensions but have different sizes in real life. This is why, in my opinion, we cannot rely on the reported dimensions and different thresholds have to be set.

>
> Also, can you remind me again why we need to fix a behaviour for a
> functionality that the hardware doesn't support? i.e. why we need to behave
> properly for multi-finger touches if the touchpad is a single-finger pad? I
> think we discussed that on IRC once but I forgot.

I'm not saying that we should support multi-finger touches but if users (and in my case, customers) complain about the cursor being horribly jumpy (and this is not only a problem of the Dell Mini10v) when they accidentally put more than one finger on their touchpad, I think it's worth doing something to make the problem at least less annoying.

>
> Having just trawled the launchpad reports I see the following picture:
> - you filed a bugreport in launchpad about the behaviour described here.
> - you applied a patch in ubuntu
> - this caused a regression with other touchpads
>
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/405943
> which, incidentally is the same issue I described in comment 4.
> - you fixed this regression by making special-casing your touchpad so that
> those users that reported the regression don't see the effect of the patch
> anymore.
>
> Can you please point to a user (other than you) who has been affected by this
> behaviour and who confirms that the patch fixes it?

Sure:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/402863

and:
https://bugs.edge.launchpad.net/ubuntu/+bug/395515

In the second case the one who reported the bug (a colleague of mine) is using my patch (even though he didn't reply in the bug report).

Not to mention the feedback that I received from Dell and other customers, which is why I wanted to fix this upstream.

>
> Because, quite frankly, right now I'm not particularly inclined to add
> special-cases and half-broken patches to the driver to fix something that
> doesn't seem to affect a lot of users just so we can not support something that
> isn't supported by the hardware anyway...
>

I think a final solution (or workaround) would be, as discussed on IRC, a property which allows users to set the threshold...

Read more...

(In reply to comment #19)
> This would be necessary because the kernel doesn't expose enough information
> (and no, ID_VENDOR, ID_PRODUCT and ID_VERSION are not specific enough) to
> identify a specific touchpad model therefore we have to rely on the laptop
> model instead.

the kernel (2.6.31) exports the resolution as well. Are you able to calculate the threshold based on that? That said, as soon as we have that threshold anywhere we kinda need to expose it as an option anyway. but a correct auto-calculation is needed nonetheless.

> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/402863
> https://bugs.edge.launchpad.net/ubuntu/+bug/395515

both bugs describe the issue where the users clicks a button while using a finger. this is what the Synaptics Area property is already for, if this area doesn't work in this use-case then that's the bit that needs fixing.
can you please test this with the area property set to the correct values, the second finger should not have any effect whatsoever if the area is active.

(In reply to comment #20)
> the kernel (2.6.31) exports the resolution as well. Are you able to calculate
> the threshold based on that? That said, as soon as we have that threshold
> anywhere we kinda need to expose it as an option anyway. but a correct
> auto-calculation is needed nonetheless.
>

I'm using kernel 2.6.31 but the resolution is still incorrectly reported as 1x1. I'll look into this problem and see if the resolution can help with this bug.

> > https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/402863
> > https://bugs.edge.launchpad.net/ubuntu/+bug/395515
>
> both bugs describe the issue where the users clicks a button while using a
> finger. this is what the Synaptics Area property is already for, if this area
> doesn't work in this use-case then that's the bit that needs fixing.
> can you please test this with the area property set to the correct values, the
> second finger should not have any effect whatsoever if the area is active.
>

In those cases the Synaptics Area was not set but the property works well when used.

I have noticed that the reports which are more specific to the problem we're dealing with are private reports from our customers. Only members of Canonical's OEM team have access to these reports. I can give you the description of their problems (stripped of private information) if you think it can help.

For example the first two paragraphs of the description that I put in this bug report on freedesktop.org were taken from one of our private reports.

(In reply to comment #21)
> (In reply to comment #20)
> I'm using kernel 2.6.31 but the resolution is still incorrectly reported as
> 1x1. I'll look into this problem and see if the resolution can help with this
> bug.

in the driver or in xinput? there's about 5 levels where this can be a bug, so please make sure the driver has the right information.

> I have noticed that the reports which are more specific to the problem we're
> dealing with are private reports from our customers. Only members of
> Canonical's OEM team have access to these reports. I can give you the
> description of their problems (stripped of private information) if you think it
> can help.
>
> For example the first two paragraphs of the description that I put in this bug
> report on freedesktop.org were taken from one of our private reports.

I can understand why two fingers would be used with the special button area. Why else would you use two fingers on a single-touch touchpad?
Looking at the values my touchpad produces here, the ranges that I can trigger with by using two fingers and lifting one are about the same of those when moving fast from one point on the screen to another one.

From an UI point of view, this is quite important: touching the touchpad with two fingers and having the cursor jump is a predictable response that can be avoided by using a single finger only. Having a threshold that cuts off certain movements can interfere with normal usage of the touchpad in a non-deterministic manner.

(In reply to comment #22)
> I can understand why two fingers would be used with the special button area.
> Why else would you use two fingers on a single-touch touchpad?
> Looking at the values my touchpad produces here, the ranges that I can trigger
> with by using two fingers and lifting one are about the same of those when
> moving fast from one point on the screen to another one.
>
> From an UI point of view, this is quite important: touching the touchpad with
> two fingers and having the cursor jump is a predictable response that can be
> avoided by using a single finger only. Having a threshold that cuts off certain
> movements can interfere with normal usage of the touchpad in a
> non-deterministic manner.
>

Users can (and do) accidentally put more than one finger on the touchpad, not only in the use case of the Synaptics Area. For example, if you use your index to move the cursor, it can happen that the middle finger (or another finger) accidentally touches the touchpad surface. On the Dell Mini10v and on some other netbooks when this happens the cursor jumps to the other side of the screen which is really not what I would call "predictable behaviour".

Of course on other models this problem is much less noticeable as in your case or on some other netbooks that I own. For this reason I think that we should adopt a case by case approach and apply the threshold only when the problem is unbearable.

I agree with you that cutting off movements is not ideal but in some cases it can really make a difference, which is why I'm more inclined to develop this as a quirk in the fdi file.

Created an attachment (id=29076)
Quirk - Fourth draft

I have played a bit with touchpad resolutions and I'm still convinced that touchpads with the same resolution and different physical size should act differently, therefore I don't think we should really relay on the resolution.

I have rewritten the patch so that the threshold is a property which we can set through xinput. Customised thresholds for different laptops can now be added to the fdi file. For example I put different values for HP Mini 1000 and Dell Mini10v.

Thanks to this patch users will be able to experiment with different values for the threshold (when the cursor jumps too much), find the one which solves the problem (or which makes it more bearable), get the output of "lshal | grep system.hardware.product" (or some other detail of their laptop) and add a quirk in the fdi file.

Feedback on the patch is welcome.

Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid

Karmic and jaunty (both lpia) on a asus 1101HA, and I have also this problem. Multi-touch works well in windows XP, not at all in ubuntu . "synclient -m 100" shows only one finger is detected.

Bryce Harrington (bryce) on 2009-09-04
tags: added: jaunty karmic
Alberto Milone (albertomilone) wrote :

I need more information about the problem.

1) If you're using Jaunty, can you install the kernel in the "-proposed" repository, reboot and follow step 3

2) If you're using Karmic, please follow step 3

3) Type:
xinput list --short

and find the name of your touchpad.

then type:
xinput list-props $YOUR_TOUCHPAD

(replace $YOUR_TOUCHPAD with the name of your touchpad in quotation marks)

and attach the output of the command

I have an Asus 1005HA-P with the same problem (and very likely the same touchpad as Frank Aurich's 1005HA-M above). I'm running karmic, and xinput's output is attached.

Davide P. (scaltro) wrote :

On my Jaunty Samsung NC10, I have launched this:
xinput list-props "SynPS/2 Synaptics TouchPad"

Asus 1101ha, karmic lpia

Alberto Milone (albertomilone) wrote :

@Jose
The "Synaptics Capabilities" (1, 1, 1, 0, 0) property shows that your touchpad doesn't support multi-touch. You can still use emulation mode but it's not guaranteed to work.

@scaltro
Please follow point 1) first, otherwise I won't be able to help you.

Strange, as multi-touch works well under wxp. I didn't know that XP had multi touch emulation. I'll try to do a few more tests.

Neatchee (neatchee) on 2010-03-22
tags: added: lucid
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → In Progress
status: In Progress → Confirmed
description: updated
description: updated
Bryce Harrington (bryce) on 2010-04-06
summary: - Multi fingers touch doesn't be correctly recognized
+ Multitouch support not available for -synaptics
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Medium → Wishlist
status: Confirmed → Triaged
Changed in xorg-driver-synaptics:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → Invalid
Vish (vish) on 2010-07-03
Changed in xorg-driver-synaptics:
importance: Undecided → Unknown
status: Invalid → Unknown
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Invalid → Triaged
summary: - Multitouch support not available for -synaptics
+ Multitouch support not available for Synaptics touchpads
Gursimran singh (simar) on 2010-07-14
summary: - Multitouch support not available for Synaptics touchpads
+ Multitouch support not available for Synaptics touchpads v7.2
Changed in xorg-driver-synaptics:
importance: Unknown → Medium
status: Unknown → Confirmed
Henrik Rydberg (rydberg) on 2010-11-16
Changed in utouch:
status: New → In Progress
assignee: nobody → Henrik Rydberg (rydberg)
importance: Undecided → High
Bryce Harrington (bryce) on 2010-12-03
tags: added: maverick natty
description: updated
183 comments hidden view all 237 comments

Created attachment 40902
Add JumpyCursorThreshold option patch v5

For those touchpads that don't support multi-finger or sending correct finger width, the jumpy cursor problem is still there. One notable example is the ClickPad found on Lenovo S10-3t whose ClickPad suffers from this jumpy cursor problem very severely, because its buttons also have sensible surface thus every time you click a button without lifting another finger from the pad, such as when trying to drag a window or select text, the cursor jumps, and renders the whole touchpad nigh unusable.

(if you are wondering why Synaptics driver doesn't enable ClickPad mode and limit the touch area thus ignore ABS sent from button area, it's because those ClickPads send out BTN_LEFT and BTN_RIGHT just as normal touchpads so they don't trigger the ClickPad mode, which is designed for ClickPads that never send BTN_RIGHT)

Therefore Alberto Milone's JumpyCursorThreshold option patch is still needed, which is the best solution I've seen so far. I've attached the new patch I ported to head. I've tested it in MeeGo and it works very well (with Threshold set to 250).

Bryce Harrington (bryce) on 2011-01-11
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in linux:
status: Unknown → Confirmed
Changed in xorg-driver-synaptics:
importance: Medium → Unknown
status: Confirmed → In Progress
Changed in linux:
importance: Unknown → Medium
Changed in xorg-driver-synaptics:
importance: Unknown → Medium
Changed in linux (Ubuntu):
assignee: nobody → Anudeep Gautamt (jatingautam08)
25 comments hidden view all 237 comments
id_ima (id-ima) wrote :

Seems to me that synaptics-dkms-1.1.1-all.deb doesn't work for me. Right-button disappeared. Double-finger scrolling still doesn't work. Double-finger touch works like right-button.

id_ima (id-ima) wrote :

Seems to me that synaptics-dkms-1.1.1-all.deb doesn't work for me. Right-button disappeared. Double-finger scrolling still doesn't work. Double-finger touch works like right-button. I've got HP Pavilion DV6 and Ubuntu 10.10 (x86) with 2.6.35-27 kernel

Ofir Klinger (klinger-ofir) wrote :

Just installed it. It seems that multi-touch works (as two finger scrolling now works).

Michael Moore (stuporglue) wrote :

I installed it and it works on Ubuntu 10.10 64 bit, on an HP Pavilion dv7.

It doesn't play well with suspend/resume though. When I run it in a terminal, I get the following output when the computer wakes up:

Enable
Disable
X Error of failed request: XI_BadDevice (invalid Device parameter)
  Major opcode of failed request: 146 (XInputExtension)
  Minor opcode of failed request: 37 (X_ChangeDeviceProperty)
  Device id in failed request: 0x17
  Serial number of failed request: 49376
  Current serial number in output stream: 49377

Henrik Rydberg (rydberg) wrote :

This bug, as stated in the title, has been fixed upstream (2.6.38), and has been released in natty. There is also a package linked in this bug, confirmed by a large number of users, to work on maverick. Therefore, I am marking this bug as fixed.

Please people, if you still experience problems related to this problem, file a new bug. A bug with 250 comments is bound to include more than one problem report. Thanks.

Changed in utouch:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: In Progress → Fix Released
affects: xorg-driver-synaptics → hp-tm2
Richard Elkins (texadactyl) wrote :

The Synaptics-dkms package improved my touchpad experience on an HP dv3-1075us immensely. Thank you very much.

For extra credit: I'd like to see hardware detection offer this as a suggested "Additional Drivers" in the future.

Changed in linux:
status: Confirmed → Fix Released
Marco Chiappetta (mardurhack) wrote :

I'm sorry to wake this thread up but I'm not able to install the package on my Ubuntu 10.04.2 (just installed). This is the error log of dpkg trying to install synaptics-dkms_1.1.1_all.deb package :

http://pastebin.com/WmYcgbtJ

And this is the content of the file /var/lib/.../make.log :

http://pastebin.com/WYyRCCLc

My machine is an Eee 1201N (Atom 330, 3GB DDR3, 320GB HD, Nvidia ION).

Multitouch scroll correctly works on Ubuntu 11.04 Natty. Thanks in advance for your help! I would like to keep using a LTS for production purposes and I miss this feature.

Same problem as #204, Same error log too.

My machine: Asus K53SV (Core i7, nvidia geforce gt640M, 4GB DDR, 640 GB HD, Synaptics touchpad.

zhanxw (zhanxw) wrote :

Different error message to 204/205, my make.log is:

DKMS make.log for synaptics-1.1.1 for kernel 2.6.38-8-generic (x86_64)
Mon May 30 01:54:09 EDT 2011
make: Entering directory `/usr/src/linux-headers-2.6.38-8-generic'
  CC [M] /var/lib/dkms/synaptics/1.1.1/build/psmouse-base.o
/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.c:47:1: error: ‘param_ops_proto_abbrev’ undeclared here (not in a function)
/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.c: In function ‘psmouse_attr_set_protocol’:
/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.c:1585:14: error: ‘struct serio’ has no member named ‘child’
/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.c: At top level:
/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.c:1682:12: warning: ‘psmouse_set_maxproto’ defined but not used
/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.c:1699:12: warning: ‘psmouse_get_maxproto’ defined but not used
make[1]: *** [/var/lib/dkms/synaptics/1.1.1/build/psmouse-base.o] Error 1
make: *** [_module_/var/lib/dkms/synaptics/1.1.1/build] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'

I am using ubuntu 11.04 64-bit, kernel 2.6.38-8.
Hopefully, we will have a newer deb package...

belltown (sea-av80r) wrote :

@Jesús Martínez
@zhanxw

I'm also using Ubuntu 11.04 64-bit, kernel 2.6.38-8 with a Synaptics touchpad.

I was able to get everything working with the released Xorg driver plus patches from Bug #582809 (Comments #144 and #190).

The multi-touch functions, tap-to-drag, and right-click seem to work correctly with the patch from Comment #144. Comment #190 includes instructions for how to install this patch plus a patch for LED tap-to-disable.

I have built a deb file for the Comment #144 patches for Ubuntu 11.04 64-bit. You can download it from http://ubuntuone.com/p/w2H/. To install it, go to the download directory and type sudo dpkg -i synaptics-patch-amd64.deb

carlosv (cvedovatti) wrote :

belltown you file almost fixed everything for me.

I have a clickpad HP tm2 Ubuntu 11.04 64bit. I installed your file and works everything fine (right button, two finger tap, etc.) except when I do two-finger-scroll. When I scroll slow is ok, but when I scroll fast it changes direction, it scroll up instead of down.

Any ideas for that?

belltown (sea-av80r) wrote :

@carlosv.

I'm not sure why it would do that . The two-finger vertical scroll works for me, although it's a little jumpier and less smooth than when I'm running the same touchpad under Windows 7. How do you have it configured, i.e. what is the output from synclient -l

carlosv (cvedovatti) wrote :

Hi, the dkms-synaptics worked really well in Ubuntu 10.10, but not in 11.04. And I just upgraded to 11.04, I dont know it affects (I uninstalled dksm-synaptics..). I got this:
    LeftEdge = 1751
    RightEdge = 5187
    TopEdge = 1626
    BottomEdge = 4306
    FingerLow = 24
    FingerHigh = 29
    FingerPress = 255
    MaxTapTime = 180
    MaxTapMove = 222
    MaxDoubleTapTime = 180
    SingleTapTimeout = 180
    ClickTime = 100
    FastTaps = 0
    EmulateMidButtonTime = 75
    EmulateTwoFingerMinZ = 280
    EmulateTwoFingerMinW = 6
    VertScrollDelta = 101
    HorizScrollDelta = 0
    VertEdgeScroll = 0
    HorizEdgeScroll = 0
    CornerCoasting = 0
    VertTwoFingerScroll = 1
    HorizTwoFingerScroll = 1
    MinSpeed = 1
    MaxSpeed = 1.75
    AccelFactor = 0.0394867
    TrackstickSpeed = 40
    EdgeMotionMinZ = 29
    EdgeMotionMaxZ = 159
    EdgeMotionMinSpeed = 1
    EdgeMotionMaxSpeed = 405
    EdgeMotionUseAlways = 0
    TouchpadOff = 1
    LockedDrags = 0
    LockedDragTimeout = 5000
    RTCornerButton = 2
    RBCornerButton = 3
    LTCornerButton = 0
    LBCornerButton = 0
    TapButton1 = 1
    TapButton2 = 3
    TapButton3 = 2
    ClickFinger1 = 1
    ClickFinger2 = 1
    ClickFinger3 = 1
    CircularScrolling = 0
    CircScrollDelta = 0.1
    CircScrollTrigger = 0
    CircularPad = 0
    PalmDetect = 0
    PalmMinWidth = 9
    PalmMinZ = 199
    CoastingSpeed = 20
    CoastingFriction = 50
    PressureMotionMinZ = 29
    PressureMotionMaxZ = 159
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice = 1
    TapAndDragGesture = 1
    AreaLeftEdge = 0
    AreaRightEdge = 0
    AreaTopEdge = 0
    AreaBottomEdge = 0
    TouchButtonArea = 20
    TouchButtonSticky = 64
    LEDStatus = 0
    LEDDoubleTap = 1
    JumpyCursorThreshold = 0

@belltown

Hi! I installed the packages you provided, but it didn't worked for me. Moreover, I followed the instructions on Bug #582809 (patched xserver-xorg-input-synaptics and psmouse) and nothing happened.

I think the problem is that the touchpad isn't recognized by the kernel. When I type: synclient -l, I get:

Couldn't find synaptics properties. No synaptics driver loaded?

Any ideas?

belltown (sea-av80r) wrote :

@Jesús Martínez

Can you post the contents of your /var/log/Xorg.0.log file.

Download full text (31.5 KiB)

@belltown

Thanks for your answer. This is the content of my /var/log/Xorg.0.log file. I guess my touchpad is recognized as a PS/2 Optical Mouse at [ 21.899]

[ 21.103]
X.Org X Server 1.10.1
Release Date: 2011-04-15
[ 21.103] X Protocol Version 11, Revision 0
[ 21.103] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
[ 21.103] Current Operating System: Linux pakitochus-K53SV 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64
[ 21.103] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=96ac74d2-86da-40be-bc35-3b3c827d876c ro quiet splash vt.handoff=7
[ 21.103] Build Date: 21 May 2011 11:48:41AM
[ 21.103] xorg-server 2:1.10.1-1ubuntu1.1 (For technical support please see http://www.ubuntu.com/support)
[ 21.103] Current version of pixman: 0.20.2
[ 21.103] Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
[ 21.103] Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 21.104] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 9 08:49:38 2011
[ 21.128] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 21.128] (==) No Layout section. Using the first Screen section.
[ 21.128] (==) No screen section available. Using defaults.
[ 21.128] (**) |-->Screen "Default Screen Section" (0)
[ 21.128] (**) | |-->Monitor "<default monitor>"
[ 21.128] (==) No monitor specified for screen "Default Screen Section".
 Using a default monitor configuration.
[ 21.128] (==) Automatically adding devices
[ 21.128] (==) Automatically enabling devices
[ 21.128] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 21.128] Entry deleted from font path.
[ 21.128] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 21.128] Entry deleted from font path.
[ 21.128] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 21.128] Entry deleted from font path.
[ 21.128] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 21.128] Entry deleted from font path.
[ 21.128] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 21.128] Entry deleted from font path.
[ 21.128] (==) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/Type1,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
 built-ins
[ 21.128] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 21.128] (II) The server relies on udev to provide the list of input devices.
 If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 21.128] (II) Loader magic: 0x7e0280
[ 21.128] (II) Module ABI versions:
[ 21.128] X.Org ANSI C Emulation: 0.4
[ 21.128] X.Org Video Driver: 10.0
[ 21.128] X.Org XInput driver : 12.3
[ 21.128] X.Org Server Extension : 5.0
[ 21.129] (--) PCI:*(0:0:2:0) 8086:0116:1043:15f2 rev 9, Mem @ 0xdd400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e000/64
[ 21.129] (--) PCI: (0:1:0:0) 10de:0df4:1043:15f2...

belltown (sea-av80r) wrote :

@Jesús Martínez

That would be the problem. You either do not have a Synaptics touchpad, or if you do the kernel is not recognizing it as such. cat /proc/bus/input/devices should show what device the kernel thinks it is dealing with. I believe some ASUS K53SV models come with an Elantech smartpad rather than Synaptics.

@belltown

Thank you for the answer. I can't find any information (for a while) about the touchpad present in Asus K35SV. I will start from this point, and try fortune.

Thanks again.

Mahesh Takate (mahesh-takate) wrote :

I have Sony Laptop with E Series VPCEB34EN model and my touch pad does not work.

Jonas (jonas-f-henriksen) wrote :

Hi,
on ubuntu 11.04 on a dell latitude e6420 i get the following error when trying to install the deb-package:
ERROR: binary package for synaptics: 1.1.1 not found

Any suggestions/workarounds?

Jonas

hrvooje (hrvooje-gmail) wrote :

I must say I installed openSUSE 11.4 on my hp 4520s and now synaptics clickpad works perfect. circular scrolling, side scrolling, taping, LED, taping LED ... maybe this info could help ubuntu developers.

Ben Hearsum (bhearsum) wrote :

Not sure if this is the right place to report this issue or not, but I've noticed that two finger vertical scrolling doesn't work when going slightly or greatly diagonal. Instead of scrolling up or down, it bounces quickly between up and down.

alberto (alberto-sanchez-upr) wrote :

i tried to install the driver but i can't theres this message

(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 250374 files and directories currently installed.)

Preparing to replace synaptics-dkms 1.1.1 (using .../synaptics-dkms_1.1.1_all.deb) ...

------------------------------

Deleting module version: 1.1.1

completely from the DKMS tree.

------------------------------

Done.

Unpacking replacement synaptics-dkms ...

Removing old module source...

Setting up synaptics-dkms (1.1.1) ...

Loading new synaptics-1.1.1 DKMS files...

Loading tarball for module: synaptics / version: 1.1.1

Loading /usr/src/synaptics-1.1.1...

Creating /var/lib/dkms/synaptics/1.1.1/source symlink...

DKMS: ldtarball Completed.

Installing prebuilt kernel module binaries (if any)

Building module...

Kernel preparation unnecessary for this kernel. Skipping...

Building module:

cleaning build area....

make KERNELRELEASE=3.0-3-generic -C /lib/modules/3.0-3-generic/build SUBDIRS=/var/lib/dkms/synaptics/1.1.1/build modules....(bad exit status: 2)

Error! Bad return status for module build on kernel: 3.0-3-generic (x86_64)

Consult the make.log in the build directory

/var/lib/dkms/synaptics/1.1.1/build/ for more information.

0

0

ERROR: binary package for synaptics: 1.1.1 not found

dpkg: error processing synaptics-dkms (--install):

 subprocess installed post-installation script returned error exit status 10

Wizek (123-wizek) wrote :

I have the exact same problem as @Alberto and @Jonas on Natty (ASUS K43SV if that matters). What could be the problem?

Alex P (alexander-e-popov) wrote :

I get the following error when trying to install the https://launchpadlibrarian.net/60964128/synaptics-dkms_1.1.1_all.deb package on my Envy 17 with Ubuntu 11.04 64-bit:

Error! Bad return status for module build on kernel: 2.6.38-10-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/synaptics/1.1.1/build/ for more information.
0
0
ERROR: binary package for synaptics: 1.1.1 not found
dpkg: error processing synaptics-dkms (--install):
 subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
 synaptics-dkms

carlosv (cvedovatti) wrote :

@outlogic

The synaptics-dkms just works on Ubuntu 10.10. For Ubuntu 11.04 try the solution on the: https://bugs.launchpad.net/bugs/582809 . It worked for me.

Changed in linux (Ubuntu):
assignee: Anudeep Gautamt (jatingautam08) → Jorge Barocio (barocio-05)
affects: linux (Ubuntu) → xf86-input-multitouch (Ubuntu)
1 comments hidden view all 237 comments

Still without final solution? I.e. a year of doing nothing in this concern?

Thomas, according to two comments up, it looks like only a small corner case is left.

Also, Yan, you should bring up your patch for discussion on xorg-devel.

Nathan Palmer (dsblue) wrote :

Right click and 2-finger-scroll is not working for me on Oneiric. I couldn't get synaptics-dkms_1.1.1_all.deb to install in 11.10 and I don't see the package available on
http://ppa.launchpad.net/utouch-team/utouch/ubuntu oneiric main

Is this supposed to be working out of the box on Ubuntu 11.10?

carlosv (cvedovatti) wrote :

@Nathan Palmer

Check comment #208 that may help you.

clay (barclay-shaw) on 2012-01-15
Changed in xf86-input-multitouch (Ubuntu):
assignee: Jorge Barocio (barocio-05) → nobody
prannoy (prannoy13in) on 2012-01-31
Changed in xf86-input-multitouch (Ubuntu):
assignee: nobody → prannoy (prannoy13in)
Lord_bow (lordbow) wrote :

@Henrik Rydberg

I have the same problem. I can use vertical edge scrolling but not horizontal edge scrolling on my touchpad. The Ubuntu Forum points to your comment on this page for a debian package that'll fix this bug. It explicitly points to your comments #115 and #116. You mention the debian package is attached but there's nothign there and comment #116 is missing (which I'm guessing had the attached files to install).

Can you help me out and repots the bug fixer or can you direct me to where I can get this bug fixed? Thanks.

I believe this patch finally fixed this issue:

commit c546779b32d8be23475b3b062e3ebc9235365c0d
Author: Chase Douglas <email address hidden>
Date: Thu Feb 9 16:56:29 2012 -0800

    Ignore motion during touch count changes on semi-mt devices

Changed in hp-tm2:
status: In Progress → Fix Released
Changed in baltix:
status: New → Fix Released
dindongpas Yu (pkpd168) wrote :

Great fixes! It works perfectly wiht my Acer Aspire v3 471G.

Changed in baltix:
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
status: Fix Released → Fix Committed

I just installed Ubuntu 12.10, and I still had trouble with my touchpad. Is this the right place to comment?

I finally found the solution on Ask Ubuntu: http://askubuntu.com/questions/154770/alps-touchpad-on-dell-how-do-i-install-the-dkms-driver-to-enable-multitouch/211755#211755

That works for me, but is it possible to get that built into the driver. Is this part of the same issue, or should I open a new bug request, or is this the wrong place?

Junior Rimac (junior-rimac) wrote :

Solution posted on comments #115 and #116 worked like charm!!!

Linux Distribution: Ubuntu 12.04
Laptop HP ProBook 6460b

Thank you so much.

I have this issue in 12.04 with an HP Pavilion dv6 laptop and SynPS/2 Synaptics touchpad. Judging by the posts above, the synaptics-dkms fix is specific to 10.10. Is that correct? If I try to install it, I get the error described in comments 130, 134, 152, 204, 205, ... I suspect we were all trying to use a fix that isn't compatible with the distro we are using. Is there any solution available for newer releases? It looks like two others have the same problem in 12.04 here:
http://ubuntuforums.org/showthread.php?p=12395532&posted=1#post12395532

monomoy (zhaomozm) on 2013-01-08
Changed in xf86-input-multitouch (Ubuntu):
assignee: prannoy (prannoy13in) → monomoy (zhaomozm)
Marc Ros (marclouieros) on 2013-03-16
Changed in xf86-input-multitouch (Ubuntu):
assignee: monomoy (zhaomozm) → Marc Ros (marclouieros)
Changed in xf86-input-multitouch (Ubuntu):
assignee: Marc Ros (marclouieros) → Daniel Joo Sung Yi (jskorea9997)
Josh Ventura (joshv10) wrote :

Three-finger clicking is very much broken for me (behaves as behaves as either one-finger or two-finger click, depending on how far apart my fingers are), on my System76 Bonobo laptop.

Josh Ventura, thank you for your comment. As this bug report is marked Fix Released, it is not covering your problem. If you want your bug fixed in Ubuntu, please feel free to file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Displaying first 40 and last 40 comments. View all 237 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.