X crash when using touch screen on Freescale MX51 in Karmic

Bug #511491 reported by Zhang Lily on 2010-01-23
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-input-evtouch (Ubuntu)
Undecided
Zhang Lily
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Zhang Lily

Bug Description

[Impact]
A bug in the implementation of the -evtouch driver's input configuration can lead to crashes due to failing to detect the end-of-list marker for the configuration options list.

[Development Solution]
Patch incorporated into -evtouch in natty.

[Stable Solution]
We carry the same upstream version of -evtouch in lucid, maverick, and natty, so the same patch can be used in all three versions without modification.

[Test Case]
See original report

[Regression Potential]
I think basically none. This is clearly incorrect code.

The scope of a regression would be quite constrained as well, since -evtouch is used only for a focused class of hardware.

[Original Report]
HW configuration: MX51 EVK board
SW configuration:
1. Install xserver-xorg-input-evtouch page (version: 0.8.8-0ubuntu6.1)
2. Add fdi file by "vi /usr/share/hal/fdi/policy/20thirdparty/50-mxc-ts.fdi":
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.product" contains="mxc_ts">
        <merge key="input.x11_driver" type="string">evtouch</merge>
    </match>
  </device>
</deviceinfo>
3. reboot the board, X crash. The backtrace is as follows:
Program received signal SIGSEGV, Segmentation fault.
0x402edae4 in strlen () from /lib/libc.so.6
(gdb) backtrace
#0 0x402edae4 in strlen () from /lib/libc.so.6
#1 0x00096a4c in xf86optionListCreate ()
#2 0x0008f8d8 in xf86CollectInputOptions ()
#3 0x42d46b0c in EVTouchPreInit (drv=<value optimized out>, dev=0x329b88,
    flags=<value optimized out>) at evtouch.c:1167
#4 0x000861c8 in ?? ()
#5 0x000861c8 in ?? ()

However if i down-grade xserver-xorg-input-evtouch to version 0.8.8-0ubuntu3, Touch screen works fine.

So what's the possible difference cause this issue?

Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Zhang,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 511491

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 511491 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/511491

Changed in xf86-input-evtouch (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xf86-input-evtouch (Ubuntu):
status: Incomplete → Expired
Zhang Lily (r58066) wrote :

This issue still exists in lucid. Jason has found one fix for it. Will attach soon.

Changed in xf86-input-evtouch (Ubuntu):
assignee: nobody → Zhang Lily (r58066)
status: Expired → In Progress
zhangjiejing (kzjeef) wrote :

Hi There,

I've fix this issue, the patch is attached.
the root casue is:
Xorg will load the config until find a NULL pointer, add a NULL pointer at the tail of default config to avoid crash.

Thanks,
Jieijing

tags: added: patch
Bryce Harrington (bryce) wrote :

Yep, confirm that this list needs to be NULL terminated, in order for xf86optionListCreate() to count how many options there are.

Patch looks good for sponsoring to natty as well as SRU to lucid and maverick (same version of -evtouch is present in all three ubuntu releases).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xf86-input-evtouch - 0.8.8-4ubuntu3

---------------
xf86-input-evtouch (0.8.8-4ubuntu3) natty; urgency=low

  * Add 07_null_terminate_config_list.patch - Xorg will load the config
    until it finds a NULL pointer, so add a NULL pointer at the tail of
    default config. Fixes crash when using touch screen on Freescale MX51.
    (LP: #511491)
 -- Bryce Harrington <email address hidden> Mon, 07 Mar 2011 17:57:51 -0800

Changed in xf86-input-evtouch (Ubuntu Natty):
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2011-03-08
description: updated
Bryce Harrington (bryce) on 2011-03-08
Changed in xf86-input-evtouch (Ubuntu Lucid):
status: New → Fix Committed
Changed in xf86-input-evtouch (Ubuntu Maverick):
status: New → Fix Committed

Accepted xf86-input-evtouch into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted xf86-input-evtouch into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Bryce Harrington (bryce) wrote :

A sufficient amount of time has passed for testing in -proposed, please roll out the maverick and lucid packages to -updates.

Martin Pitt (pitti) wrote :

Nobody tested the proposed packages yet and confirmed that they work and don't introduce a regression.

Bryce Harrington (bryce) wrote :

Martin, this is a very rarely used driver and I would not expect it to have that many users watching this bug.

The patch is obviously correct and has been adequately tested in other releases. -evtouch is not critical infrastructure, but this is a serious bug if and when it does come up.

Hi Martin,

We have tested this patch on i.MX 53 Tablet reference board Ubuntu release,
it works fine.

Best regards,
Zhang Jiejing

2011/6/28 Bryce Harrington <email address hidden>

> Martin, this is a very rarely used driver and I would not expect it to
> have that many users watching this bug.
>
> The patch is obviously correct and has been adequately tested in other
> releases. -evtouch is not critical infrastructure, but this is a
> serious bug if and when it does come up.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/511491
>
> Title:
> X crash when using touch screen on Freescale MX51 in Karmic
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xf86-input-evtouch/+bug/511491/+subscriptions
>

zhangjiejing (kzjeef) wrote :

Maybe Eric Miao @ Canonical also verified this patch.

Hi Eric,

I think you have used Ubuntu touch screen in MX53 SMD board, this patch is
need to make the touchscreen worked, but the Bug owner need some one tested
this patch.

This patch was applied on i.MX 's ubuntu image, the xf86-input-evtouch
package in freescale's deb package, so better this patch can going to
ubuntu's release.

Can you say something ?

Best regards,
Zhang Jiejing

2011/6/28 Jiejing.Zhang <email address hidden>

> Hi Martin,
>
> We have tested this patch on i.MX 53 Tablet reference board Ubuntu
> release, it works fine.
>
> Best regards,
> Zhang Jiejing
>
>
>
> 2011/6/28 Bryce Harrington <email address hidden>
>
>> Martin, this is a very rarely used driver and I would not expect it to
>> have that many users watching this bug.
>>
>> The patch is obviously correct and has been adequately tested in other
>> releases. -evtouch is not critical infrastructure, but this is a
>> serious bug if and when it does come up.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/511491
>>
>> Title:
>> X crash when using touch screen on Freescale MX51 in Karmic
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/xf86-input-evtouch/+bug/511491/+subscriptions
>>
>
>

zhangjiejing (kzjeef) wrote :

CCing Eric Miao,

Maybe Eric Miao @ Canonical also verified this patch.

Hi Eric,

I think you have used Ubuntu touch screen in MX53 SMD board, this patch is
need to make the touchscreen worked, but the Bug owner need some one tested
this patch.

This patch was applied on i.MX 's ubuntu image, the xf86-input-evtouch
package in freescale's deb package, so better this patch can going to
ubuntu's release.

Could you confirm this?

Thanks~

Best regards,
Zhang Jiejing

>
>
> 2011/6/28 Jiejing.Zhang <email address hidden>
>
> Hi Martin,
>>
>> We have tested this patch on i.MX 53 Tablet reference board Ubuntu
>> release, it works fine.
>>
>> Best regards,
>> Zhang Jiejing
>>
>>
>>
>> 2011/6/28 Bryce Harrington <email address hidden>
>>
>>> Martin, this is a very rarely used driver and I would not expect it to
>>> have that many users watching this bug.
>>>
>>> The patch is obviously correct and has been adequately tested in other
>>> releases. -evtouch is not critical infrastructure, but this is a
>>> serious bug if and when it does come up.
>>>
>>> --
>>> You received this bug notification because you are subscribed to the bug
>>> report.
>>> https://bugs.launchpad.net/bugs/511491
>>>
>>> Title:
>>> X crash when using touch screen on Freescale MX51 in Karmic
>>>
>>> To manage notifications about this bug go to:
>>>
>>> https://bugs.launchpad.net/ubuntu/+source/xf86-input-evtouch/+bug/511491/+subscriptions
>>>
>>
>>
>

Martin Pitt (pitti) wrote :

Did you test the patch (manually applied), or the actual package from -proposed?

zhangjiejing (kzjeef) wrote :

I tested this patch with put the patch under debian/ dir of the package, and
use debian tool to generate the package.

not tested -proposed, since the MX53/MX51 is actully ARM based.

Can I get the -proposed package with ARM cross-compiled ?

BTW, this evtouch(event based input device ) is more common on ARM based
hardware/board.

Best regards,
Zhang Jiejing

2011/6/28 Martin Pitt <email address hidden>

> Did you test the patch (manually applied), or the actual package from
> -proposed?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/511491
>
> Title:
> X crash when using touch screen on Freescale MX51 in Karmic
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xf86-input-evtouch/+bug/511491/+subscriptions
>

Bartosz Kosiorek (gang65) wrote :

The package 0.8.8-4ubuntu2.1 is fixed the crash on Maverick for me.

tags: added: verification-done-maverick
Changed in xf86-input-evtouch (Ubuntu Maverick):
status: Fix Committed → Won't Fix

The fix for this bug has been awaiting testing feedback in the -proposed repository for lucid for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Brian Murray (brian-murray) wrote :

The version of xf86-input-evtouch in lucid-proposed has been removed as this bug report was not verified in a timely fashion.

tags: removed: verification-needed
tags: removed: removal-candidate
Changed in xf86-input-evtouch (Ubuntu Lucid):
status: Fix Committed → Triaged
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in xf86-input-evtouch (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers