Ubuntu

Missing directory /var/lib/xen/ causes user-unfriendly errors

Reported by blue balls on 2012-03-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xen (Ubuntu)
Undecided
Unassigned

Bug Description

  I tried to create a new xen domain :
Command:
     xl create XenWin_4.cfg

Output:

Parsing config file XenWin_4.cfg
xc: info: VIRTUAL MEMORY ARRANGEMENT:
  Loader: 0000000000100000->000000000017c310
  TOTAL: 0000000000000000->000000002f800000
  ENTRY ADDRESS: 00000000001015a0
xc: info: PHYSICAL MEMORY ALLOCATION:
  4KB PAGES: 0x0000000000000200
  2MB PAGES: 0x000000000000017b
  1GB PAGES: 0x0000000000000000
libxl: error: libxl_dom.c:718:libxl_userdata_store cannot write /var/lib/xen/userdata-n.4.3b6bf199-996c-4d45-b374-7bac050ebe0e.xl for /var/lib/xen/userdata-d.4.3b6bf199-996c-4d45-b374-7bac050ebe0e.xl: No such file or directory
cannot save config file: No such file or directory
libxl: error: libxl_dom.c:645:libxl__userdata_destroyall glob failed for /var/lib/xen/userdata-?.4.3b6bf199-996c-4d45-b374-7bac050ebe0e.*: No such file or directory

  Upon investigation, the directory

     /var/lib/xen/

was missing.
   After creating the directory, the error vanished.

   So the solution is to create the directory during the installation of the "xen" package.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xen-hypervisor-4.1-amd64 4.1.1-2ubuntu4.1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Mar 8 15:32:36 2012
Dependencies:

ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xen
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in xen (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers