Libvirt fails to work with paravirt guest Xen 4.1 Dom0 ( kernel 3.0.0-5-generic)

Bug #811635 reported by Boris Derzhavets on 2011-07-16
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xen (Ubuntu)
Undecided
Unassigned

Bug Description

Unable to complete install: 'POST operation failed: xend_post: error from xen daemon: <Fault 3: 'VF14PV'>'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1643, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/pymodules/python2.7/virtinst/Guest.py", line 1186, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/pymodules/python2.7/virtinst/Guest.py", line 1245, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 1686, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: POST operation failed: xend_post: error from xen daemon: <Fault 3: 'VF14PV'>

Boris Derzhavets (bderzhavets) wrote :

Snapshot attached. Virt-Manager connected to Xen 4.1 Hypervisor. Install fails to start

Boris Derzhavets (bderzhavets) wrote :

root@boris-P5Q-E:~/vms/f15# virsh version
Compiled against library: libvir 0.9.2
Using library: libvir 0.9.2
Using API: Xen 3.0.1
Running hypervisor: Xen 4.1.0

Boris Derzhavets (bderzhavets) wrote :

Install keymaps fixes the issue ( /usr/share/qemu/keymaps/en-us).
However, in Virt-manager PV domain stays paused 2-4 sec after start
before status shows "runing". Snapshot attached ( SL6 PV DomU )

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xen (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers