[FFE][Feature] KVM CLX avx512_vnni

Bug #1739665 reported by Paul Lai on 2017-12-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Thadeu Lima de Souza Cascardo
Bionic
Undecided
Thadeu Lima de Souza Cascardo
qemu (Ubuntu)
Wishlist
Unassigned
Bionic
Wishlist
Unassigned
xen (Ubuntu)
Wishlist
Unassigned
Bionic
Wishlist
Unassigned

Bug Description

This feature has been released in ICX platform and the definition of AVX512_VNNI as below
 AVX512_VNNI Vector Nerual Network Instructions, an addition to AVX512. cpuid.(7,0). ECX[11]

This is a new instruction to support machine learning. This instructions is pure HW features, currently, there is no test cases for this new instruction, we only check CPUID info by cpuid tool.

Target Kernel: 4.16
Target Qemu: 2.12
Target Release: 18.04

Alice Liu (dxliu) on 2017-12-22
description: updated
Alice Liu (dxliu) wrote :

KVM patch has been merged in kernel 4.16-rc1.
Commit id:
80fef315a74d79d765dbf58d9481843a364c50d6

description: updated
Alice Liu (dxliu) wrote :

The Qemu patch for AVX512_VNNI cpu feature has been merged into Qemu release in last Nov, Qemu 2.12 release, master branch.

Commit id:
aff9e6e46a343e1404498be4edd03db1112f0950

tags: added: kernel
tags: removed: kernel
tags: added: kernel
Changed in linux (Ubuntu Bionic):
status: New → Confirmed
assignee: nobody → Thadeu Lima de Souza Cascardo (cascardo)
status: Confirmed → In Progress
status: In Progress → Fix Committed
Andreas Hasenack (ahasenack) wrote :

Confirmed that qemu in bionic does not have that commit yet. Subscribing ubuntu-server for consideration.

Changed in xen (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Wishlist
status: Triaged → New
importance: Wishlist → Undecided
Changed in qemu (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Wishlist
tags: added: server-next

Hi,
For Qemu this needs a a feature freeze exception for the qemu change was identified after 1st of March.
Sorry, I missed the update with the upstream sha for a bit, otherwise I'd have marked it as FFE earlier, but IMHO it is no problem.
The patch is rather small and does not imply extra danger IMHO.

So getting a Feature Freeze ack by the release team is very likely.
But lets stay formal and do that.

Afterwards I can upload the package with the qemu fix applied.

summary: - [Feature] KVM CLX avx512_vnni
+ [FFE][Feature] KVM CLX avx512_vnni

I'll ping the release team to ack the FFE:
To make it easier, the change is really just "giving names to formerly undefined bits"
=> https://git.qemu.org/?p=qemu.git;a=commit;h=aff9e6e46a343e1404498be4edd03db1112f0950

Changed in qemu (Ubuntu Bionic):
status: Triaged → New
Łukasz Zemczak (sil2100) wrote :

FFe for qemu approved, you can proceed now. Will any similar FFe be required for xen as well?

Changed in qemu (Ubuntu Bionic):
status: New → Triaged

It would be required for Xen as well if it will be done, but I didn't hear on Xen in regard to this so I don't know.

SMB might share his opinion on this for xen and he is generally subscribed to xen so he will see the updates.

PPA: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3225

Regression test against ppa was ok tonighz, but I need to respin to add more things before pushing to Bionic.

If you want to pre-test feel free to use this PPA.
Given the change thou I assume we can just let it roll in (under usual regression checks being ok)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu - 1:2.11+dfsg-1ubuntu6

---------------
qemu (1:2.11+dfsg-1ubuntu6) bionic; urgency=medium

  * Remove LP: 1752026 changes to d/p/ubuntu/define-ubuntu-machine-types.patch.
    The Kernel fixes are preferred and already committed to the kernel.
    Therefore remove the default disabling of the HTM feature (LP: #1761175)
  * d/p/ubuntu/lp1739665-SSE-AVX-AVX512-cpu-features.patch: Enable new
    SSE/AVX/AVX512 cpu features (LP: #1739665)
  * d/p/ubuntu/lp1740219-continuous-space-commpage.patch: make Arm
    space+commpage continuous which avoids long startup times on
    qemu-user-static (LP: #1740219)
  * d/p/ubuntu/lp-1761372-*: provide pseries-bionic-2.11-sxxm type as
    convenience with all meltdown/spectre workarounds enabled by default.
    This is not the default type following upstream and x86 on that.
    (LP: #1761372).
  * d/p/ubuntu/lp-1704312-1-* provide means to manually handle filesystem-dax
    with pmem by backporting align and unarmed options (LP: #1704312).
  * d/p/ubuntu/lp-1762315-slirp-Add-domainname.patch: slirp: Add domainname
    option to slirp's DHCP server (LP: #1762315)

 -- Christian Ehrhardt <email address hidden> Wed, 04 Apr 2018 15:16:07 +0200

Changed in qemu (Ubuntu Bionic):
status: Triaged → Fix Released

There wasn't a xen commit listed (and we didn't bump the xen version so we haven't picked it up by accident).
I'd assume this is a Won't Fix for 18.04 and might appear sometime later.

Is there any xen change to consider (later on) or was xen just optionally listed but doesn't come to life?

Changed in xen (Ubuntu Bionic):
status: New → Incomplete
importance: Undecided → Wishlist
Stefan Bader (smb) wrote :

Due to time constraints and because we would deviate further and further away from Debian, we are not planning to update the Xen version for Bionic.

Changed in xen (Ubuntu Bionic):
status: Incomplete → Won't Fix
Launchpad Janitor (janitor) wrote :
Download full text (40.4 KiB)

This bug was fixed in the package linux - 4.15.0-15.16

---------------
linux (4.15.0-15.16) bionic; urgency=medium

  * linux: 4.15.0-15.16 -proposed tracker (LP: #1761177)

  * FFe: Enable configuring resume offset via sysfs (LP: #1760106)
    - PM / hibernate: Make passing hibernate offsets more friendly

  * /dev/bcache/by-uuid links not created after reboot (LP: #1729145)
    - SAUCE: (no-up) bcache: decouple emitting a cached_dev CHANGE uevent

  * Ubuntu18.04:POWER9:DD2.2 - Unable to start a KVM guest with default machine
    type(pseries-bionic) complaining "KVM implementation does not support
    Transactional Memory, try cap-htm=off" (kvm) (LP: #1752026)
    - powerpc: Use feature bit for RTC presence rather than timebase presence
    - powerpc: Book E: Remove unused CPU_FTR_L2CSR bit
    - powerpc: Free up CPU feature bits on 64-bit machines
    - powerpc: Add CPU feature bits for TM bug workarounds on POWER9 v2.2
    - powerpc/powernv: Provide a way to force a core into SMT4 mode
    - KVM: PPC: Book3S HV: Work around transactional memory bugs in POWER9
    - KVM: PPC: Book3S HV: Work around XER[SO] bug in fake suspend mode
    - KVM: PPC: Book3S HV: Work around TEXASR bug in fake suspend state

  * Important Kernel fixes to be backported for Power9 (kvm) (LP: #1758910)
    - powerpc/mm: Fixup tlbie vs store ordering issue on POWER9

  * Ubuntu 18.04 - IO Hang on some namespaces when running HTX with 16
    namespaces (Bolt / NVMe) (LP: #1757497)
    - powerpc/64s: Fix lost pending interrupt due to race causing lost update to
      irq_happened

  * fwts-efi-runtime-dkms 18.03.00-0ubuntu1: fwts-efi-runtime-dkms kernel module
    failed to build (LP: #1760876)
    - [Packaging] include the retpoline extractor in the headers

linux (4.15.0-14.15) bionic; urgency=medium

  * linux: 4.15.0-14.15 -proposed tracker (LP: #1760678)

  * [Bionic] mlx4 ETH - mlnx_qos failed when set some TC to vendor
    (LP: #1758662)
    - net/mlx4_en: Change default QoS settings

  * AT_BASE_PLATFORM in AUXV is absent on kernels available on Ubuntu 17.10
    (LP: #1759312)
    - powerpc/64s: Fix NULL AT_BASE_PLATFORM when using DT CPU features

  * Bionic update to 4.15.15 stable release (LP: #1760585)
    - net: dsa: Fix dsa_is_user_port() test inversion
    - openvswitch: meter: fix the incorrect calculation of max delta_t
    - qed: Fix MPA unalign flow in case header is split across two packets.
    - tcp: purge write queue upon aborting the connection
    - qed: Fix non TCP packets should be dropped on iWARP ll2 connection
    - sysfs: symlink: export sysfs_create_link_nowarn()
    - net: phy: relax error checking when creating sysfs link netdev->phydev
    - devlink: Remove redundant free on error path
    - macvlan: filter out unsupported feature flags
    - net: ipv6: keep sk status consistent after datagram connect failure
    - ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
    - ipv6: sr: fix NULL pointer dereference when setting encap source address
    - ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel state
    - mlxsw: spectrum_buffers: Set a minimum quota for CPU port traffic
    - net: phy: Tell caller result ...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released

Dropping server subscription as the remaining (xen) task is incomplete still

tags: removed: server-next
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers