[FFE Yakkety] Upgrade to Xen 4.7

Bug #1621618 reported by Leann Ogasawara on 2016-09-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xen (Ubuntu)
High
Stefan Bader

Bug Description

Several features which have been requested to support are part of Xen-4.7. Backporting the code for those is high risk and effort:
- https://bugs.launchpad.net/bugs/1460900
- https://bugs.launchpad.net/bugs/1328027
- https://bugs.launchpad.net/bugs/1460904
- https://bugs.launchpad.net/bugs/1611210
- https://bugs.launchpad.net/bugs/1611242

There is no changes/news file which could be diffed, however the Xen project website has a features page (if that helps): https://wiki.xenproject.org/wiki/Xen_Project_4.7_Feature_List

I have a release candidate of the new package uploaded to my PPA (along with qemu and libvirt built against the new Xen version):

https://launchpad.net/~smb/+archive/ubuntu/xen?field.series_filter=yakkety

PLEASE NOTE: the PPA is just to prove test compiles worked. I would like to upload packages with proper version numbers once the FFE is accepted (also ensuring that qemu and libvirt get correct no-change rebuilds).

Changed in xen (Ubuntu):
assignee: nobody → Stefan Bader (smb)
tags: added: upgrade-software-version
Stefan Bader (smb) wrote :

Ran my regression testing after dist-upgrading Xen from my PPA. None of the problems reported are related to Xen. The upgrade step that failed was successfully re-tried and the problems of the security-qrt test are due missing or incorrect dependency declarations.

Stefan Bader (smb) on 2016-09-14
description: updated
Stefan Bader (smb) on 2016-09-14
description: updated
description: updated
description: updated
description: updated
Tim Gardner (timg-tpi) on 2016-09-14
description: updated
Stefan Bader (smb) on 2016-09-16
Changed in xen (Ubuntu):
importance: Undecided → High
status: New → In Progress
Martin Pitt (pitti) wrote :

This is a leaf package, and yakkety isn't a (viable) production platform, so the risk is low enough at this point. Needless to mention, please ensure that upgrades and the main functionality still work with those.

Approved. Status is already higher than "triaged".

Stefan Bader (smb) wrote :

As asked by review: when moving to the new version I was going through all quilt patches (including the security ones) and made sure they got refreshed or dropped (if already applied) accordingly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen - 4.7.0-0ubuntu1

---------------
xen (4.7.0-0ubuntu1) yakkety; urgency=low

  * Rebasing to upstream Xen release 4.7 (LP: #1621618)
    - Renamed all *-4.6* files into *-4.7*. Also moved references within
      various files from 4.6 to 4.7.
    - Follow previous abiname patches to create individual run-time libs
      for the versioned libxen package for libxencall, libxenevtchn,
      libxenforeignmemory, libxengnttab, and libxentoollog.
    - Modified debian/libxen-dev.install to pick up the additional headers
      and drop one which is no longer present. And also add the new libs.
    - Refreshed Debian patchesS
    - Dropped transitional packages <4.6, added a set for 4.6.
    - Dropped tools-allow-configure-time-choice-of-libexec-subdire.patch
      (upstream)
    - Dropped ubuntu-config-prefix-fix.patch (unnecessary)
    - Dropped all security patches since those were all included in
      the new upstream release.
    - Added fix for FTBS on Arm due to unused static variables and
      hardening flags turned on.
    - Switched dependencies of sysvinit scripts from libvirt-bin to
      libvirtd.
    - Added modprobe for xen-acpi-processor (no auto-load alias) to
      xenstrore init script. Otherwise there is no frequency scaling
      if the driver is compiled as a module.
    - Added proposed upstream fix for regression to save PV guests
      with more than 1G of memory.

xen (4.6.0-1+nmu2) unstable; urgency=medium

  * Ensure debian/control.md5sum is correctly updated. Fixes FTBFS of
    4.6.0-1+nmu1 on buildds where linux-support-4.2.0-1 is not expected to be
    installed.

xen (4.6.0-1+nmu1) unstable; urgency=medium

  * Non-maintainer upload.
  * Drop unused patching in of $(PREFIX), $(SBINDIR) and $(BINDIR)
    which are no longer used by the upstream build system.
  * Use correct/consistent LIBEXEC dirs throughout build
    (Closes: #805508).

 -- Stefan Bader <email address hidden> Wed, 31 Aug 2016 16:12:26 +0200

Changed in xen (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers