[FFE] Pull Xen-4.4 into Trusty

Bug #1290743 reported by Stefan Bader on 2014-03-11
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xen (Ubuntu)
High
Stefan Bader

Bug Description

Normally we would go with Xen-4.3 (as it was in Saucy) for the LTS. However the 4.4 release (which happened yesterday, Mar-10) is supposed to improve support for Arm platforms a lot (hypervisor ABI is now declared stable). Also libvirt/xl integration is supposed to be improved much and last but not least the number of event channels was raised substantially which lifts the limitation of concurrent guests a lot.

http://blog.xen.org/index.php/2014/03/10/xen-4-4-released/

Stefan Bader (smb) on 2014-03-11
description: updated
Changed in xen (Ubuntu):
importance: Undecided → High
assignee: nobody → Stefan Bader (smb)
status: New → Confirmed
Stefan Bader (smb) wrote :
Stefan Bader (smb) wrote :

Rebuild of qemu and libvirt will be required to depend on the correct libxl. Especially libvirt which otherwise segfaults when launching a guest with the libxl driver.

Stefan Bader (smb) wrote :

Adding block-proposed to let it wait for at least libvirt to do a no-change rebuild before moving out.

tags: added: block-proposed
Iain Lane (laney) wrote :

Are you ready to upload this now?

If all you care about is having libvirt built against the new soname then you don't need block-proposed. britney will take care of that on her own.

Changed in xen (Ubuntu):
status: Confirmed → New
Stefan Bader (smb) wrote :

I am ready. Though I cannot upload myself. I uploaded things to my PPA (ppa:smb/xen) but I cannot upload to the main archive. The block-proposed was a safety-latch that Adam suggested.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xen (Ubuntu):
status: New → Confirmed
Thiago Martins (martinx) wrote :

+10 for this FFE! :-D

Adam Conrad (adconrad) wrote :

Please get this into the archive ASAP. There will be things we'll need to fix (like arm64 support), but let's sort that after it's in, rdeps rebuilt, and everything seems sane on x86.

FFe approved.

Changed in xen (Ubuntu):
status: Confirmed → Fix Committed
Andy Whitcroft (apw) wrote :

This and its rdeps have been sponsored to trusty.

Stefan Bader (smb) wrote :

Qemu and libvirt rebuild. Let the chaos begin (unblocking).

tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen - 4.4.0-0ubuntu3

---------------
xen (4.4.0-0ubuntu3) trusty; urgency=low

  * Fixing up changelog history and preparing for FFE (LP: #1290743).

xen (4.4.0-0ubuntu2) trusty; urgency=low

  * debian/patches/tools-ocaml-disable-test.patch: This disables the ocaml
    test build for now until linking issues are resolved.
  * debian/xen-utils-common.xen.init: Write domid for dom0 into xenstore
    (now required).

xen (4.4.0-0ubuntu1) trusty; urgency=low

  * New upstream release (Xen.4.4)
  * Refreshed patches:
    - debian/patches/tools-libxc-abiname.diff
    - debian/patches/tools-libxl-abiname.diff
    - debian/patches/tools-libxl-prefix.diff
  * debian/rules.real: Force xend to be built.
  * debian/rules.real: For utils_<arch> installation move binaries from
    usr/sbin/ to usr/lib/xen-<version>/bin. Several that used to go into
    the private bin directory moved to the public sbin directory.
    Not ideal but quicker to do without side-effects.
  * debian/rules.real: Hypervisor has no .gz type on armhf.
  * debian/control, debian/rules.gen: Manually update version from 4.3 to 4.4.
  * debian/control: Add build dependency for libfdt-dev on armhf.
  * debian/control: Only depend on qemu-system-x86 for i386 and amd64 builds.
  * debian/*: Also rename several versioned packaging files.
  * debian/tree/xen-utils-common/usr/share/xen-utils-common/default.xen:
    Add comment about toolstack names and make xl the default.
 -- Stefan Bader <email address hidden> Thu, 20 Mar 2014 12:53:21 +0100

Changed in xen (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints