manpage for xm etc. missing in xen-utils-3.3

Bug #346003 reported by David Klotz
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xen-3.3 (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: xen-utils-3.3

The manpage (/usr/share/man/man8/xm.8.gz) for the main Xen administrative command xm seems to be missing in the 3.3 version of the xen-utils package. It is there in the 3.1 version*, but missing in 3.3**. The manpages for the configuration files xmdomain.cfg and xend-config.sxp that were there in 3.1 also seem to be missing in 3.3.

Since xm ist the single most used tool for managing a Xen setup, this manpage would probably be really helpful.

Regards,
David

* Files in 3.1: http://packages.ubuntu.com/intrepid/i386/xen-utils-3.1/filelist
** Files in 3.3: http://packages.ubuntu.com/intrepid/i386/xen-utils-3.3/filelist

Related branches

David Klotz (ravenmokel)
description: updated
Revision history for this message
David Klotz (ravenmokel) wrote :

This still seems to be true for jaunty: http://packages.ubuntu.com/jaunty/i386/xen-utils-3.3/filelist

Is anyone even reading these bug reports?

Revision history for this message
agent 8131 (agent-8131) wrote :

I can confirm that xen-utils-3.3 is missing the manpage for xm.

Changed in xen-3.3 (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.3 - 3.3.0-1ubuntu10

---------------
xen-3.3 (3.3.0-1ubuntu10) karmic; urgency=low

  * debian/patches/use-python-2.6.diff: Pass --install-layout=deb for the
    brave new Python 2.6 world.
  * Also rebuild for Python 2.6. (LP: #362691)
  * debian/patches/suppress-python-2.6-warnings.diff: Patch out a few
    DeprecationWarnings introduced in Python 2.6
  * debian/patches/gcc-4.4-fixes.diff: Fix some inline assembly to build
    with gcc 4.4
  * debian/control: Make sure a dependency on a specific Python version
    gets added.
  * debian/control: Fix the Replaces line for libxen3 and libxen3-dev (LP:
    #286450)
  * debian/control: Fix a lintian warning in libxen3-dev's dependencies.
  * debian/rules: Don't clean out debian/tmp between install stages. This
    reunites some manpages with their long-lost packages. (LP: #346003)
  * debian/rules: Clean up the debian/xen-utils-3.3.udev file created as
    part of the build process.
  * debian/rules: Restart xend after the upgrade is complete to be sure
    pycentral installed the modules.

 -- Evan Broder <email address hidden> Sat, 16 May 2009 18:01:24 -0400

Changed in xen-3.3 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers