libxen3 and libxen3-dev both include /usr/lib/libblktap.so

Bug #264554 reported by Anders Kaseorg
10
Affects Status Importance Assigned to Milestone
xen-3.3 (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Preparing to replace libxen3 3.3.0-1ubuntu4 (using .../libxen3_3.3.0-1ubuntu5_amd64.deb) ...
Unpacking replacement libxen3 ...
dpkg: error processing /var/cache/apt/archives/libxen3_3.3.0-1ubuntu5_amd64.deb (--unpack):
 trying to overwrite `/usr/lib/libblktap.so', which is also in package libxen3-dev
dpkg-deb: subprocess paste killed by signal (Broken pipe)

(Intrepid amd64, libxen3 3.3.0-1ubuntu5, libxen3-dev 3.3.0-1ubuntu5.)

Related branches

Changed in xen-3.3:
assignee: nobody → d.filoni
status: New → In Progress
Revision history for this message
Devid Antonio Filoni (d.filoni) wrote :
Changed in xen-3.3:
assignee: d.filoni → nobody
status: In Progress → Confirmed
Revision history for this message
Stefan Hamminga (stefanhamminga) wrote :

I can confirm this, same Intrepid AMD64 (fully updated), same packages & error.

(Risky) workaround, by forcing the libxen3 install (overwriting the libxen3-dev libblktap.so):
sudo dpkg -i --force-all /var/cache/apt/archives/libxen3_3.3.0-1ubuntu5_amd64.deb
sudo apt-get install -f

This enables my system to install updates again.

Revision history for this message
Anders Kaseorg (andersk) wrote :

Still present in 3.3.0-1ubuntu6.

Revision history for this message
Michael Bienia (geser) wrote :

Wouldn't it be better to remove the line "usr/lib/lib*" from libxen3.install and add "usr/lib/lib*.a" to libxen3-dev.install?

libxen3 contains files (usr/lib/lib*.a and usr/lib/lib*.so) which are usually found in a -dev package.

Revision history for this message
Albin Tonnerre (lutin) wrote :

I'd tend to agree with michael biena. by the way, increasing the severity as it causes other packages to FTBFS (see eg. collectd)

Cheers

Changed in xen-3.3:
importance: Undecided → High
Revision history for this message
Michael Bienia (geser) wrote :

Here is a debdiff for it.

As the affecting line was introduced in -1ubuntu5 for "Update for missing libraries" I've compared the package contents of libxen3 from my test build and that one listed in the build-log and the only missing files were the .so links and the .a files (as intended).

I've also checked that the package installs now fine:
# dpkg -i libxen3_3.3.0-1ubuntu7_amd64.deb libxen3-dev_3.3.0-1ubuntu7_amd64.deb
Selecting previously deselected package libxen3.
(Reading database ... 10679 files and directories currently installed.)
Unpacking libxen3 (from libxen3_3.3.0-1ubuntu7_amd64.deb) ...
Selecting previously deselected package libxen3-dev.
Unpacking libxen3-dev (from libxen3-dev_3.3.0-1ubuntu7_amd64.deb) ...
Setting up libxen3 (3.3.0-1ubuntu7) ...

Setting up libxen3-dev (3.3.0-1ubuntu7) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.3 - 3.3.0-1ubuntu7

---------------
xen-3.3 (3.3.0-1ubuntu7) intrepid; urgency=low

  * debian/libxen3.install: remove usr/lib/lib*
    debian/libxen3-dev.install: add usr/lib/lib.*a
    Install lib*.so and lib.*a only with the -dev package (LP: #264554).

 -- Michael Bienia <email address hidden> Tue, 30 Sep 2008 17:30:43 +0200

Changed in xen-3.3:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers