Script /etc/xen/qemu-ifup is missing in xen-utils-3.2 (32bit)

Bug #201765 reported by terra01
12
Affects Status Importance Assigned to Milestone
xen-3.2 (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

In the 32 Bit Version the script "qemu-ifup" isn't included in "xen-utils-3.2". The vm's won't start. I take out from the xen-utils-3.1, now it works.

The error message was found in (qemu-dm-xx.log) in /var/log/xen:

---snip---
/etc/xen/qemu-ifup: could not launch network script
Could not initialize device 'tap'
---snip---

Please include the qemu-if-up

DISTRIB_ID=Ubuntu
DISTRIB_ARCH=x86 (32bit)
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Thanks, Andy

Related branches

Revision history for this message
Lionel Porcheron (lionel.porcheron) wrote :

Same on 64 bits systems :(.

Changed in xen-3.2:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Todd Deshane (deshantm) wrote :

was this fixed with the latest version of xen-utils last week or is it still a problem?

Revision history for this message
Acura Tech (acuratech) wrote :

I have de same problem with a fresh install of Hardy (xen-utils 3.2.0-0ubuntu9) :

root@ubuntu:/var/log/xen# cat qemu-dm-6.log
Watching /local/domain/0/device-model/6/logdirty/next-active
Watching /local/domain/0/device-model/6/command
/etc/xen/qemu-ifup: could not launch network script
Could not initialize device 'tap'

Revision history for this message
Todd Deshane (deshantm) wrote :

I can confirm this is still a problem in 64bit hardy.

Revision history for this message
Chuck Short (zulcss) wrote :

once of out beta I will upload a new version.

Thanks
chuck

Changed in xen-3.2:
status: Confirmed → In Progress
Revision history for this message
Henri Cook (henricook) wrote :

For anyone with this problem in the meantime, just create a symlink between /etc/xen and /etc/xen/scripts e.g.

ln -s /etc/xen/scripts/qemu-ifup /etc/xen/qemu-ifup

That seems to be working for me!

Henri

Revision history for this message
Elie De Brauwer (elie) wrote :

With the best will of the world, the qemu-ifup isn't in that directory on my system:

root@bean:/etc/xen/scripts# ls -hal
total 132K
drwxr-xr-x 2 root root 4.0K 2008-04-07 10:20 .
drwxr-xr-x 4 root root 4.0K 2008-04-07 10:54 ..
-rwxr-xr-x 1 root root 2.2K 2007-12-29 12:57 blktap
-rwxr-xr-x 1 root root 9.2K 2008-03-13 09:19 block
-rw-r--r-- 1 root root 2.7K 2007-12-29 12:57 block-common.sh
-rwxr-xr-x 1 root root 498 2007-12-29 12:57 block-enbd
-rwxr-xr-x 1 root root 498 2007-12-29 12:57 block-nbd
-rwxr-xr-x 1 root root 2.9K 2007-12-29 12:57 external-device-migrate
-rw-r--r-- 1 root root 2.0K 2007-12-29 12:57 locking.sh
-rw-r--r-- 1 root root 804 2007-12-29 12:57 logging.sh
-rwxr-xr-x 1 root root 7.2K 2008-03-13 09:19 network-bridge
-rwxr-xr-x 1 root root 2.4K 2007-12-29 12:57 network-nat
-rwxr-xr-x 1 root root 741 2007-12-29 12:57 network-route
-rwxr-xr-x 1 root root 2.6K 2007-12-29 12:57 vif-bridge
-rw-r--r-- 1 root root 3.9K 2007-12-29 12:57 vif-common.sh
-rwxr-xr-x 1 root root 3.8K 2007-12-29 12:57 vif-nat
-rwxr-xr-x 1 root root 1.6K 2007-12-29 12:57 vif-route
-rwxr-xr-x 1 root root 351 2007-12-29 12:57 vtpm
-rw-r--r-- 1 root root 11K 2007-12-29 12:57 vtpm-common.sh
-rwxr-xr-x 1 root root 160 2007-12-29 12:57 vtpm-delete
-rw-r--r-- 1 root root 1.1K 2007-12-29 12:57 vtpm-hotplug-common.sh
-rw-r--r-- 1 root root 5.8K 2007-12-29 12:57 vtpm-impl
-rw-r--r-- 1 root root 750 2007-12-29 12:57 vtpm-migration.sh
-rwxr-xr-x 1 root root 767 2007-12-29 12:57 xen-hotplug-cleanup
-rw-r--r-- 1 root root 2.2K 2007-12-29 12:57 xen-hotplug-common.sh
-rw-r--r-- 1 root root 2.7K 2007-12-29 12:57 xen-network-common.sh
-rw-r--r-- 1 root root 993 2007-12-29 12:57 xen-script-common.sh

Revision history for this message
Elie De Brauwer (elie) wrote :

And you can get this file from the xen-utils-3.1 package, or simply copy paste this one:

root@bean:~# cat /etc/xen/qemu-ifup
#!/bin/sh

#. /etc/rc.d/init.d/functions
#ulimit -c unlimited

echo 'config qemu network with xen bridge for ' $*

ifconfig $1 0.0.0.0 up
brctl addif $2 $1

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.2 - 3.2.0-0ubuntu10

---------------
xen-3.2 (3.2.0-0ubuntu10) hardy; urgency=low

  * debian/xen-utils-3.2.xendomains.init
    - fix cut in the init script. (LP: #208300)
  * debian/xen-utils-3.2.install (LP: #201765)
    - fixed missing /etc/xen/qemu-ifup
  * debian/patches/xen-ubuntu-fixes.diff
    - Added fixes from xen-3.1
  * debian/xen-utils-3.2.xend.init
    - Disable loading of modules since they are builtin into the kernel.

 -- Chuck Short <email address hidden> Thu, 03 Apr 2008 15:28:08 -0400

Changed in xen-3.2:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers