xen-3.2: FTBFS if LDFLAGS are set in env

Bug #193850 reported by Steve Langasek on 2008-02-20
4
Affects Status Importance Assigned to Milestone
xen-3.2 (Ubuntu)
High
Unassigned

Bug Description

xen-3.2 will fail to build if any LDFLAGS are set in the environment that aren't valid options to ld, because xen makes non-standard use of LDFLAGS by passing them directly to $(LD) instead of to $(CC). This is a critical problem now because dpkg-buildpackage on Ubuntu sets default LDFLAGS of -Wl,-Bsymbolic-functions - perfectly valid for CC, but causes xen-3.2 to FTBFS.

Steve Langasek (vorlon) wrote :
Changed in xen-3.2:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: New → Confirmed
Luca Falavigna (dktrkranz) wrote :

xen-3.2 (3.2.0-0ubuntu6) hardy; urgency=low

  * Clear LDFLAGS values that might be set in the environment because
    the Xen build uses them in a non-standard way. Thanks to Steve Langasek.

 -- Chuck Short < <email address hidden>> Thu, 21 Feb 2008 07:07:18 -0500

Changed in xen-3.2:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers