no init script in xen-utils-3.2

Bug #191875 reported by Lionel Porcheron
18
Affects Status Importance Assigned to Milestone
xen-3.2 (Ubuntu)
Fix Released
Undecided
Unassigned
Declined for Hardy by Daniel Holbach

Bug Description

There are no init scripts ini xen-utils-3.2 package. Xen does not start at startup.
# dpkg -L xen-utils-3.2 | grep init.d
#

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.2 - 3.2.0-0ubuntu5

---------------
xen-3.2 (3.2.0-0ubuntu5) hardy; urgency=low

  * Readded init script. (LP: #191875)

 -- Chuck Short <email address hidden> Fri, 15 Feb 2008 19:58:12 -0500

Changed in xen-3.2:
status: New → Fix Released
Revision history for this message
Paul Wagland (paul-kungfoocoder) wrote :

This package failed to build: https://launchpad.net/ubuntu/+source/xen-3.2/3.2.0-0ubuntu5/+build/519412

The important lines would appear to be:

ld -Wl,-Bsymbolic-functions -melf_x86_64 -melf_x86_64 -melf_x86_64 -r -o built_in.o head.o
ld: unrecognized option '-Wl,-Bsymbolic-functions'
ld: use the --help option for usage information
make[4]: *** [built_in.o] Error 1
make[4]: Leaving directory `/build/buildd/xen-3.2-3.2.0/debian/build/build-hypervisor/xen/arch/x86/boot'
make[3]: *** [/build/buildd/xen-3.2-3.2.0/debian/build/build-hypervisor/xen/arch/x86/boot/built_in.o] Error 2
make[3]: Leaving directory `/build/buildd/xen-3.2-3.2.0/debian/build/build-hypervisor/xen/arch/x86'
make[2]: *** [/build/buildd/xen-3.2-3.2.0/debian/build/build-hypervisor/xen/xen] Error 2
make[2]: Leaving directory `/build/buildd/xen-3.2-3.2.0/debian/build/build-hypervisor/xen'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/build/buildd/xen-3.2-3.2.0/debian/build/build-hypervisor/xen'
make: *** [debian/stamps/build-hypervisor] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

Revision history for this message
Paul Wagland (paul-kungfoocoder) wrote :

This was fixed in the 3.2.0-0ubuntu6 upload. Thanks for the good work Chuck!

Revision history for this message
Paul Wagland (paul-kungfoocoder) wrote :

Hmm. Well, the build failure is fixed, but the issue is not resolved :-)

#$ dpkg -l xen-utils-3.2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================-
ii xen-utils-3.2 3.2.0-0ubuntu6 XEN administrative tools

#$ dpkg -L xen-utils-3.2 | grep init

Changed in xen-3.2:
status: Fix Released → Incomplete
Revision history for this message
Paul Wagland (paul-kungfoocoder) wrote :

Hi Chuck... I hate to be the bearer of bad news :-)

# dpkg -l xen-utils-3.2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================
ii xen-utils-3.2 3.2.0-0ubuntu7 XEN administrative tools
# dpkg -L xen-utils-3.2 | grep init
#

That is, something in apt land seems to be conspiring against you :-)

Changed in xen-3.2:
status: Incomplete → Confirmed
Revision history for this message
Wolfgang Glas (wglas) wrote :

Does anyone have a workaround for this this or some sort of ubuntu+xen-3.2 HOWTO, because due to thiese nsty packaging pbs my mileage with xen-3.2 is very depressive so far...

Revision history for this message
Lionel Porcheron (lionel.porcheron) wrote :

The attached debdiff readd the init scripts (just copying what was done for xen 3.1).

Revision history for this message
Paul Wagland (paul-kungfoocoder) wrote :

I can verify that the patch from Lionel worked, however the scripts themselves seem to have an error, since they are referencing field 0 in a cut command and that is not allowed.

Changed in xen-3.2:
status: Confirmed → Fix Released
Revision history for this message
Lionel Porcheron (lionel.porcheron) wrote :

I'm afraid we still not have any init scripts with last upload. Reopening.
Paul is right, there are some error, I'll check it tomorrow.

Changed in xen-3.2:
status: Fix Released → Confirmed
Revision history for this message
Paul Wagland (paul-kungfoocoder) wrote :

$ dpkg -S /etc/init.d/xendomains
xen-utils-3.2: /etc/init.d/xendomains

dpkg -l xen-utils-3.2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-============================================-============================================-
ii xen-utils-3.2 3.2.0-0ubuntu8

I was a little surprised, since I had built my own packages, and then immediately upon installing found out that the same change had also been pushed into the repository.

Revision history for this message
Marco Scholl (traxanos) wrote :

workaround

xen ist enable by "xend start" manually.

if somebody wan't they can create a link in the init.d directory
and activate it with update-rc.d

Revision history for this message
Daniel Holbach (dholbach) wrote :

Chuck: could you please take a look at it?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.2 - 3.2.0-0ubuntu9

---------------
xen-3.2 (3.2.0-0ubuntu9) hardy; urgency=low

  * Fixed typo in debian/rules. Init scripts are back. (LP: #191875)
  * Disabled suse patches. (LP: #199533)
  * Dont conflict with libxen3.0 (LP: #199467)

 -- Chuck Short <email address hidden> Thu, 13 Mar 2008 07:24:42 -0400

Changed in xen-3.2:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers