Ubuntu

xemacs jde error on editing java files: File mode specification error: (file-error "Cannot open load file" "jde-autoload")

Reported by Harald on 2009-12-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xemacs21 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xemacs21

Since I switched to this version of ubuntu:

Description: Ubuntu 9.10
Release: 9.10

the xemacs jde-package does not start properly anymore when editing a Java source file. Whenever I open a Java source file, i.e. extension .java, I get the following error message in the xemacs minibuffer:

File mode specification error: (file-error "Cannot open load file" "jde-autoload").

When I look at show-message-log, there is just this:

Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el...done
Loading 50dictionaries-common...done
Loading 50psvn...
Loading 50psvn...done
Loading guided-tour...
Loading guided-tour...done
Making completion list...
Loading efs-cu...
Loading efs-cu...done
Loading jde...
Loading cus-face...
Loading cus-face...done
Loading arc-mode...
Loading arc-mode...done
File mode specification error: (file-error "Cannot open load file" "jde-autoload"

To make sure I don't mess things up with any personal startup files, I even removed the ~/.xemacs subdirectory.

apt-cache policy xemacs21
xemacs21:
  Installiert: 21.4.22-2ubuntu1
  Kandidat: 21.4.22-2ubuntu1
  Versions-Tabelle:
 *** 21.4.22-2ubuntu1 0
        500 http://172.16.0.5 karmic/universe Packages
        500 http://de.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: amd64
Date: Wed Dec 16 12:10:17 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: xemacs21 21.4.22-2ubuntu1
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 LANGUAGE=de_DE.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-16.52-generic
SourcePackage: xemacs21
Uname: Linux 2.6.31-16-generic x86_64

Harald (harald-kirsch) wrote :
pype (pype-1999-geo) wrote :

also affects Lucid Lynx
xemacs21:
  Installed: 21.4.22-2ubuntu1
  Candidate: 21.4.22-2ubuntu1
  Version table:
 *** 21.4.22-2ubuntu1 0
        500 http://be.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        500 http://fr.archive.ubuntu.com/ubuntu/ lucid/universe Packages

emm (monsler) wrote :

Note: I had this error in 10.04 after doing a dist-upgrade.

I found that the package "jde" was not installed. Since searching for (x)emacs nor java showed the package, it isn't trivial to realize what is missing.

It is semi-unfortunate that the previous java-mode functionality was not preserved when the separate package for jde was added, but I'm willing to believe that it would be technically hard or problematic.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers