*ERROR* EDID checksum is invalid, remainder is 161

Bug #992346 reported by Bryce Harrington
74
This bug affects 24 people
Affects Status Importance Assigned to Milestone
xdiagnose (Ubuntu)
Medium
Bryce Harrington

Bug Description

This computer is connected to its monitor via a VGA KVM. The display looks fine but dmesg is filled with EDID errors:

[ 36.583335] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 161
[ 36.583338] Raw EDID:
[ 36.583341] 10 ff ff ff ff ff ff 00 4d d9 90 11 01 01 01 01
[ 36.583343] 09 0d 21 03 0e 26 1e 8c ea 6f 89 aa 5a 4d 94 24
[ 36.583345] 1a 48 4c a1 08 00 81 80 81 40 01 21 01 01 01 01
[ 36.583347] 01 01 01 01 01 01 30 2a 00 98 51 00 2a 40 30 70
[ 36.583349] 13 00 78 2d 11 00 00 1e 00 00 00 fd 00 37 41 1c
[ 36.583351] 41 0b 40 0a 20 20 20 20 20 24 00 00 00 fc 00 53
[ 36.583353] 44 4d 2d 53 39 35 0a 20 20 20 20 20 00 00 00 ff
[ 36.583354] 00 34 32 35 39 39 31 33 0a 20 20 20 20 20 00 d3

Graphics tends to also break on the system after a while. I think it may occur after switching to and from another system or something but haven't pinned that down.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Apr 30 18:49:57 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.2.0-17-generic-pae, i686: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-19-generic-pae, i686: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-23-generic-pae, i686: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 82G965 Integrated Graphics Controller [8086:29a2] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:514d]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm-256color
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=ab5cf3f2-058f-4f92-afe1-9d4bb7232c8c ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/17/2008
dmi.bios.vendor: Intel Corp.
dmi.bios.version: MQ96510J.86A.1754.2008.1117.0002
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DG965OT
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD63733-205
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrMQ96510J.86A.1754.2008.1117.0002:bd11/17/2008:svn:pn:pvr:rvnIntelCorporation:rnDG965OT:rvrAAD63733-205:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Revision history for this message
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce)
tags: added: quantal
bugbot (bugbot)
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
status: Confirmed → Triaged
importance: Undecided → Medium
Revision history for this message
Bryce Harrington (bryce) wrote :

When I grab the edid via the read-edid package, this is the result:

root@chideok:~# ls -l edid.dat
-rw-r--r-- 1 root root 128 May 31 15:07 edid.dat
root@chideok:~# hexdump edid.dat
0000000 ff00 ffff ffff 00ff d94d 1090 0101 0101
0000010 0d09 0301 260e 8c1e 6fea a289 4d5a 2494
0000020 481a a14c 0008 8081 4081 0101 0101 0101
0000030 0101 0101 0101 2a30 9800 0051 402a 7030
0000040 0013 2d78 0011 1e00 0000 fd00 3700 1c41
0000050 0b41 0a00 2020 2020 2020 0000 fc00 5300
0000060 4d44 532d 3139 200a 2020 2020 0000 ff00
0000070 3400 3532 3939 3331 200a 2020 2020 d300
0000080

Revision history for this message
Bryce Harrington (bryce) wrote :

from xrandr --verbose:

  00ffffffffffff004dd9901001010101
  090d01030e261e8cea6f89a25a4d9424
  1a484ca1080081808140010101010101
  010101010101302a009851002a403070
  1300782d1100001e000000fd0037411c
  410b000a202020202020000000fc0053
  444d2d5339310a2020202020000000ff
  00343235393931330a202020202000d3

Found bug #712075 which has a similar error, although not sure it's the same issue yet.

Revision history for this message
Bryce Harrington (bryce) wrote :

The edid from xrandr and read-edid are identical but alternately inverted.

Note those edids are different from what I posted originally, although it's connected to the same kvm and monitor.

dmesg is returning this edid now:

[166049.859894] 00 ff ff ff ff ff ff 00 4d d9 90 10 01 01 01 01
[166049.859896] 09 0d 01 03 0e 26 1e 8c ea 6f 89 a2 5a 5d 94 24
[166049.859898] 1a 48 4c a1 08 00 81 80 81 40 01 01 03 01 01 01
[166049.859900] 01 01 01 01 11 01 30 2a 00 98 51 00 aa 40 30 70
[166049.859902] 13 00 78 2f 11 00 00 1e 00 00 00 fd 00 37 41 1c
[166049.859904] 41 0b 40 0a 20 20 20 20 20 20 00 00 00 fc 00 53
[166049.859906] 44 4d 2d 53 39 31 0a 20 20 20 20 20 00 00 00 ff
[166049.859907] 00 34 32 35 39 39 31 33 0a 20 20 20 20 20 00 d3

That matches up to the edid from xrandr, but there's some slight differences:

- 090d01030e261e8cea6f89a25a5d9424 # 5 vs 4
+090d01030e261e8cea6f89a25a4d9424
- 1a484ca1080081808140010103010101 # 3 vs 1
+1a484ca1080081808140010101010101
- 010101011101302a00985100aa403070 # a vs 2
+010101010101302a009851002a403070
- 1300782f1100001e000000fd0037411c # f vs d
+1300782d1100001e000000fd0037411c
- 410b400a202020202020000000fc0053 # 4 vs 0
+410b000a202020202020000000fc0053

Revision history for this message
Bryce Harrington (bryce) wrote :

I'm currently on:

Linux chideok.bryceharrington.org 3.2.0-24-generic-pae #39-Ubuntu SMP Mon May 21 18:54:21 UTC 2012 i686 i686 i386 GNU/Linux

If my reading of the EDID hex is correct, the first error (5d vs. 4d) corresponds to the green_x parameter. The others appear to be various pieces of the timings.

Don't know if it's relevant or related but I have been noticing the screen turns a shade of green (or other colors) from time to time, as if it had a loose cable (I've been blaming the cat), however the cables are in their tightly.

Revision history for this message
Bryce Harrington (bryce) wrote :

While a quirk to fix this particular instance may or may not make sense, the larger issue here is the need to be able to override the EDID being reported by the monitor. For this, we need a tool (provided by xdiagnose) to install alternate EDID files in the kernel's /lib/firmware/edid/.

affects: xserver-xorg-video-intel (Ubuntu) → xdiagnose (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 3.4

---------------
xdiagnose (3.4) raring; urgency=low

  * bin/xrotate: Add new script to manually rotate screen and input.
    Designed for the Nexus 7 tablet; will need extended to support other
    devices.
  * bin/xedid: Add new script for viewing and installing EDID files into
    firmware.
    + Fixes situation where EDID is unavailable, corrupted, or invalid
      (LP: #575985)
    + Fixes situation where KVM corrupts the EDID the monitor provides.
      (LP: #992346)
  * bin/xpci: Fix two string issues so xpci will run.
    (LP: #1098390)
  * apport/source_xorg.py: Gracefully skip Xorg.0.log parsing if the
    parsing fails.
    (LP: #1098395)
  * apport/apport-gpu-error-intel.py: Gracefully skip DMI parsing if
    the parsing fails.
    (LP: #1062042)
  * xdiagnose/applet.py: Fix bug where a stray =1 gets added to
    GRUB_CMDLINE_LINUX_DEFAULT.
    (LP: #954123)
  * tests: Add sample Xorg.*.log files rather than using the on-disk one
 -- Bryce Harrington <email address hidden> Wed, 09 Jan 2013 18:17:24 -0800

Changed in xdiagnose (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Chris Wright (dhasenan) wrote :
Download full text (4.5 KiB)

I ran the xedid script but it did not allow me to use the monitor in question. (I have an irun ZT-SH270QHD.)

get-edid says:
get-edid: get-edid version 2.0.0

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
 Function supported
 Call successful

 VBE version 300
 VBE string at 0x11100 "NVIDIA"

VBE/DDC service about to be called
 Report DDC capabilities

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
 Function supported
 Call successful

 Monitor and video card combination does not support DDC1 transfers
 Monitor and video card combination supports DDC2 transfers
 0 seconds per 128 byte EDID block transfer
 Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
 Read EDID

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
 Function supported
 Call failed

The EDID data should not be trusted as the VBE call failed
EDID claims 255 more blocks left
EDID blocks left is wrong.
Your EDID is probably invalid.

/var/log/Xorg.0.log says:
  552 [ 28.729] (WW) NVIDIA(GPU-0): The EDID read for display device DFP-0 is invalid: the
  553 [ 28.729] (WW) NVIDIA(GPU-0): checksum for EDID version 1 extension is invalid.
  554 [ 28.729] (--) NVIDIA(GPU-0):
  555 [ 28.729] (--) NVIDIA(GPU-0): Raw EDID bytes:
  556 [ 28.729] (--) NVIDIA(GPU-0):
  557 [ 28.729] (--) NVIDIA(GPU-0): 00 ff ff ff ff ff ff 00 04 68 fa 00 00 00 00 00
  558 [ 28.729] (--) NVIDIA(GPU-0): 28 15 01 03 a5 3c 22 78 22 6f b1 a7 55 4c 9e 25
  559 [ 28.729] (--) NVIDIA(GPU-0): 0c 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
  560 [ 28.729] (--) NVIDIA(GPU-0): 01 01 01 01 01 01 56 5e 00 a0 a0 a0 29 50 30 20
  561 [ 28.729] (--) NVIDIA(GPU-0): 35 00 55 50 21 00 00 1a 00 00 00 fc 00 51 48 44
  562 [ 28.729] (--) NVIDIA(GPU-0): 32 37 30 0a 20 20 20 20 20 20 00 00 00 fc 00 51
  563 [ 28.729] (--) NVIDIA(GPU-0): 48 44 32 37 30 0a 20 20 20 20 20 20 00 00 00 fc
  564 [ 28.729] (--) NVIDIA(GPU-0): 00 51 48 44 32 37 30 0a 20 20 20 20 20 20 01 b0
  565 [ 28.729] (--) NVIDIA(GPU-0):
  566 [ 28.729] (--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
  567 [ 28.729] (--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
  568 [ 28.729] (--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
  569 [ 28.729] (--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
  570 [ 28.729] (--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
  571 [ 28.729] (--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers